Do USB-3 hubs need a reboot/reset?

Discussion in 'hardware' started by act8192, Jan 15, 2014.

Thread Status:
Not open for further replies.
  1. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,272
    Trendnet USB-3 hub TU3-H4/A, H/W:v1.1R
    It worked fine on Win7 for about 3 months, and then suddenly, when we plug it into the laptop, it's an unknown device.
    The USB3 port is ok, flash sticks work, little portable external drive works.
    Tried it on XP - it responded just like Win7.
    In their warranty writeup there's not even a phone number nor a web address for contact.
    But as we contemplated going the warranty route, we decided to check the power supply. It's ok, 5v DC.
    When the power cord returned to the hub, the hub now works fine. Sort of like a reboot situation.
    So what made it fail, what made it work?

    I have an 8-yr old usb-2 hub which never did that sort of thing. So I'm worried about the integrity of images and backups going through this hub.
     
Loading...
Thread Status:
Not open for further replies.