DISKPART, BARTPE AND ACRONIS

Discussion in 'Acronis True Image Product Line' started by xkravenx, Feb 14, 2008.

Thread Status:
Not open for further replies.
  1. xkravenx

    xkravenx Registered Member

    Joined:
    Feb 14, 2008
    Posts:
    10
    I am using BartPE to restore an image with Acronis True Image.

    BartPE boots up and launches Diskpart to clean the disk, create new partition and assigns the new volume as the Z: drive.

    The volume is formatted and acronis is launched to restore the image. The issue I am having is the TruImage does something to the disk drive. In some computers it re-assigns the restored drive as C:. Which is exactly what I want...

    But in other computers..it doesn't assign it as anything..and I can't do anything until I reboot the computer.
     
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello xkravenx,

    Thank you for choosing Acronis Disk Backup software

    Could you please describe the situation and your goal in details?
    Please note that in most cases you do not need to format destination hard drive prior to the image restoration. Acronis True Image would do it by itself during restoration process.

    Thank you.
    --
    Michael Levchenko
     
  3. xkravenx

    xkravenx Registered Member

    Joined:
    Feb 14, 2008
    Posts:
    10
    Acronis returns an error message syaing it couldn't get a lock on the hard disk right after using the CLEAN command in diskpart.

    However, I have discovered if you clean, create partition, then clean and create the partition again.. Acronis will work.

    Then after Acronis finishes restoring the image. run diskpart to set the partition active and assign the drive letter.
     
Thread Status:
Not open for further replies.