Difficulty booting TI from USB flash

Discussion in 'Acronis True Image Product Line' started by SmegUp, Jan 14, 2008.

Thread Status:
Not open for further replies.
  1. SmegUp

    SmegUp Registered Member

    Joined:
    Jan 14, 2008
    Posts:
    2
    I am having trouble booting Acronis TrueImage from a flash drive.

    I have tried v10 and 2 versions of v11 (including the current version.)

    My TI11 is a retail copy, with a boot cd. That cd does boot and work correctly. I've used it lots of times.

    I can boot from the flash drive. I've done it for Linux (Knoppix v5.1.1) and for BartPE. (Yes, I know I can use the BartPE plugin for TI11. I may do that. But I'd like to solve this problem anyway.)

    But I can't boot TrueImage from the usb flash drive.

    As soon as the computer tries to boot from the flash drive, I get the following error:

    Starting Acronis Loader...

    Acronis Loader fatal error: Boot drive (partition) not found.
    Press <Enter> to try to boot your OS...


    There is nothing wrong with my MBR or partition, etc. Vista boots fine. As do Knoppix & BartPE from the USB flash drive, as does the TrueImage cd.

    I found a web site that says TI sometimes has problems with flash drives and forgets to the boot loader. The site gives four TI images to put onto the drive. Two based on PEtoUSB and two based on Syslinux. Each in 256m and 512m sizes.

    I tried those and it didn't help.

    I've tried booting from different usb ports. Didn't help.

    When making the recovery media, it gives you the chance to enter some command line paramters. Following some web pages advice, I added acpi=off noacpi That didn't help.



    I'm using a Sandisk 2gig flash drive with the u3 junk removed.

    My latpop is an Acer 5520-5912 with a geForce 7000M. I'm runing Vista.


    I'm wondering if maybe it's the hidden emergency recovery partition that is confusing the USB booted version of TI.

    Acer (like many computer makers), at Microsoft's very strong suggestion, puts a hidden recovery partition onto the drive. This way they don't have to give out a real Vista dvd.

    That hidden partition is the very first partition, and it has a non-standard partition number type.

    That hidden partition doesn't confuse Linux, BartPE, or the TI cd. But maybe when TI11 boots from the USB it gets confused?


    Or maybe that's not even close...

    Maybe it can't handle the USB hardware properly until it fully boots? But even an old Knoppix can do that.


    Any ideas?
     
  2. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    If you're getting the "Acronis Loader" error, then the MBR and the boot sector should be okay. The problem is the loader isn't reading the flashdrive correctly.

    Do you have another flashdrive you can try? Preferably one that never had any "security" or "encryption" software installed on it.

    What format is the flashdrive (FAT or FAT32)?

    Is the partition on the flashdrive a Primary partition? Is it set Active?

    Does the laptop have a "Legacy USB" option? Have you tried it enabled and disabled to see if it makes a difference?

    I don't think the internal hard disk is causing any problems.

    The Linux parameters won't make any difference on the Acronis loader. They only work on the Linux version of TI (or DD) when loaded from the Acronis menu.
     
  3. SmegUp

    SmegUp Registered Member

    Joined:
    Jan 14, 2008
    Posts:
    2
    That would be my opinion too. But from all the messages & pages I've seen about TrueImage booting from a flash drive, the response is often to check the MBR & boot sector & partition.


    Nope. Not any more.

    On 'Black Friday' I got a good deal on a bunch of 2g & 4g flash drives. They are all Sandisk Cruzer micro's.

    I removed the U3 stuff and tested them, and then gave away my 512m & 1g flash drives.

    Once the U3 stuff is removed and it repartitions & reformats the flash drive, it should behave just as if it had never been there.

    (I used the official U3 removal tool, rather than trying to do it myself. So it was done right.)


    FAT. But I'm pretty sure that at some point during my efforts, I've tried FAT32 as well, with no luck.


    In the Acer boot options, it shows up as a USB HDD, rather than a USB-ZIP or USB-Key or USB-Floppy, etc. etc.


    I don't know. I would assume Primary & Active, since I can boot Linux & BartPE.


    Nope. Acer systems come pretty bare in the BIOS options area. I'm lucky they even let me choose what I want booted...


    I don't either, really. But that's the only unusual thing I can think of that might cause a problem.

    The only real reason I included that idea was that the error message was saying it couldn't find the boot drive partition. It's probably meaning the USB stuff, but on the off chance it meant my C: drive, I thought I'd include that part about the hidden Acer partition.


    I didn't figure it would either. It's not getting that far.

    But I wanted to try them just to make sure, and mention it so nobody would bother telling me to try them.
     
  4. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello SmegUp,

    Thank you for choosing Acronis Disk Backup Software.

    Please make sure that the partition on the flash drive is marked as "Primary, Active" after the creation of Acronis Bootable Rescue Media on the drive.

    If the issue persists, please submit a request for technical support with the subject indicating that you want to contact Marat Setdikov. Attach all the information to your request along with the step-by-step description of the actions taken before the problem appears and the link to this thread. We will investigate the problem and try to provide you with a solution.

    Thank you.
    --
    Marat Setdikov
     
  5. teo

    teo Registered Member

    Joined:
    Jan 18, 2008
    Posts:
    1
    I also had issues creating USB bootable sticks with A 9.1 Workstation.
    I was able to create a good bootable stick by using 'syslinux -ma G:' (or whatever your drive letter is) and after that using Acronis media builder. I also use the HP format utility you can find at www.pendrivelinux.com. The stick I used is SanDisk Cruzer Titanium 2GB. I format FAT32. It works even if you don't remove the U3 garbage. I also tested this on a SanDisk cruzer 256 MB and works the same. Looks like Acronis does not properly make the MBR, the partition or activate the partition.
    Maybe this will help you.
    Acronis guys should look at syslinux code and fix their product. Looks like syslinux works on most USB drives.
    Cheers,
    Teo
     
    Last edited: Jan 18, 2008
Thread Status:
Not open for further replies.