Desperately need some help to restore an image

Discussion in 'Acronis True Image Product Line' started by Luminous, Aug 31, 2004.

Thread Status:
Not open for further replies.
  1. Luminous

    Luminous Registered Member

    Joined:
    Aug 31, 2004
    Posts:
    38
    Hi. This message is quite long as I have tried to be as specific as possible. I really am struggling to get this machine to work. You will really make my day if you can help me fix this. Thanks, in advance.

    I purchased both True Image 8 and Disk Director Suite 9 over this weekend. I made an image of my machine for emergency use in the future, and now need to use it. One of my HDD's died which corrupted my OS. For some reason when I restore the image, my machine refuses to boot. I must confess to have not read the manual as yet, and my only copy of the software is on a data partition on my sick machine..... :( (I have made emergency boot CDs for both pieces of software)

    Here are the specifics, so that hopefully you can help me out.

    I have 2 HDD's in my machine. One of them was solely used for data, and that is now toast - totally and utterly dead. It has been removed from the machine. The other HDD had 2 installs of XP Pro SP2. One was an old install that had far too many free programs installed and was starting to go wrong. The other was a nice fresh install of Windows that I was slowly configuring to perfection.

    Using True Image I made a copy of my progress to date with the fresh install on a network drive. At the point that this was made, the fresh install was the second partition on the primary HDD. The first partition on the primary HDD was the old XP system. I had installed the OS Boot selector to allow my to choose which OS to boot.

    When my second drive failed it managed to corrupt the first partition on the primary drive. I therefore deleted this partition, and tried to move the fresh install partition to the beginning of the HDD. Unfortunately, during this process the machine crashed as there was temporary loss of power.

    This corrupted both OS partitions. I made a freshly formatted NTFS primary partition of 10Gb. I then expanded the data partition to take the rest of the drive. The 10Gb partition was then ready to accept the network image that I had made.

    I booted the machine with the True Image CD, told it to restore the freshly configured copy of XP Pro SP2 to the first partition over the network. I verified that the image was not corrupt, and the operation was carried out without error. Brilliant.....err no.... When I restarted the machine I get the following error:

    “Windows could not start because the following file is missing or corrupt:
    <Windows root>\system32\hal.dll
    Please re-install a copy of this file”

    I think that this error has something to do with the fact that the partition this image was made from was the 2nd one on the HDD. I have played around with multi-boot systems before with Partition Magic and occasionally got this error. I used to be able to fix it by booting the machine with the XP CD, going to the recovery console and fixing both the MBR and Boot sector.

    I tried the above method, but it just broke everything. So I went back into True Image and have re-copied the image file to the first partition.. The data partition remains intact and ready to use if only the machine would boot.

    The machine is sitting next to be with the error message from above, and I have no idea what to do next. I will be very grateful for any assistance that you can provide.
     
  2. anon

    anon Guest

    The error is due to the number of partitions the machine is expecting.
    The boot.ini file will be pointing the system to load from partition(2) once the boot files on the active partition have been read.
    Suggest create 2 partitions , with the first one v.small (as FAT.)
    Re-deploy image back to 2nd partition
    Run repair disk (mbr etc.) and copy 3 initial loader files onto c: drive- as FAT should be accesable by dos/xp etc. so easy to do

    1) boot.ini 2) ntldr 3) ntdetect.com

    when copied over- on command line c:\ drive ,type 'attrib -h -r -s boot.ini' and edit file
    default and options should contain.(assuming 'd:\windows' is origonal install directory).......

    [boot loader]
    timeout=5
    default=multi(0)disk(0)rdisk(0)partition(2)\windows
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\windows="Windows xxx /fastdetect"
    multi(0)disk(0)rdisk(0)partition(2)\windows="Windows yyy /fastdetect"
    ...........................................................................
    this gives either 1st or 2nd partition boot options

    I'm assuming you retained drives lettering, C: (1st partition- make active) and d:(second partn) when loading new version. problems will be caused if C: and D: used but revert to only one (c:)
    This info is for server but should apply equally to XP
     
  3. Luminous

    Luminous Registered Member

    Joined:
    Aug 31, 2004
    Posts:
    38
    Thank you so much!! You really have done me a great favour today :)

    I did not follow the exact instructions that you suggested, as I knew any easier way (for me) to sort it all out once I understood what had gone wrong.

    You really hit the nail right on the head with the comments about the boot.ini file. I cannot believe that I forgot about that, and that Acronis does not sort it out for you....

    Anyway, my solution was as follows:

    Boot system with Win 98 boot disk (making sure the attrib and edit commands are on it)
    Load NTFS Pro (a program that can mount NTFS partitions in DOS)
    type the following:
    a:\
    attrib c:\boot.ini -s -h -r
    edit c:\boot.ini
    change all entries of partition 2 to partition 1
    save the file
    attrib c:\boot.ini +s +h +r
    reboot

    JOB DONE !! :D :D

    Thanks again, you really have pulled me right out of a mess here.


    Nope, spoke too soon.....

    It boots up showing the windows splash screen, and then just halts on that blue screen just before it would show the welcome screen....

    oh well, back to your suggestion
     
  4. Luminous

    Luminous Registered Member

    Joined:
    Aug 31, 2004
    Posts:
    38
    Nope....

    I think this is day that life just wants to annoy me.

    When I use Acronis Disk Director or True Image it can now no longer detect a HDD.

    Partition Magic also fails to find a HDD....

    Looks like my other HDD has just died................

    I think what we were doing could have worked. Maybe when I get some new hardware I'll have some more luck (and yes they have both just gone out of warranty).
     
Thread Status:
Not open for further replies.