Deletion of old backups failing in Backup Location

Discussion in 'Acronis True Image Product Line' started by beej9, Aug 23, 2007.

Thread Status:
Not open for further replies.
  1. beej9

    beej9 Registered Member

    Joined:
    Aug 23, 2007
    Posts:
    5
    Hi, I hope you can help.

    I have read the ATI manual and all the forum posts on backup locations thoroughly; I am an IT consultant and am quite certain that I have created the backup location and scheduled jobs correctly, yet old backups are not getting deleted - ATI (4942) tries to delete them, but fails with the error "Archive is invalid or its type is unsupported." The archives **_ARE_** valid, proven by ATI Validation succeeding and the fact that I have successfully restored them - once for test purposes, once after my primary HDD failed.

    I run a simple backup scenario: full disk images only, no incrementals or differentials, and only one quota (number of backups).

    I run Windows XP SP2.
    I am backing up to a 2nd internal hard drive.
    I ran CHKDSK /R on the 2nd hard drive and there were no errors.

    Here is what I have tried, for both full disk image and single file folder backups (the latter so I can quickly test settings):
    - delete existing Backup Location
    - uninstall previous build / reboot / clean install Build 4942
    - create Backup Location (only one limit is set: # of Backups = 2)
    - create Scheduled Task (Full Backups ONLY)
    - set Task start time to one minute from now, so it runs via schedule
    - repeat until # of Backups limit is exceeded
    - oldest archive NOT DELETED!
    - check log and see ERROR (Archive is invalid or its type is unsupported.)

    Here is a screenshot of a typical log entry:
    http://www.pcmentoring.com/images/ScreenShot-ArchiveIsInvalid.jpg

    WRT uninstall/reinstall, this post refers to a confounded registry. When I uninstalled, I simply used Add/Remove Programs in Control Panel, I did not regedit and manually delete any leftover keys. Might that help?

    Lastly, I emailed Acronis Support the above info (and supporting files per their Support Request Guidelines) and received an insultingly simple response suggesting I watch this movie -- all it does it show you how to create backup locations and set quotas, which I have already done properly, and re-done, and re-done...!! It's as if they did not read my email, just saw the subject and replied with a standardized, baby-formula "solution". Useless!

    Thanks for any help!
     
    Last edited: Aug 23, 2007
  2. shieber

    shieber Registered Member

    Joined:
    Oct 27, 2004
    Posts:
    3,710
    I'm not sure what your specific prob is here but I know that ocassionally, but not often, Managed Backup Locations gets wonky and doesn't observe limits correctly and you need to whup ATI 10 upside the head to get it to behave, and then everything is fine.

    I would save/move the existing tib files to another location using Explorer. Delete the Backup Directory and the related tasks that use it and recreate them. I'd then make a small task using the backup location to test the functioning.

    If that doens't work, then I'd unistall ATI and reinstall after msconfigging everything out of start and services except MS services. Once reinstalled, recreate the Backup Locations and tasks and test. Sounds like a pita but shouldn't take more than about 15 minutes.

    ONce its working correctly, you should be able to copy/move the origianl tib files into the new Backup Location(s) using Explorer.


    Hope that is some help.
     
  3. beej9

    beej9 Registered Member

    Joined:
    Aug 23, 2007
    Posts:
    5
    Thanks shieber for the reply. I now have ATI10 fully-functional - after some hassles (see below) - but I'm still not sure which of the several things I did fixed the problem...

    For closure of this thread:

    Simply deleting and recreating the backup location and jobs did not solve my problem (I had already tried that many times). Similarly, simply uninstalling and reinstalling did not help.

    This time I uninstalled ATI, then deleted all registry keys with "acronis" in them, rebooted, and ran the Build 4942 executable. The install appeared to succeed, but upon opening ATI I got an error about missing modules and was told to reinstall. After a Repair Install failed and then an Install-over failed, I uninstalled and reinstalled successfully, but got the missing modules error again. Then I remembered the SnapAPI driver installation I had done while first trying to solve my problem (the original one about archives not being auto-deleted...). I reran the SnapAPI driver install and now ATI is successfully deleting the oldest archive per whatever backup location quotas I have set! Phew, finally.

    So in summary, despite the reinstall hiccups, I have to presume that the solution was clearing out the registry keys leftover after uninstalling, reinstalling the latest build, then installing the SnapAPI drivers.
     
  4. beej9

    beej9 Registered Member

    Joined:
    Aug 23, 2007
    Posts:
    5
    Re: Auto-deletion of old backups failing in Backup Location

    Follow-up:

    The above "solution" turned out to be incomplete. File/folder backups were successfully auto-deleted, but disk image archive were NOT getting deleted.

    ATI10 Build 4942 was identifying that the Backup Location quota had been exceeded, it tried to delete the oldest archive, but failed. I continued to get the error message "Archive is invalid or its type is unsupported".

    I submitted a support request to Acronis (with log file and system report) and after a couple generic and unhelpful responses, they identified the problem as my using a password on the archives. This is a known bug. (Per Acronis: "This is a well known issue. Our Development Team is working on it and the fix will be available in the nearest future.")

    I removed the archive password from my scheduled jobs and the Default Options, and now the oldest archive is successfully deleted when my Backup Location quota is exceeded.

    I hope this help some others avoid wasting WEEKS on this issue. For a "well-known" bug, I could not find this solution anywhere else.
     
  5. aussiegtc

    aussiegtc Registered Member

    Joined:
    Oct 18, 2006
    Posts:
    23
    Thank you! You have saved me MUCH frustration.

    Turned off passwords and the files are now deleted as they should be - even on a network drive.

    Excellent - although as you say - very frustrating when you can't find the answer!
     
  6. beej9

    beej9 Registered Member

    Joined:
    Aug 23, 2007
    Posts:
    5
    I am happy my problems helped someone else.
     
Thread Status:
Not open for further replies.