CyberGhost and LastPass

Discussion in 'privacy technology' started by Victek, Feb 15, 2014.

Thread Status:
Not open for further replies.
  1. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,121
    Location:
    USA
    I'm based in the US and using CyberGhost VPN, connecting to their US based servers. When I log into LastPass though I'm getting a warning about country authorization. LastPass perceives the login as originating from Romania. I understand that CyberGhost is based in Romania, but since I'm not using a server in Romania why would I see this issue?
     
  2. dogbite

    dogbite Registered Member

    Joined:
    Dec 13, 2012
    Posts:
    1,166
    Location:
    EU
    Maybe you have a DNS leak and your DNS's are in Romania....just a wild guess.
    Check it here:

    http://ipleak.net/
     
  3. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,121
    Location:
    USA
    Thanks, that was it! I found a setting in the CyberGhost UI that was forcing their DNS servers. Disabling it solved the problem.
     
  4. Taliscicero

    Taliscicero Registered Member

    Joined:
    Feb 7, 2008
    Posts:
    1,439
    I hope you know your actually creating a "DNS Leak" which is actually the opposite of a good thing.
     
  5. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,028
    Yes, indeed!

    Specify one of the DNS servers from http://www.wikileaks.org/wiki/Alternative_DNS.
     
  6. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,121
    Location:
    USA
    Please say more...
     
  7. Taliscicero

    Taliscicero Registered Member

    Joined:
    Feb 7, 2008
    Posts:
    1,439
    DNS leaks destroy the anonymity of your VPN software, if your DNS is leaking there is little benefit to using a VPN.

    Your ISP will see all your DNS "Website" requests regardless of the fact your being tunneled through CyberGhost. Mirimir posted a link to "alt" DNS services, if you want to appear from the US without creating a leak you can use one of those DNS servers like OpenNIC which are based in the USA which stops your ISP getting your website requests.

    (http://www.howtogeek.com/167533/the-ultimate-guide-to-changing-your-dns-server/)

    You want the "Windows – Control Panel" section guide.

    You can check to see if it worked at (https://www.grc.com/dns/dns.htm).

    CyberGhost changes your DNS for a reason.

    (https://airvpn.org/topic/9289-dns-leaks-and-how-to-fix-them/)
     
  8. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,121
    Location:
    USA
    Thanks for the explanation and links. I use the VPN on my laptop primarily for security over open Wifi in coffee shops, etc, and I'm not very concerned about what those ISPs can see. I was concerned though when I logged into LastPass the first time after I started using CyberGhost and received a country authorization warning. Now I understand that the DNS servers are separate and Lastpass was reacting to their location in Romania. Still my preference would be to not authorize LastPass to accept logins from any country other than the one I'm in, so if possible I want to set a couple of US based DNS servers in CyberGhost. I'll try adding them to the VPN adapter and see if they stick. If that doesn't work I'll try changing the servers on the fly with DNS Jumper - very cool little utility that :thumb:
     
  9. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,121
    Location:
    USA
    So, I tried to use US based servers in the CyberGhost TAP Adapter and couldn't get a functional connection. What does work OK is to allow CyberGhost to initially connect using its own DNS and then use DNS Jumper to switch to US based DNS servers (which solves the problem with LastPass thinking I'm in a different country). Since the DNS of the ISP isn't being used it seems to avoid a leak - any additional thoughts about this? TIA
     
  10. Taliscicero

    Taliscicero Registered Member

    Joined:
    Feb 7, 2008
    Posts:
    1,439
    You don't use it in the TAP-v9, you change the DNS of the main adapter you connect to the internet on. Your computer will then default to using it and you wont have to change it every time.
     
  11. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,121
    Location:
    USA
    I already use a different DNS in the main adapter IPv4 settings, such as OpenDNS, however that's a different matter. When the VPN is enabled the DNS servers change. By default CyberGhost uses servers in Poland and Switzerland (according to ipleak.net). Those DNS servers can only be changed in the TAP-v9 adapter.
     
  12. Taliscicero

    Taliscicero Registered Member

    Joined:
    Feb 7, 2008
    Posts:
    1,439
    When in doubt you can always try disabling the DNS change in the cyberghost VPN menu. You can then change the DNS in all of your adapters on your system to the same US based DNS server. I think what's happening is cyberghost is changing them back, or something else is. Changing then all and disabling cyberghost DNS and doing this should fix your problems :)
     
  13. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,121
    Location:
    USA
    Yes, after experimenting a little more I confirmed this does work. My thanks to everyone who responded here :thumb:
     
Loading...
Thread Status:
Not open for further replies.