Crash with long EULAs

Discussion in 'EULAlyzer Forum' started by cantoris, Sep 14, 2005.

Thread Status:
Not open for further replies.
  1. cantoris

    cantoris Registered Member

    Joined:
    Apr 3, 2005
    Posts:
    4
    Hi!

    What a cool idea for a piece of software!
    It seems it doesn't like long EULAs. I tried to paste the info from this site into it and when you then tell it to Analyze it crashes with "Run-Time Error '0'":
    http://www.sms.ac/HomePage/termsandcons.aspx
    Although not strictly an EULA it is very similar sort of nonsense to what you get in one.
    I tried pasting "just" points 11 to 22 of it instead but it still crashed. Then I gave it just points 1 to 5 and it was happy with those.

    Perhaps the app can be formally expanded in the future to deal with some of these sorts of "Terms and Conditions" things too?

    Best wishes,

    Andrew
     
  2. javacool

    javacool BrightFort Moderator

    Joined:
    Feb 10, 2002
    Posts:
    3,997
    Hi,

    Thanks for the heads-up. This will be fixed in version 1.1. :)

    (And just an FYI - the length actually isn't what's causing it.)

    Best regards,

    -Javacool
     
Thread Status:
Not open for further replies.