Configuring private firewall

Discussion in 'other firewalls' started by Overkill, Nov 19, 2013.

Thread Status:
Not open for further replies.
  1. Overkill

    Overkill Registered Member

    Joined:
    Mar 16, 2012
    Posts:
    2,134
    Location:
    USA
    I want to try private firewall but I've never used it with utorrent and was wondering how to configure it to allow utorrent traffic and should I click on "allow" for all my security apps?
     
  2. NSG001

    NSG001 Registered Member

    Joined:
    Jul 14, 2006
    Posts:
    617
    Location:
    Wembley, London
    Not used Utorrent with PFW but..
    Some general reading for you HERE and HERE

    I am sure someone here will be able to provide that utorrent info.
     
  3. Overkill

    Overkill Registered Member

    Joined:
    Mar 16, 2012
    Posts:
    2,134
    Location:
    USA
    Thanks, "Local Network Site set to "Untrusted"" can't find this setting o_O
    All my security apps and other software that I trust I have set to allow in process monitor hopefully this is ok to do.
    I have utorrent allowed under applications (internet) but no other special rules and it seems to be working fine, if anyone knows of other tweaks please let me know.
     
  4. Sm3K3R

    Sm3K3R Registered Member

    Joined:
    Feb 29, 2008
    Posts:
    494
    Add an application rule in which you allow inbound and outbound port sets.5 rules with DNS:2 inbound 3 outbound.Try without service ports first.
     
  5. Overkill

    Overkill Registered Member

    Joined:
    Mar 16, 2012
    Posts:
    2,134
    Location:
    USA
    I'm not quite following, screens would be great if possible:oops:
     
  6. Sm3K3R

    Sm3K3R Registered Member

    Joined:
    Feb 29, 2008
    Posts:
    494
    Having in mind i have removed Private firewall i can help you a little with no screens.I hope i remember properly ,but you can post some screens though.

    In the applications tab create a new ruleset for your executable.
    Inside that you will create (more than 5 though : ) ):

    !.DNS rule -> Allow Outbound /Specific IP-s(add the DNS IP-s here) or High /Low for any DNS server /UDP/ local ports 1024-65535 /remote only 53
    The DNS IP-s specifically set may be ignored ,the firewall seems to ignore IP-s you set here randomly ,but the ports specified seems to be taken into account.Uncheck High Low if IP-s are specified and see how the rule works.

    1.Allow Outbound for Low /High /UDP/ local ports 1024-65535 /remote 1024-65535
    2.Allow Outbound for Low/High /TCP/local 1024-65535 /remote 1024-65535
    3.Allow Inbound for Low/High / UDP/local 1024-65535 /remote 1024-65535
    4.Allow Inbound for Low/High /TCP /local 1024-65535 /remote 1024-65535
    5.Allow a TCP rule for Outbound with the ports used by the application specifically like you have for ApexDC++ the 410-413 for example ,or another rule for remote port 80 and so on ,UNLESS you just set a TCP rule with all ports allowed remotely and local for Outbound.The inbound TCP rule may not be needed ,test see if the program works without it.This may allow remote control to your machine

    After making this , the ruleset may not work though ,so you will have to check the other 2 TABS with generic rules you find in the first section of the firewall ,where you will see the rules you ve created unchecked sometimes ,thus not working.

    At the end of the rules i have suggested you can close with rules that block the rest to avoid pop-ups.Experiment yourself.
     
  7. Overkill

    Overkill Registered Member

    Joined:
    Mar 16, 2012
    Posts:
    2,134
    Location:
    USA
    I will fiddle with it here soon...another problem i'm having is whenever I send a file from this pc to another one on my network, the file is blocked from working so I can't use it o_O

    BTW here's the existing rules for utorrent
    http://i.imgur.com/2f2dOeJ.png
    and rules window
    http://i.imgur.com/bwzNvaH.png
     
    Last edited: Nov 24, 2013
  8. Sm3K3R

    Sm3K3R Registered Member

    Joined:
    Feb 29, 2008
    Posts:
    494
    The picture doesnt load fully in first case ,but it s a strange 5351 rule there as a more generic rule exists.
    You can try the full range of ports if it doesnt work properly 0-65535 ranges but you expose yourself.
    Test and play with the settings.
     
  9. Overkill

    Overkill Registered Member

    Joined:
    Mar 16, 2012
    Posts:
    2,134
    Location:
    USA
    That's all the rules that are in the window, it loaded
    Thanks will play with them
     
Loading...
Thread Status:
Not open for further replies.