Computers will see neither one another nor workgroup on LAN

Discussion in 'Other ESET Home Products' started by tunesmanca, May 7, 2010.

Thread Status:
Not open for further replies.
  1. tunesmanca

    tunesmanca Registered Member

    Joined:
    May 7, 2010
    Posts:
    2
    I have been pulling my hair out trying to get ESET Smart Security to work consistently with the computers on my LAN. Two desktops and one laptop are wireless; my main computer is hard wired to the SMC Barricade SWC20804WBRP-G router.

    At varying times, I get frequent error messages on any or all of the computers that the workgroup is not available or a particular computer is not available; this happens all the time with the one that is cable connected to the router. When I disable the firewall component of ESET the network runs flawlessly. This is telling me that it is not likely a Windows problem

    I have unticked under Intrusion Detection ARP and DNS poisoning attacks as per ESET's recommendations. This has not solved the problem.

    It does appear that I am missing some settings somewhere; the firewall is set to allow sharing. I have also tried adding the two way UDP rule on port 137-139 to no avail. That has helped for a while sometimes but not consistently.

    If someone has some idea as to what I might be missing, please let me know. I do love this program a lot but it is of no use to me if I can't see my computers on my network.

    Thanks a lot for your help.
     
  2. Jenee

    Jenee Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    185
    Do you have the latest version installed on all PCs. (4.2.40)
    Make sure you have Personal Firewall set to interactive mode.
    Add the following rule to allow netbios in the trusted zone (local network):

    Under Advanced Options go to Personal Firewall and select to add a new rule under the heading "Rules with no application assigned".
    The direction should be both and Action should be allow. Go to the remote tab and click on zone and then add trusted zone.
    When you have ok'd the new rule it should look like this:
    Rule Name: Local Netbios
    General: Direction: Both Action: Allow Protocol: TCP UDP Profile: For Every
    Remote Side: Zone: Trusted Zone
    For every port
    Local side: For all

    This rule has to be added to all PCs. You also have to tick everything under Advanced Options - Personal Firewall - IDS and Advanced Options (although allowing incoming streams from the internet via the IGMP protocol does not have to be ticked.

    Then restart all the PCs.
     
  3. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
  4. tunesmanca

    tunesmanca Registered Member

    Joined:
    May 7, 2010
    Posts:
    2
    We have resolution!!! Thank you ever so much Jenee and Cudni. Everything now works as it should.

    I have actually learned what I was doing wrong. I did implement such a rule before (got the advice from another forum) but did not assign it to the Trusted Zone. It by default went to the Internet Zone instead.

    I knew there had to be a simple answer somewhere. Thanks again; you folks rock.
     
  5. tanstaafl

    tanstaafl Registered Member

    Joined:
    Apr 8, 2005
    Posts:
    207
    Yikes! Glad you resolved that one, that was a huge security snafu...
     
Thread Status:
Not open for further replies.