Command line /log switch

Discussion in 'NOD32 version 2 Forum' started by Proactive Services, Jun 26, 2007.

Thread Status:
Not open for further replies.
  1. Proactive Services

    Proactive Services Registered Member

    Joined:
    Jan 10, 2006
    Posts:
    153
    Location:
    Petersfield, Hampshire, UK
    When running NOD32 from the command line, I can't seem to be able to specify a log file path name with spaces in it.

    For example:
    nod32.exe /log=C:\nod32log.txt C:\test.txt
    Works OK, but:

    nod32.exe /log=C:\"nod32 log.txt" C:\test.txt
    ...and...
    nod32.exe /log=C:\nod32 log.txt C:\test.txt
    ...don't work. This means I can't give NOD32 a user's %temp% directory as a log file, as it has spaces in the directory structure.
     
  2. infosecpodcast

    infosecpodcast Registered Member

    Joined:
    Sep 17, 2006
    Posts:
    2
    Location:
    Newmarket, NH
    Can you pass the %username% variable instead of the actual username with the space?
     
  3. Proactive Services

    Proactive Services Registered Member

    Joined:
    Jan 10, 2006
    Posts:
    153
    Location:
    Petersfield, Hampshire, UK
    No, as the spaces in "Documents and Settings" mean it fails, whether using quotes or not, environment variables or not. It looks like the program isn't parsing quotes in the the /log switch correctly.
     
  4. CarlB

    CarlB Former Eset Employee

    Joined:
    May 17, 2007
    Posts:
    37
    Perhaps you could use the truncated 11 character filename scheme in your command line?

    For example, nod32.exe /log=c:\DOCUME~1\%username% etc
     
  5. Megachip

    Megachip Registered Member

    Joined:
    Dec 4, 2006
    Posts:
    243
    why want to have spaces in logfilenameo_O
     
Thread Status:
Not open for further replies.