chx-i + starcraft

Discussion in 'other firewalls' started by ghost2003, Jan 26, 2006.

Thread Status:
Not open for further replies.
  1. ghost2003

    ghost2003 Registered Member

    Joined:
    Aug 10, 2004
    Posts:
    13
    I have a small problem with my chx-i rules. When I make a starcraft server people can only join when I turn off chx-i. Usualy it works without changing anything in my router and any other firewall works without any special configuration so I thought it was odd.
    So I went to make a rule to allow inbound connections to local port 6112 UDP from anywhere and any port (although I think it is all from 6112 too). I checked with port explorer and its the only port from the program that is listning.
    BTW, all outbound is allowed.
     
  2. Alphalutra1

    Alphalutra1 Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    1,160
    Location:
    127.0.0.0/255.0.0.0
    Why don't you go to the website of the game(starcraft). Then look for an faq or something that will say which ports need to be opened. Then just create packet filter rules that force allow these ports open and thus bypass the spi. Turn off these filters when you are not gaming.

    Alphalutra1
     
  3. ghost2003

    ghost2003 Registered Member

    Joined:
    Aug 10, 2004
    Posts:
    13
    Changing the rule from "allow" to "force allow" worked perfectly. Thanks!
     
  4. Alphalutra1

    Alphalutra1 Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    1,160
    Location:
    127.0.0.0/255.0.0.0
    Glad to here that :D

    Alphalutra1
     
Thread Status:
Not open for further replies.