chx-i.and stealthing ports

Discussion in 'other firewalls' started by CLEARICE01, Jul 2, 2005.

Thread Status:
Not open for further replies.
  1. CLEARICE01

    CLEARICE01 Registered Member

    Joined:
    Feb 19, 2004
    Posts:
    63
    Location:
    TRONTO CANADA
    after hearing so meany good things about chx-i.i thought i would give it a try.after installing. i did a shields up test and all ports are closed exept for 135.and 445.are open.how can i stealth all ports ? o_O o_O
     
  2. Jazzie1

    Jazzie1 Registered Member

    Joined:
    Dec 5, 2003
    Posts:
    174
    Hi, what filters are you using with CHX-I? Plus, if you go to 'Packet Filter'(Global) and Local interface and right click on it and select properties:
    Deny all incomming fragmented packets+Deny TCP packets containing CWR,ECE Flags+Enable TCP Stateful Inspection. And then the bottom two UDP and ICMP psuedo options... You can download the sample filters from IDRCI

    Regards
    Jazzie
     
  3. Jaws

    Jaws Registered Member

    Joined:
    Apr 4, 2005
    Posts:
    210
    Hi Clearice,

    Having myself been testing out CHX recently. And I got all stealth ports when I did shields up test.

    I installed the 2.6 filters and the BIND_PE_Filters from HERE on the network interface in CHX. Both of these filter sets are on this page. I then deleted out unused (for me) and duplicate filters. Also did what Jazzie said, but he/she beat me to it.

    Then go HERE and executed these programs. DCOMbob.exe, shootthemessenger.exe, socketlock.exe, sockettome.exe, unpnp.exe.

    Regards,

    Jaws
     
    Last edited: Jul 2, 2005
  4. CLEARICE01

    CLEARICE01 Registered Member

    Joined:
    Feb 19, 2004
    Posts:
    63
    Location:
    TRONTO CANADA
    thanks for the instructions.Jazzie1.and thanks for the links.Jaws.iam stealthed thanks to your help.i love this forum... :D
     
  5. CLEARICE01

    CLEARICE01 Registered Member

    Joined:
    Feb 19, 2004
    Posts:
    63
    Location:
    TRONTO CANADA
    i should of said in my first post that i use edonkey.iam stealthed but now i cant connect to edonkey.the tcp port is 10300.and the udp.port is 10301.does eny one know how i can configure chx-i to connect to these ports. o_O
     
  6. DRI

    DRI Guest

    Just make two inbound rules (TCP & UDP) from any source ip, source port =10300 (TCP) 10301 (UDP) to your ip and destination port=1024-5000


    Cherrs
    DRI
     
  7. Jaws

    Jaws Registered Member

    Joined:
    Apr 4, 2005
    Posts:
    210
    Clearice, I had similar problem going to my modem test page (192.168.100.1) because of a deny filter. What I did was to create a new filter with a force allow rule to open up that IP address.

    You can do the same by right clicking on your network interface and selecting new. Name your filter, force allow, select the protocol and click the check box for source/destination port and type in the port you need. Make one for each protocol.

    I know nothing about edonkey so I don't know if you need them on the inbound or outbound direction. Experiment a little. You can always disable or delete the filter and start over.

    Good Luck,

    Jaws
     
  8. CLEARICE01

    CLEARICE01 Registered Member

    Joined:
    Feb 19, 2004
    Posts:
    63
    Location:
    TRONTO CANADA
    its not working,this is what i have.discription.force allow,type. filter.action type.force allow.priority,3high.discription. incoming,sorce port. any.destination ip.mine.protocol. tcp the other udp.source port,10300.the other 10301.destination port 1024-5000
     
    Last edited: Jul 2, 2005
  9. DRI

    DRI Guest

  10. CLEARICE01

    CLEARICE01 Registered Member

    Joined:
    Feb 19, 2004
    Posts:
    63
    Location:
    TRONTO CANADA
    hi.DRI.iam using edonkey.lite.the tcp and udp ports are 10300 and 10301 by default.and i cant find a log with eny thing being blocked
     
  11. Jaws

    Jaws Registered Member

    Joined:
    Apr 4, 2005
    Posts:
    210
    OK I went to edonkey site and read their requirements for connections. Try this:

    filter descripion ---- edonkey TCP
    filter action type ---- force allow
    priority ---- 3 high
    packets direction ---- incoming
    protocol ---- TCP

    packets source --- IP - any
    source port --- equal to: 10300

    packets destination --- IP - any
    destination --- any

    Then do the same for UDP.

    filter descripion ---- edonkey UDP
    filter action type ---- force allow
    priority ---- 3 high
    packets direction ---- incoming
    protocol ---- UDP

    packets source --- IP - any
    source port --- equal to: 10301

    packets destination --- IP - any
    destination --- any

    Hope this helps.

    Jaws
     
  12. Jaws

    Jaws Registered Member

    Joined:
    Apr 4, 2005
    Posts:
    210
    Hi DRI,

    Looks like we're both working in the dark with edonkey. Hope someone comes along that knows about edonkey and CHX to help out.

    Regards,

    Jaws
     
  13. CLEARICE01

    CLEARICE01 Registered Member

    Joined:
    Feb 19, 2004
    Posts:
    63
    Location:
    TRONTO CANADA
    hi.Jaws.i tryed three times to be sure it didn;t work.i want to thank every one that has helped out so far.i hope some one that uses chx-i and edonkey comes along soon.thanks again...
     
  14. Jaws

    Jaws Registered Member

    Joined:
    Apr 4, 2005
    Posts:
    210
    Clearice, I'm wondering if you have to enable FTP in interface properties.

    In the right hand column in CHX's manage console right click on network interface then click on properties.

    You'll be in the interface properties popup. Put check marks in the incoming and outgoing boxes for active and passive FTP. All 4 boxes. I hope you didn't delete the filters I posted for you to use. You'll still need to open up those ports.

    Don't give up, CHX is worth it. HTH

    Jaws
     
    Last edited: Jul 2, 2005
  15. Jaws

    Jaws Registered Member

    Joined:
    Apr 4, 2005
    Posts:
    210
    I would also delete any packet filter logs (you do have logging turned on I hope) that are present. Then when you're ready, log in to edonkey. If it's being blocked by a filter it should get logged in and may give you a clue as to what is stopping you.

    Regards,

    Jaws
     
  16. dholiday

    dholiday Registered Member

    Joined:
    Nov 4, 2004
    Posts:
    48
    This thread is welcomed. Why? CHX-I questions. Just my two cents.
     
  17. CLEARICE01

    CLEARICE01 Registered Member

    Joined:
    Feb 19, 2004
    Posts:
    63
    Location:
    TRONTO CANADA
    hi.Jaws.checked off the four active and passive FTP boxes.and deleted the log file.but i still can't connect to edonkey.in the log file port 10301 doesn't match allow policy.and i don't see enything for port 10300.ive tryed every thing that was suggested and ive been playing around but still no luck. o_O o_O
     
  18. Jaws

    Jaws Registered Member

    Joined:
    Apr 4, 2005
    Posts:
    210
    Hi Clearice,

    A couple more suggestions and then I'll have to turn it over to someone that's more familiar with edonkey. Perhaps Diver will be along to answer your problem since he uses emule and bitorrent which I think are similar to edonkey.

    Try switching around the filter I suggested to set the ports on the packets destination instead of packets source. Double check edonkey > options > network to make sure you're using the right ports.

    Maybe you have to make an outbound filters?? You can double click on the filter that's stopping, which will take you to the rule, and disable it if you have to get on edonkey.

    Sorry I can't be more helpful.

    Jaws
     
  19. Jazzie1

    Jazzie1 Registered Member

    Joined:
    Dec 5, 2003
    Posts:
    174
    Hi all! I never used Edonkey (do Not like anything you have to give server rights/access to)I decided to install it, just to find out the problem you were having, why it wouldn't connect. Found that you have to allow those specific ports inbound and outbound. So yes, two seperate rules are needed. Plus if you use the bit torrent plug-in, then you have to assign a rule for it as well. And another for the tracker... I for one use MIRC which uses one port (well one other for a file download) but that's it, no server access. If you still want to use edonkey.lite then make inbound and outbound rules for tcp and udp on the ports that DRI and Jaws suggested.............

    Regards
    Jazzie
     
  20. CLEARICE01

    CLEARICE01 Registered Member

    Joined:
    Feb 19, 2004
    Posts:
    63
    Location:
    TRONTO CANADA
    hi.Jaws.i just want to thank you again for all your help.ok i set the ports on the packets destination instead of packets source.and now i can connect.but i only show 2 servers with 0 users and 0 files.i also made a out bound rule as suggested by Jazzie1
     
Loading...
Thread Status:
Not open for further replies.