Chkdsk always runs when booting disk.

Discussion in 'Paragon Drive Backup Product Line' started by lunalobo, Nov 3, 2009.

Thread Status:
Not open for further replies.
  1. lunalobo

    lunalobo Registered Member

    Joined:
    Oct 13, 2009
    Posts:
    10
    I have just backed up my disk c: partition to e:
    I boot on c:
    Every time I boot my system Windows XP complains that I needs to check e:
    It does so with no errors. Takes 5 - 10 minutes.
    The next time I boot it is the same and chkdsk requests to check e:
    Why and How do I stop it?
     
  2. SIW2

    SIW2 Registered Member

    Joined:
    Sep 6, 2009
    Posts:
    1,572
    To remove the Chkdsk.exe or Autochk.exe from the list of scheduled tasks. http://support.microsoft.com/kb/831426

    1. Click Start>All Programs>Accessories>System Tools>Scheduled Tasks.

    2. Click either Chkdsk or Autochk in the list of scheduled tasks.

    3. Under Folder Tasks, click Delete this item.




    To Check the Session Manager registry entry


    Serious problems might occur if you modify the registry incorrectly.

    Therefore, make sure that you follow these steps carefully. Please back up the registry before you modify it.

    How to back up and restore the registry - MS KB:322756 ( http://support.microsoft.com/kb/322756/ )


    Follow these steps, and then quit Registry Editor:

    1. Click Start, click Run, type regedit, and then click OK.

    2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\BootExecute

    3. On the Edit menu, click Modify.

    4. Type autocheck autochk *, and then press ENTER.

    Hope it helps.
     
  3. lunalobo

    lunalobo Registered Member

    Joined:
    Oct 13, 2009
    Posts:
    10
    Sorry, no.

    I don't just want to remove the symptoms. I wanted to know why chkdsk is kicking in. It didn't before when I backed up a disk.
    Something is triggering the chkdsk but it is not resolving it as it seems to be a false alarm. That is, what ever is triggering the request, is not being reset.
    What could the back up software not do, so that windows thinks that the backup disk is still not set up correctly. And will think so every time it is mounted or looked at by windows as the original disk is being booted (c: - see original message).
    There must be some indication, a flag, or something that tells windows to check this disk. Is it something to do with the mbr on that disk.
    It is not complaining about the booted and original disk.

    Just removing chkdsk could put my system in an unchecked state when chkdsk is needed.

    The regedit entry already exists.
     
    Last edited: Nov 3, 2009
  4. SIW2

    SIW2 Registered Member

    Joined:
    Sep 6, 2009
    Posts:
    1,572
    Hi,

    I don't believe that is a Paragon problem - it is certainly a known Windows glitch.

    Did you check in Scheduled Tasks? There may well be a glitch there.

    The fix doesn't remove checkdisk - it just resets it/Task Scheduler to where it should be. It should have done that itself - not uncommon for it to get confused.

    Sometimes it is the other way round and it won't run at boot when it is scheduled. To prove it is a windows glitch - the issue persists in Vista and ( as far as I know in 7 ) - with no Paragon programs in sight - this tutorial covers chkdsk not running when it should - and trying to run when it shouldn't.

    http://www.vistax64.com/tutorials/130824-chkdsk-will-not-run-startup-vista.html

    Hope it helps
     
    Last edited: Nov 3, 2009
  5. lunalobo

    lunalobo Registered Member

    Joined:
    Oct 13, 2009
    Posts:
    10
    I have resolved the problem.
    In XP Chkdsk/autochk runs if the dirty flag is set on the partition. Which it was.
    To check if it is set, in a cmd window type:
    >fsutil dirty query e:
    This will show whether the dirty bit is set or not on partition e:

    My problem was the dirty flag on the partition wasn't being reset.
    Chkdsk doesnt do this.

    looking at ms notes. I disabled all start-up programs in mscofig and then in a cmd window typed
    >chkdsk /x /f e: for drive e: which sets up to checkdisk e: at boot time. But this time apparently the disk is unmounted and remounted, this should reset the flag, and I suppose there is not a boot process stopping this happening.
    booted and CHKDSK ran.
    rebooted and I found the dirty flag was reset. Now the system boots with out chkdsk running. Obviously re-enabled the boot processes to run again at boot.
    see - http://www.infocellar.com/winxp/chkdsk-and-autochk.htm
    look at the section - What if the Dirty Bit won't go away ??
     
  6. SIW2

    SIW2 Registered Member

    Joined:
    Sep 6, 2009
    Posts:
    1,572
    Glad you fixed it. It is an odd windows issue - been around a long time.
     
Loading...
Thread Status:
Not open for further replies.