changing grub resolution

Discussion in 'all things UNIX' started by cet, Aug 25, 2012.

Thread Status:
Not open for further replies.
  1. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    I bought a new monitor and it is working fine,but every time I am at the grub screen the monitor tries to fine tune and adjusts itself,if I open the monitor after the grub screen nothing is adjusted and I see the display.I think I have to change the grub screen resolution.I found this :
    Step 1: find the preferred mode

    Reboot and press and hold shift to display your grub. Press C to enter console mode.

    Type vbeinfo

    this will display various stuff how grub recognises your display. At the bottom is "preferred mode" - in your case it should say 1200x800. Note down the value.

    Note: sometimes, some buggy video cards incorrectly give Grub the wrong preferred resolution - if the preferred mode is much higher than you were expecting, then select the nearest mode in the list displayed that you were expecting.

    Press ESC to return to grub and press Enter to boot.

    Step 2: Setting the resolution in grub

    Reach for your terminal and type

    sudo nano /etc/default/grub
    find the line

    #GRUB_GFXMODE=640x480

    remove the # and change 640x480 for the preferred mode you wrote down.

    e.g. GRUB_GFXMODE=1200x800

    save, then type

    sudo update-grub

    I tried vbeinfo and it says the preferred mode is 1366x768 which is the resolution I use.So is it safe to change the grub as suggested.Sorry I have never edited anything for grub and I am afraid to break somethings.Please tell me if it is safe so I can change the grub screen resolution.
     
  2. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
  3. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    Thanks,I changed the resolution and it is fine now.But every time I boot up the computer and turn on the screen ,the monitor adjusts from 1 to 100 at the grub screen.Strange.
     
  4. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    I am not sure what you mean. Do you mean the time out ? If so set it to 10 secs. GRUB_TIMEOUT="10" in /etc/default/grub
     
  5. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    It is not about grub,it is about the monitor.I see the monitor adjusting auto lines from 1 to 100. 1IIIIIIIIIII........100 like this.
     
Loading...
Thread Status:
Not open for further replies.