Change proxy settings

Discussion in 'ESET NOD32 Antivirus' started by pbt, Oct 20, 2011.

Thread Status:
Not open for further replies.
  1. pbt

    pbt Registered Member

    Joined:
    Oct 20, 2011
    Posts:
    1
    Hi, I have several users with notebooks that go in and out of office regularly. When they are at the office they use a proxy server with auth (squid) to get Internet access, when they go outside they disable the proxy in their browsers. Problem is, they cannot alter the proxy settings for EAV because they use limited Windows accounts (non-admin), so in one of the two cases they cannot get upgrades. Is there a way for them to change these settings or make the settings follow what is configured at the browser (proxy/no proxy), so that they can get updates either in or out the office?

    Thanks

    Pablo
     
  2. MattJN

    MattJN Former ESET Support Rep

    Joined:
    Feb 19, 2010
    Posts:
    149
    Hello Pablo,

    Thanks for your input. To best accomplish your goal, you will want to set up a dual update profile for the notebooks. This will let them use one profile when internal to the network (including the proxy settings), then fail over to the 2nd profile when outside the network. Again, when modifying the internal mirror update profile, make sure you include the proxy settings it will need.

    Hope that helps.

    Thanks,

    Matt
     
  3. Kitesurfer

    Kitesurfer Registered Member

    Joined:
    Apr 15, 2010
    Posts:
    4
    Hi Matt and Pablo,

    I have the same issue and would like to assure you that Matt's solution doesn't actually work as expected. I have tried in vain to convince ESET support of this issue, but so far have had no luck.

    Whilst the "failover" mechanism does work, it seems to ignore the proxy settings in the profile and continues to use whatever proxy settings you have selected in Advanced Setup -> Update -> Selected Profile.

    I have tried this every way:

    1) Select proxied profile in advanced setup. Select proxied profile as primary, non-proxied profile as secondary in update scheduler: WORKS

    2) Select proxied profile in advanced setup. Select non-proxied profile as primary, proxied profile as secondary in update scheduler: FAILS

    3) Select non-proxied profile in advanced setup. Select proxied profile as primary, non-proxied profile as secondary in update scheduler: FAILS

    4) Select non-proxied profile in advanced setup. Select non-proxied profile as primary, proxied profile as secondary in update scheduler: WORKS

    So, in summary, I must always manually select the profile that matches my current connection configuration in advanced setup if I want update scheduler to work.

    Update Scheduler only works when your selected profile in advanced setup matches your current physical connection state. Failover is only useful for trying different update servers, NOT different proxy configurations.
     
  4. Kitesurfer

    Kitesurfer Registered Member

    Joined:
    Apr 15, 2010
    Posts:
    4
    On re-reading my post above, I think it's even more simple:

    Your selected profile in advanced setup MUST match your current physical connection state (i.e. PROXY/PROXY or NO-PROXY/NO-PROXY). If it doesn't, then no matter what proxy settings are in your primary and secondary update profiles, updates will fail.
     
Thread Status:
Not open for further replies.