Can't update Spywareblaster...

Discussion in 'SpywareBlaster & Other Forum' started by TexasT, Sep 26, 2007.

Thread Status:
Not open for further replies.
  1. TexasT

    TexasT Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    10
    Location:
    Texas
    I am having trouble manuelly downloading the update for Spywareblaster. This is my first time using the program.
    I am running the program as an admin on Vista. I get the below message;

    Run-time error '339':

    Component 'MSINET.OCX' or one of its dependencies not correctly
    registered: a file is missing or invalid.

    Can anyone please give me any advise?

    Thanks,
    Michael
     
  2. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
  3. TexasT

    TexasT Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    10
    Location:
    Texas
    Thanks for the quick response...:)

    I downloaded the installer file and went through the install procedure, but I still get the same message when trying to update. I think I did it right.

    I used the missingfilesetup application from the post.

    I am confused about the first way to excecute the two files. Should the step I took work?

    Thanks,
    Michael
     
  4. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    Heres what you do: extract the files from msinet.cab into the same folder, right-click on MSINET.INF and select Install.

    If that doesnt work, try these instructions:

    1.) Browse to your SpywareBlaster directory (usually C:\Program Files\SpywareBlaster).
    2.) Delete the "sbdatabase.dtb", "ckdatabase.dtb" and "sbinfo.dtb" files.
    3.) Run SpywareBlaster (press "NO" when it asks you to download updates because the files are missing.)
    4.) Press the settings button and check the item "Use Alternative Download Method". Save the Settings.
    5.) Now Check for Updates and see if it works correctly.
     
  5. TexasT

    TexasT Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    10
    Location:
    Texas
    I uninstalled and re-installed the program and tried everything again. After I delete the three
    files as you instructed, the program gives an error page and does not work.

    I attached a screenshot of the program screen, I think.

    Spyguard will not work either...

    Any suggestions,
    Michael
     

    Attached Files:

  6. TexasT

    TexasT Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    10
    Location:
    Texas
    Sorry, I forgot to tell you that I checked and MSINET.OCX is located in the Windows\System32\ folder.

    Thanks,
    Michael
     
  7. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    Have you done steps 4 and 5?
     
  8. TexasT

    TexasT Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    10
    Location:
    Texas
    After the three file deletions and running SpywareBlaster, I am not asked to download updates,
    and I can not locate the option to the settings button that you mention and locate the
    'Use Alternative Download Method' and to save the settings.

    Sorry for my ignorance, but where is the "settings" feature?

    Thanks,
    Michael
     
  9. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    I think its the Options tab in the Updates section.
     
  10. TexasT

    TexasT Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    10
    Location:
    Texas
    Hello, and thanks for your continued support...

    I have tried all possible features and can not access any options for updates.

    When clicking on either of the update buttons, I get the first screen I mentioned.

    I get the same screen when trying to update Spyguard.

    Thanks again,
    Michael
     
  11. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
  12. TexasT

    TexasT Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    10
    Location:
    Texas
    Hello again,

    Downloaded and installed vbrun60sp5.exe, but updates still will not work.

    I checked and did not see the file in the \System32 folder, if that matters. The install process showed to work.

    I still get the same original message when trying to update either program.

    Thanks again,
    Michael
     
  13. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    I would try an uninstall, make sure there no leftovers whatsoever, then reinstall.
     
  14. TexasT

    TexasT Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    10
    Location:
    Texas
    Hello,

    I did another uninstall/reinstall since my last post. Still does not work.
    I tried with and without deleting the three files.

    Thanks,
    Michael
     
  15. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    Maybe if you uninstall both SpywareBlaster and SpywareGuard and only reinstall SpywareBlaster?

    If that doesnt help, I can only suggest you update manually by downloading the following files and putting them in your SpywareBlaster directory (C:\Program Files\SpywareBlaster by default):

    http://www.javacoolsoftware.com/spywareblaster/sbdatabase.dtb
    http://www.javacoolsoftware.com/spywareblaster/sbdatabase2.dtb
    http://www.javacoolsoftware.com/spywareblaster/sbinfo.dtb
    http://www.javacoolsoftware.com/spywareblaster/ckdatabase.dtb
     
  16. TexasT

    TexasT Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    10
    Location:
    Texas
    Hello,
    The below message is what I get when clicking on each of the links that you provided;

    Whoops! We can't find that page.
    The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.
    Quick Links:
    SpywareBlaster
    Javacool Software Home

    My internet connection was lost when trying again to connect to the mentioned links.

    The only items that I have downloaded lately are from Javacool. My Norton Anti Virus scan yesterday showed an item called Adware.Mirar and Norton website says it must be installed manuelly. Could the Javacool programs added the Adware.Mirar files? Norton detected it and also removed it. I checked all the registry entries Norton's website said in the 'manuel removal instructions' and none existed after Norton had removed the files...over sixty files and items for the toolbar etc.!!!
    A full system scan two days ago did not detect the mentioned Adware.Mirar

    I am still lost as to what to do...

    Thanks,
    Michael
     
  17. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
  18. TexasT

    TexasT Registered Member

    Joined:
    Sep 26, 2007
    Posts:
    10
    Location:
    Texas
    Hello again,

    I downloaded the first three files on the link list you gave me, but the rest of the links only gave plain text info and nothing to download.
    After downloading the three files and replacing them, still same error message.
    I downloaded another copy of the program from MajorGeeks and still same problem.

    Is there anyway Javacool could respond? It seems he would want to know why it does not work?

    Do you know if the program works with Vista Home Premium?

    Thanks,
    Michael
     
  19. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    SpywareBlaster works more or less with Vista. The next version should officially support Vista.

    BTW Ive sent a PM to javacool. Hopefully he'll respond soon.
     
  20. javacool

    javacool BrightFort Moderator

    Joined:
    Feb 10, 2002
    Posts:
    3,997
    Hi,

    I'm afraid that I haven't been able to reproduce this issue when using the current version of SpywareBlaster (3.5.1) with Vista.

    As another troubleshooting step, could you please try extracting the MSINET.OCX file as described in one of WSFuser's earlier posts - but this time, place it in your C:\Program Files\SpywareBlaster directory (or wherever you installed SpywareBlaster). Please let me know if the error message is resolved after doing this, or if the text of the error message changes at all. :)

    Best regards and thanks,

    -Javacool
     
Loading...
Thread Status:
Not open for further replies.