Can't save settings "common to all users" ?

Discussion in 'LnS English Forum' started by JeanJean, Nov 25, 2009.

Thread Status:
Not open for further replies.
  1. JeanJean

    JeanJean Registered Member

    Joined:
    May 29, 2008
    Posts:
    5
    Hello All,

    I am with Windows 7 64bits using LNS 2.07 ;-) my favorite firewall in the world (and OS so far too)

    Only problem is the option to save the looknstop settings for all users is disabled; I can only save for current user it seems.

    In Windows I have my very secure little Admin users settings and I have a guest user for friends, my guests can allow anything through LookNStop and compromise my security :-(

    Why is this option disabled?

    See the attached screenshot to see what I mean

    Thanks for any clues
     

    Attached Files:

  2. JeanJean

    JeanJean Registered Member

    Joined:
    May 29, 2008
    Posts:
    5
    Up !

    Any ideas how to enable the settings for all users on the computer?

    Thx
     
  3. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    1,732
    i guess you have to change that with admin rights...
     
  4. JeanJean

    JeanJean Registered Member

    Joined:
    May 29, 2008
    Posts:
    5
    Thanks !!!!

    How simple yet I didn't think about it, as I am admin user already, I tend to forget that apps don't run with admin rights.

    I closed look n stop and restarted it with "Run as Admin" and the settings were enabled.

    Cool
    Thanks again
     
  5. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    1,732
    i am as admin too here - but i have that normal (not grayed). strange...
    UAC? Is off here due constant setting up the system (main OS is still XP)
     
  6. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hello JeanJean and Brummelchen,

    These options are greyed for Vista and Win7, because for these OS it is not possible to read/write into [HKLM] registry key (except if the application is executed "As Admin").

    If you change the option (by running "as Admin"), you need to ensure Look 'n' Stop is started systematically that way, otherwise it will not work.
    Then another problem occurs (at least with UAC enabled) because it is not possible (still under Vista/Win7) to have Look 'n' Stop automatically started at Windows start-up.

    Regards,

    Frederic
     
Thread Status:
Not open for further replies.