Can't Receive From Punkbuster

Discussion in 'ESET Smart Security' started by stabgotham, Mar 3, 2010.

Thread Status:
Not open for further replies.
  1. stabgotham

    stabgotham Registered Member

    Joined:
    Mar 3, 2010
    Posts:
    3
    Hello!

    I have been trying to get Punkbuster to work with Smart Security for hours. I can't figure out what I am missing. Everytime I run the punkbuster service test, both PnkBstrA and PnkBstrB are unable to receive. I can send out just fine.

    I have rules created to allow both services to send and receive on any port, but still can't receive. What am I missing??
     
  2. Rmuffler

    Rmuffler Former Eset Moderator

    Joined:
    Jun 26, 2008
    Posts:
    995
    Location:
    San Diego, CA USA
  3. stabgotham

    stabgotham Registered Member

    Joined:
    Mar 3, 2010
    Posts:
    3
    I did, but in the local tab, I added the Punkbuster service applications:

    PnkBstrA.exe
    PnkBstrB.exe

    Still no dice, can't receive. If I turn the firewall off, everything works perfect.
     
  4. timid

    timid Registered Member

    Joined:
    Mar 3, 2010
    Posts:
    22
    Try to delete created rules for PunkBuster, and turn the Firewall mode to Interactive mode, then run the test and Eset personall firewall should show you a pop up window in which you can enable/block the connection.

    Try to enable the requesting connections and see the result.

    Also try to check the Firewall log in the Logs - in ESS, what does the log file say?
     
  5. stabgotham

    stabgotham Registered Member

    Joined:
    Mar 3, 2010
    Posts:
    3
    Tried that. Still didn't work. PB can communicate out, but still not in. The logs show a ton of the following:

    "Incorrect IP packet checksum"

    I don't know what that means though.
     
  6. RED_404

    RED_404 Registered Member

    Joined:
    Mar 5, 2010
    Posts:
    5
    I get the same with eset ss 4.2 Windows 7 x64

    the only way I can find to fix it is uncheck the eset driver in connection settings or uninstall eset disableing the firewall don't help
    you can see the the problem win you install the pb service with pbsvc.exe

    Fail with eset firewall Enabled or Disabled
    Code:
    Checking OS
      Windows NT 6.1 (build 7600) 64-bit
    Checking PnkBstrA service status   RUNNING
    Checking PnkBstrA Version          OK (1032)
    Extracting "PnkBstrB.exe" to:
       "C:\Users\Red\AppData\Roaming\PnkBstrB.exe"
                                       OK
    Checking firewall settings         OFF
    Checking if PnkBstrB is running    NOT RUNNING
    Getting port for PnkBstrA          OK (44301)
    Opening socket for packet send     OK
    Sending version packet to PnkBstrA SENT
    Receiving version from PnkBstrA    TIMEOUT
    Getting PnkBstrB install instance  NOT FOUND
    Sending start packet to PnkBstrA   SENT
    Waiting for packet from PnkBstrA   TIMEOUT
    Watching for PnkBstrB instance change (0) TIMEOUT
    Getting port for PnkBstrB          FAILED
    Sending version packet to PnkBstrB SENT
    Receiving version from PnkBstrB    TIMEOUT
    Checking PnkBstrK driver status    NOT FOUND
    Manually stopping PnkBstrB         FAILED - no handle
    Removing test PnkBstrB file        OK
    Good after unchecking eset in the connection settings or uninstalling eset
    Code:
    Starting PunkBuster Service Tests (v0.987) (03/05/10 03:51:35)
    Checking OS
      Windows NT 6.1 (build 7600) 64-bit
    Checking PnkBstrA service status   RUNNING
    Checking PnkBstrA Version          OK (1032)
    Extracting "PnkBstrB.exe" to:
       "C:\Users\Red\AppData\Roaming\PnkBstrB.exe"
                                       OK
    Checking firewall settings         OFF
    Checking if PnkBstrB is running    RUNNING
    Manually stopping PnkBstrB         STOPPED
    Getting port for PnkBstrA          OK (44301)
    Opening socket for packet send     OK
    Sending version packet to PnkBstrA SENT
    Receiving version from PnkBstrA    OK
    Received 6 bytes from 127.0.0.1:44301
      Response = 8221 (ms) Version = v1032
    Getting PnkBstrB install instance  OK
    Sending start packet to PnkBstrA   SENT
    Waiting for packet from PnkBstrA   OK
    Received 3 bytes from 127.0.0.1:44301
      Response = 12230 (ms) PnkBstrB started.
      Load SUCCESSFUL.
    Watching for PnkBstrB instance change (1) CHANGED (2)
    Getting port for PnkBstrB          OK (45301)
    Sending version packet to PnkBstrB SENT
    Receiving version from PnkBstrB    
     
  7. STRYDER

    STRYDER Registered Member

    Joined:
    Aug 21, 2008
    Posts:
    99
    Any word on how to fix this?
     
Thread Status:
Not open for further replies.