Can't Auto-delete previous backups

Discussion in 'Acronis True Image Product Line' started by John Grove, Jan 26, 2009.

Thread Status:
Not open for further replies.
  1. John Grove

    John Grove Registered Member

    Joined:
    Jan 26, 2009
    Posts:
    7
    All I want to do is to have the following...

    1. Weekly FULL backup.
    2. Daily INCREMENTAL backup.
    3. Auto deletion of oldest backups when disk is full.

    I know Vlad has given instructions elsewhere on how we might get Acronis Home Image 2009, CD version to automatically delete previous backups...but I'm afraid it doesn't work here!!

    In the step-by-step instructions on this version you cannot set the number of backups before consolidation to less than "1".

    Following Vlad's instructions, here's the sequence of settings I have in creating a new backup...

    (Required Steps)

    1. Create new backup task.
    2. Data type - My Computer. (next)
    3. Source selection - partitions to back up. (next)
    4. Target Archive - Create new backup archive. (next)
    5. Options - Scheduling (next)
    6. Backup method - Incremental (recommended) next
    7. Files to exclude - have left untouched (next)
    8. Backup options - these settings are not relevant to problem (next)
    9. Automatic Consolidation - I cannot set backups to "0" as suggested.

    It's not much to ask, is it? ;)

    grovesey.
     
  2. shieber

    shieber Registered Member

    Joined:
    Oct 27, 2004
    Posts:
    3,710
    Are yuo using the English version?

    Have you tired it using the Windows version (ATI installed on hdisk) instead of the linux version that's on the bootCD?
     
  3. John Grove

    John Grove Registered Member

    Joined:
    Jan 26, 2009
    Posts:
    7
    Yes, I am using the English version, and since downloading the latest build (via advice on another thread here) I am now able to follow Vlad's instructions. Whether it will enable me to do auto-deletions is another matter :cool:

    grovesey.
     
  4. Vlad V

    Vlad V Registered Member

    Joined:
    Dec 17, 2008
    Posts:
    61
    Hello,
    You've misundrestood my recommendations. They refer to autodeleting the oldest backup when making only full backups. To make only full backups, it's necessary to set "0" in the fileld under "Create a new full backup after" box at the "Backup method" step and not at the "Consolidation" step. At the "Consolidation" step you set the desired number of full backups to keep at all times. E.g. set "3" when you want to keep 3 full backups. In such a case after ATI makes the 4th beckup, it will delete the oldest one.
    If you want to make a weekly full backup and daily incrementals, and then delete the oldest backups when the disk is full, the latest version (9709) now provides such an ability when storing backups in ASZ. Acronis added "When not enough space in ASZ delete the oldest archive" box to "Error handling" item in "Default backup options". So you can create on your backup disk ASZ with a size you want and make backups there. When the zone is full, the program will delete the oldest backup chain (full+incrementals). BTW, you need not activate Startup Recovery Manager.

    Vlad
     
  5. John Grove

    John Grove Registered Member

    Joined:
    Jan 26, 2009
    Posts:
    7
    Vlad, you're a genius! I don't know what relation you have to Acronis, but they should take note of your clearly-written instructions...

    I had a feeling your original instructions were for FULL backup deletions only. Things only began to make sense having downloaded the most recent build 9709, with additional features.

    Your method for auto deletion of "oldest archives" works very well, although I might have listed it the other way around like so...

    1. Go to "Protection State" on Acronis home page.
    2. Activate the "Acronis Security Zone".
    3. Go to Tools/Options/Default Backup Options/Error Handling.
    4. Check box "When not enough space in ASZ delete the oldest acrchive".

    I ensured that my ASZ is on my separate backup drive - where I used to keep my conventional backups. The ASZ is occupying as much of that disk as possible - Acronis will then delete the oldest archives first to make way for the latest.

    I have set my auto backups for "once a day", creating 10 incremental backups before it creates a FULL backup.

    I don't understand why the conventional backup routine can't do the same, but utilising the Acronis Secure Zone it works well.

    Thanks again for your help Vlad,

    grovesey.
     
  6. Bogene2020

    Bogene2020 Registered Member

    Joined:
    Jul 28, 2008
    Posts:
    22
    Hi,
    I was having this Auto Delete problem with True Image 11 ann a USB wd drive .. Is this problem fixed in 2009 Edition .
    Basically will I be able to run a full backup and then daily incrementals and have True Image delete lth older backups when the external USB drive is full ..
    Thanks
     
  7. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello Bogene2020,

    Thank you for your interest in Acronis True Image

    You can set automatic consolidation and limit maximum archive size.

    After creating a backup the program checks the archive for quota violations, such as exceeding a pre-set maximum number of gigabytes set aside for backups and, if any limitation is exceeded, consolidates the oldest backups.

    Thank you.

    --

    Oleg Lee
     
  8. Bogene2020

    Bogene2020 Registered Member

    Joined:
    Jul 28, 2008
    Posts:
    22
    Thanks, where do I go to set the Archive Size ?
     
  9. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello Bogene2020,

    Thank you for your interesting in Acronis True Image

    You can set archive size from Automatic Consolidation tab while creating the backup. Look through user guide chapter concerning Automatic Consolidation for more details.

    Best regards,
    --
    Dmitry Nikolaev
     
Thread Status:
Not open for further replies.