Cannot Update Prevx Online

Discussion in 'Prevx Releases' started by Scoobs72, May 12, 2010.

Thread Status:
Not open for further replies.
  1. Scoobs72

    Scoobs72 Registered Member

    Joined:
    Jul 16, 2007
    Posts:
    1,108
    Location:
    Sofa (left side)
    Hmmm...I'm having the same problem I had the last time there was an update:

    - Click "Check for Updates"
    - Pop-up saying "There is a new.....". I click "Yes" to update
    - I get a dialog box in the bottom right corner saying "Download complete, installing Prevx"...and at the same time another saying "Prevx Update Failed. Please try again later"

    Previously I had to download the full version from Prevx.com and manually update. Any ideas on a solution?
     
  2. pling_man

    pling_man Registered Member

    Joined:
    Feb 11, 2010
    Posts:
    463
    Location:
    UK
    I have the same problem. Don't wait 'till later! It doesn't work.

    This is a known problem with standard user accounts on Vista or Windows 7. Its been an issue for the last several releases (RC or Official). That's why you saw it before.

    PrevxHelp/Joe says they hope to have a fix soon.

    A solution for now: You can sign in or fast switch to an admin account to do the update. Then switch back.
     
  3. Scoobs72

    Scoobs72 Registered Member

    Joined:
    Jul 16, 2007
    Posts:
    1,108
    Location:
    Sofa (left side)
    Thanks pling_man. I'm running as admin already, though this was originally a standard user account that I changed to admin. I still have the original admin account, so I'll switch to that and try upgrading
     
  4. pling_man

    pling_man Registered Member

    Joined:
    Feb 11, 2010
    Posts:
    463
    Location:
    UK
    Ok. It could have been a problem if the original install was done when the account was a standard user. It depends on what the issue is but we don't know.

    I think full installs must be done as admin. But update installs (either automatic or clicking check for upates) should work for admin and standard users. At the moment there is a bug in the update installs for standard users.
     
  5. Scoobs72

    Scoobs72 Registered Member

    Joined:
    Jul 16, 2007
    Posts:
    1,108
    Location:
    Sofa (left side)
    I had to log out fully from my main admin account (the one that used to be standard user), log into the old admin account and upgrade from there...which worked. Thanks a lot pling_man.
     
  6. pling_man

    pling_man Registered Member

    Joined:
    Feb 11, 2010
    Posts:
    463
    Location:
    UK
    Great. There's probably a clue here too about the issue for the Prevx team as well. :D

    P.S. For goodness sake change your account back to standard user. Its much more secure.
     
  7. Scoobs72

    Scoobs72 Registered Member

    Joined:
    Jul 16, 2007
    Posts:
    1,108
    Location:
    Sofa (left side)
    I did the original install in the admin account, but subsequent updates from the standard user account. It was only recently (either .127 or .130) that updates in the new admin account stopped working, so something has changed somewhere.
     
  8. pling_man

    pling_man Registered Member

    Joined:
    Feb 11, 2010
    Posts:
    463
    Location:
    UK
    Yes, I agree; it used to work and stopped working at or near .127.
     
  9. Triple Helix

    Triple Helix Webroot Product Advisor

    Joined:
    Nov 20, 2004
    Posts:
    12,011
    Location:
    Ontario, Canada
    See pling_man everyone helps everyone good job with LUA issue! :thumb: You see I always use Admin account because I always know what's happening on my machine and I'm the only one that uses it so I don't have these problems with updates!

    TH
     
  10. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    Thank you for the information, everyone (especially pling_man :)) We're still digging through the LUA/Standard user upgrade support and should hopefully have some more luck reproducing problems with the additional information from this thread :)

    Thanks again!
     
Thread Status:
Not open for further replies.