Cannot stop ping replies when using router

Discussion in 'other firewalls' started by Just Looking, Apr 19, 2006.

Thread Status:
Not open for further replies.
  1. Just Looking

    Just Looking Registered Member

    Joined:
    May 3, 2004
    Posts:
    3
    I have been operating quite happily for a few years running using Sygate Personal Firewall Pro in a WinXP Home SP2 laptop. Just recently I purchased an ethernet router/ADSL modem (PROLiNK 9000P). When I connected the laptop to the internet for the first time and ran the grc.com ShieldsUp test, a great number of ports that were stealthed before turned up closed. In addition, the laptop was responding to pings despite the fact that there is an advanced rule in my rule set prohibiting inbound and outbound ICMP traffic of all types and for all ip addresses and interfaces.

    In the few days since, I was able (thanks to expert advice) to stealth all ports again. However, I am still unable to keep the laptop from responding to incoming pings. I even wrote a new advanced rule (in case the old one was ineffective because at the time of its writing the interface corresponding to the ethernet modem was not in my system yet) but to no avail. Can anyone in this forum help me solve this nasty problem?
     
  2. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    i think you need to block icmp 8 to drop ping replies. it might be icmp 0. look them up and it will be one of them.
     
  3. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Icmp echo(:cool:, ICMP echo reply(0)

    But I should think that it is your router that is making the echo replies. Check your router settings, there should be an option to drop/block wan requests (block anonymous internet request)
     
  4. Alphalutra1

    Alphalutra1 Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    1,160
    Location:
    127.0.0.0/255.0.0.0
    To back up what has been previously stated, your sygate firewall is not the firewall being tested by www.grc.com The router and it's firewalling capabilities are being tested. Ensure that the router is set up properly by going to its web interface, and then going to the firewall section. Ensure that the SPI portion, if it came with one, is turned on. Next, ensure that the options to "Block Anoynymous Internet Requests" or something to that effect is enabled.

    If you want to test your laptop and the Sygate firewall, put your laptop in the DMZ. Be warned however, that your router will still be in charge of handling ICMP, but your laptop will have to filter all TCP,UDP, and other traffic.

    Cheers,

    Alphalutra1
     
Thread Status:
Not open for further replies.