Cannot assi

Discussion in 'Acronis True Image Product Line' started by kvdv, Aug 18, 2006.

Thread Status:
Not open for further replies.
  1. kvdv

    kvdv Registered Member

    Joined:
    Aug 18, 2006
    Posts:
    1
    Cannot assign a drive letter to a partition

    I'm using True Image Workstation 9.1

    I want to mount an archive, but I can only do this in read-only mode.
    When I try read/write mode, i get: "Cannot assign a drive letter to a partition from the backup archive.
    The problem is that i really need read/write because of ntfs security on a specific directory. I need to change the permission/ownership before i can copy it to my local harddisk.

    I hope someone can help me......

    Thanks in advance!
    -Kris
     
    Last edited: Aug 18, 2006
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Re: Cannot assign a drive letter to a partition

    Hello kvdv,

    Thank you for choosing Acronis Workstation Disk Backup Software.

    Please accept our apologies for the delay with the response.

    First of all, please make sure you use the latest build (3718 ) of Acronis True Image 9.1 Workstation. To get access to updates you should first register your software.

    If the issue persists, please validate the image archives using Validate Archive tool (Tool -> Validate Archive) of Acronis True Image.

    If the image archive appears to be consistent, please create a screen shot of the last screen of the Mount Image wizard which contains the operation scenario.

    Please check whether there is an EISA partition in your image archive (generally the service partition on a laptop). If yes, then please select the "Do not mount option" for this partition. If there is no EISA partition, then please run "regedit" command and let me know the data lines of the below registry keys:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318} -> UpperFilters

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{71A27CDD-812A-11D0-BEC7-08002BE2092F} -> UpperFilters

    Could you please also do the following?

    - Download SetupApiLog.zip, unpack it and run in order to add the information to the Windows registry;

    - Delete \Windows\setupapi.log and reboot the computer;

    - Reproduce the problem and collect the setupapi.log file created;

    - Let us know whether there is a delay after hitting Proceed and getting the error message;

    Then submit a request for technical support. Attach all the collected files and information to your request along with the link to this thread. We will investigate the problem and try to provide you with the solution.

    Thank you.
    --
    Aleksandr Isakov
     
  3. Clearline

    Clearline Registered Member

    Joined:
    Aug 27, 2006
    Posts:
    33
    Location:
    Miami FL
    On one of my disks, I have about 8 gbs of freespace there, (partitioned in 3 logical drvs). I use these for client systems for rebuild. TI images are read only by their nature (just like a an iso mounted drv.) With the extra logical drives, I can either "explore" the image and then copy the files of the mounted image over, or can just restore it to one of the drvs set a side for it. Once there you can edit them and then even re-image them (although you will probably lose the active disk flag, not a problem).

    If you are using an XP system, and are running low on drv letters, you can redirect any non-system drive to a folder, and remove the drive letter. I have over 15 different drives mounted that way, that don't use drive letters. TI pays little attention to drive letters, as it shows you what drives are available even if they haven't been formatted.

    I don't know if that handles your access problems, but I would imagine if you copy files to a folder or drive that you have control of, then you should be able to gain control of the files.

    Alternate: copy files to a fat32 formated drive, which should strip out the NT locking attributes.
    or from the cmd line try attrib yourdir\*.* -r -s /S/D .
    * /D removes the attributes from the Folders.
    * there has to be a space btween any attribute cmd (-r -h)
     
Thread Status:
Not open for further replies.