Can scheduled events be delayed?

Discussion in 'NOD32 version 2 Forum' started by bcronin, Apr 10, 2005.

Thread Status:
Not open for further replies.
  1. bcronin

    bcronin Registered Member

    Joined:
    Jun 24, 2004
    Posts:
    105
    Location:
    Hyde Park, NY USA
    I keep all my computers setup so that they sleep after 30 minutes of inactivity (they're all on UPS's so it is a convenient way to have them all be capable of near-instant startup without significant danger of losing any work).

    The problem I am having is that one of the computers is the one that builds the NOD32 mirror for all the others. I have a NOD32 scheduled event on that computer to check for updates/rebuild-the-mirror every hour. If the computer has been sleeping for more than an hour since the last update attempt, whenever I wake it up it tries to go do the update check/rebuild-the-mirror *immediately* upon being woken up and before the network is fully functional. This results in constant failures to rebuild the mirror and I have to intervene manually.

    It seems to me I could avoid this if there were a way I could schedule the event such that it would wait a bit longer before trying to do the update after having been woken up.

    Is there any way I can accomplish this with existing NOD32 functionality? If not, I wonder if Eset might consider providing some way around this difficulty in a future release ...

    Bob Cronin
     
  2. ShunterAlhena

    ShunterAlhena Registered Member

    Joined:
    Aug 1, 2004
    Posts:
    134
    Location:
    Szigethalom, Hungary
    Hello,

    Could you please look at the Scheduler/Planner in NOD32 System Tools?
    It should show you how the mirror update is scheduled. I suppose it says something "hourly, if task fails to run at scheduled time run it ASAP". Edit it to "hourly, if task fails to run at scheduled time wait until next schedule". This way it won't try to update as soon as you wake it up, but wait some time and try then. Should be a workaround ;)

    If you cannot see the mirror update task in the Scheduler, click "NOD32 System Setup/Setup button/Enable display of default system tasks".

    Regards,
    SA
     
  3. bcronin

    bcronin Registered Member

    Joined:
    Jun 24, 2004
    Posts:
    105
    Location:
    Hyde Park, NY USA
    It is already scheduled that way. I think the problem is that it is setup to run hourly. That means that if it has been at least an hour since it last ran, when I wake it back up again the "next scheduled instant" is immediately ... I need a way to tell it to wait a brief interval before trying. One possible workaround might be to schedule the update to take place at specific times (e.g. at 1am, 2am, 3am, 4am, etc.). That way, as long as I did not wake the machine at one of those specific times, it should wait until the next one. But thats cumbersome and annoying. I don't want to have to schedule 24 different events if I can avoid it. I know, I'm a fussy bugger ;-)

    Bob
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Hi Bcronin,
    You should not encounter these problems with the beta anymore so I suggest you give it a try and install it on one machine to see how it goes.
     
  5. anotherjack

    anotherjack Registered Member

    Joined:
    Jun 13, 2003
    Posts:
    224
    Location:
    Louisiana
    ShunterAlhena suggested changing that to "Wait until the next scheduled time," instead of "As soon as possible." That way, if (for instance) it's scheduled to check at x:00 and you wake it at x:05, it will wait until the next x:00 comes around before checking again.

    Jack
     
  6. bcronin

    bcronin Registered Member

    Joined:
    Jun 24, 2004
    Posts:
    105
    Location:
    Hyde Park, NY USA
    I will try it, thank you.
     
  7. bcronin

    bcronin Registered Member

    Joined:
    Jun 24, 2004
    Posts:
    105
    Location:
    Hyde Park, NY USA
    So I haven't seen any more update failures on the box that I put the beta on, but I have noticed that since I installed it, my PC never goes to sleep anymore (i have it set to go into standby after 30 minutes of inactivity). Ideas? Is there something in the beta that would be causing more "activity" more often so that the inactivity timer in XP would not time out in 30 minutes?

    Bob Cronin
     
  8. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Try setting Early warning system to submit files during update, maybe this is causing it.
     
  9. bcronin

    bcronin Registered Member

    Joined:
    Jun 24, 2004
    Posts:
    105
    Location:
    Hyde Park, NY USA
    That was it. Thanks.
     
Thread Status:
Not open for further replies.