Bug in NOD32 GUI during virus detection with IMON

Discussion in 'NOD32 version 2 Forum' started by Philippe_FR22, Sep 12, 2007.

Thread Status:
Not open for further replies.
  1. Philippe_FR22

    Philippe_FR22 Registered Member

    Joined:
    Sep 6, 2007
    Posts:
    249
    Hello,
    I was testing NOD32 on the last skype threat, based on skype forum post http://forum.skype.com/index.php?showtopic=96634
    In this topic, the dsc027.scr virus is explained and 2 links were given as redirects to download the virus.

    I tried to download (not execute) the virus using "save target as" just to see if NOD32 detect this threat (because I found that Mcafee Viruscan did'nt !!!) and something strange happened. The download process were aborted but no alert windows were displayed by NOD32 GUI. I repeated the same process 4 or 5 times and always the same. No alert, but download process were aborted before the file is completely downloaded. I noticed that the NOD32 icone has disappeared on the system tray (but probably NOD32 protection service was still ok). I decided to reboot the PC (note that the first test was made just after having powered on my PC and windows XP pro were completely loaded) and the second test were ok. Red windows alert as displayed each time I try to save the target file on my PC.

    My config : an old but still very well working PC based on abit KT7, AMD T-bird 800 MHz, 1GB SDRAM, 110 GB Hard disk, Graphic card is GEFORCE 5700 LE, Windows XP pro, Firewall is ZA pro 7 and there are no more applications running at this moment on the PC, except IE 7.0.

    Thank U in advance, if you have some more informations about that strange bug that only concern (a priori) the GUI functionnal entity of NOD32.
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,376
    It looks like nod32kui.exe was not running. This would explain why NOD32 actually blocked it (the kernel service was still running) though no alert window appeared.
     
  3. Philippe_FR22

    Philippe_FR22 Registered Member

    Joined:
    Sep 6, 2007
    Posts:
    249
    Hello,

    Well, It should be... But I remember to have had a look to the list of processes running on the PC and nod32kui.exe was still in the list...

    Another thing : I noticed yersterday just after having starting my PC, and logged as admin, that the NOD32 icon didn't appeared un system tray. Also, nod32kui.exe was in the process list. So I repaired icon cache with TweakUI XP and rebooted the PC. Every thing were OK.

    Note that sometime (not often) my NVIDIA icon does'nt appear in the system tray (setup to show all running application), but for NOD32, it was the very first time.
     
Thread Status:
Not open for further replies.