Bug: Cannot unhide WinXP boot partition.

Discussion in 'Acronis Disk Director Suite' started by walybare, Mar 25, 2006.

Thread Status:
Not open for further replies.
  1. walybare

    walybare Registered Member

    Mar 25, 2006
    1. I have installed Win2k in 1st primary partition (NTFS) of sii3114 raid5 drive array and installed DDS10 - OS Selector is working on this software raid. :-D

    2. I disabled the "Force Hidden" option under the Win2k boot in DDS10.

    3. I create a 2nd primary partition (NTFS) from DDS10 while in Win2k.

    4. I then booted from OS Selector and used it to boot CD WinXP install - setting the Win2k partition hidden (but not forced). WinXP install sees 2nd partition as drive C:, and assigns other drive letters to Win2k - this is OK. Disk C: partition was formatted via the WinXP install but not created by WinXP - this was done in step 3.

    5. Installed WinXP.

    6. After install had to recover the OS Selector boot - I'll omit details here because its not important - basically I just uninstalled and reinstalled OS Selector.

    7. Everything works fine when I set active and hidden partition for Win2k, BUT here is the problem...

    8. For booting WinXP, it is set active in the partition info settings, and I can set other partitions hidden or non-hidden, BUT the WinXP partition is marked hidden and it will not let me unhide it - its grayed out. This is dumb - bootable partition should always be unhidden. No matter what I do OS Selector will not let me unhide it. I can unhide and hide the WinXP partition from the Win2k partition info in OS Selector. So, I've even tried booting into Win2k with the 2nd partition (WinXP) unhidden and then tried to modify the partition info for WinXP. But it still show hidden in the boot select partition info and will not let me unhide it. If you try to boot to WinXP you get windows errors with something to the effect it can't find partition.

    Can we get a fix for this problem?


    PS - If I create a small (less than 100MB) Fat16 primary partion and install OS Selector in it, this problem goes away.

    But it wastes a precious primary partition so we need a fix.
  2. Batfink

    Batfink Registered Member

    Jun 26, 2004
    When Ive had this problem.. I found that removing the folders from the operating system folder properties but do not delete the contents or remove them from the disk.. just remove them from the list.... this should then allow you to unhide/hide them on other os properties.

    I have taken a different and more logical approach when having a multiboot system.. I have only a single 100mb primary partition (c) which contains the boot files, boot ini etc... any os's I install get installed to a logical partition (d)... I can then copy (d) to as many logical partitions I wish, hide them from each other, and boot into any of them... adn they are all clones of the original install...

    This way the boot files can be kept seperate from the OS... you could in theory have the primary botoable c drive, and say 4 logical partitions. When install a new OS, the bootfiles would be updated on C, and then choose another logical partition to install the OS... there is no limit to logical partitions, like primary.. so you caould have alot more. OS Selector can then be installed to C also. The only clever bit you have to do is hide these partitions from each other... which is when I had to do the above method to allow me to hide/unhide certain partitions....
  3. walybare

    walybare Registered Member

    Mar 25, 2006
    Hmmm... So you have one C partition and a bunch of D partitions that contain the operating system. You only have one active D partition and the rest are hidden. Right?

    Well, I though about that before and done it before. But I’ve experienced problems with software that have poor installation routines and tries to install itself to the C: partition when it should install in the D: partition with the OS (in the program folder of course). The worst case was when part of the software installs to C and other part installs to D.

    That also means that I would have to convert all my other disk's primary partitions to logical partitions, because they will probably interfere with disk lettering scheme for the windows OS's.

    At this point I'm not willing to do that because I’ll have to reinstall all my Windows OS’s and all the software. That will take about 2 weeks and I just don’t have that kind of time to spend on it. And, I’m not confident enough in DDS10 that it won’t blow away partitions and data if I try to convert them. It has already blown away my raid 5 partitions twice because of the “Force Hidden” option under Windows 2000. There is no way to recover it because the recovery option is only available for raid 0 not raid 5 – another bug in the software. It takes about 4 hours just to build a raid 5 array – not counting partitioning and formatting.

    Thanks anyways though.
  4. Acronis Support

    Acronis Support Acronis Support Staff

    Apr 28, 2004
    Hello walybare,

    Thank you for choosing Acronis Partition and Disk Managing Software.

    Please accept our apologies for the delay with the response.

    Yes, you are right. Bootable partition cannot be hidden. This is a very strange situation you have described. If you would like to let us to investigate it thoroughly then please create Acronis Report and Windows System Information as it is described in Acronis Help Post and submit a request for technical support. Attach the collected report file and information to your request along with the step-by-step description of the actions taken before the problem appears and the link to this thread. We will investigate the problem and try to provide you with the solution.

    Actually Acronis Disk Director Suite 10.0 supports all levels of RAID arrays and should be able to recover partitions which reside on any RAID configuration. If you have encountered with some errors during the recovering process then please make a screen shot of the error message and attach this screen shot to your request too.

    Thank you.
    Kirill Omelchenko
  5. mjliteman

    mjliteman Registered Member

    Jun 23, 2005
    This has been reported before and the workaround is in my posts in the thread below. Acronis said they were going to fix this in future versions, but have not. Indeed, they provide the solution themselves in the thread but have failed to implement it. I would eagerly await for the full control over my boot options they promised with each new build and each time was disappointed. And since I've not been able to find any kind of changelog for any product/any build of Acronis EVER, I would test out each new build just for this problem. Alas, it seems to have fallen through the cracks. Maybe this fresh thread will bring renewed effort to finally correct the issue.


Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.