Browser leakage

Discussion in 'other firewalls' started by nixie21, Aug 9, 2006.

Thread Status:
Not open for further replies.
  1. nixie21

    nixie21 Registered Member

    Joined:
    Oct 1, 2004
    Posts:
    279
    Re: Comodo firewall

    How do you stop the browser leakage? I did a test at one of the sites and it knew where I had been and suck, how do i stop this with comodo?

    Thanks
     
  2. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Re: Comodo firewall

    This is possibly "referers", which browser do you use?
     
  3. nixie21

    nixie21 Registered Member

    Joined:
    Oct 1, 2004
    Posts:
    279
    Re: Comodo firewall

    I am using firefox....how do i fix it?

    THNAKS
     
  4. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Re: Comodo firewall

    Try this blocker link,(first one) set to block referer, then try your test again, please post back results.

    Stem
     
  5. storm119

    storm119 Registered Member

    Joined:
    Apr 11, 2004
    Posts:
    39
    Location:
    `Land Below The Wind'
    Re: Comodo firewall

    @ nixie21

    (OT)Try this, set it in your user.js (as per-below) or at url bar type about:config and search for * network.http.sendRefererHeader * and set to 1. Once done you need to close/relaunch FF, clear your "private data" via Tools >>> clear private data and try the browser test again ;)

    Code:
    // Sending REFERRER Header 
    // 0=DON'T SEND ANY, 
    // 1=SEND ONLY ON CLICKS, 
    // 2=SEND ON IMAGE REQUESTS AS WELL  
    user_pref("network.http.sendRefererHeader", 1);  // Default is 2

    HTH
     
  6. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    I have split the post, so that full attention/answers can be given.

    Hope this is O.K.
     
  7. nixie21

    nixie21 Registered Member

    Joined:
    Oct 1, 2004
    Posts:
    279
    I installed the extension, and changed the item in about:config

    still got:
    Danger!
    While visiting web sites your browser reveals private information about you and your computer. It sends information about previous sites you have visited. It may also save special cookies on your hard drive that have the purpose of directing advertising or finding out your habits while web surfing.

    Recommendation:
    We advise you to get personal firewall software. If you already have a firewall program adjust it to block the distribution of such information.

    ??

    Thanks for the help!!
     
  8. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Have you checked the "allow sites to set cookies"? in firefox:tools/options/privacy
     
  9. nixie21

    nixie21 Registered Member

    Joined:
    Oct 1, 2004
    Posts:
    279
    yes, for the originating site only is checked.....
     
  10. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    You need to uncheck that (uncheck "allow sites to set cookies"), and make exceptions for only the sites you want to set cookies.
     
  11. nixie21

    nixie21 Registered Member

    Joined:
    Oct 1, 2004
    Posts:
    279
    Thanks!!!!
     
  12. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    please check this, to see if now is O.K.
     
  13. nixie21

    nixie21 Registered Member

    Joined:
    Oct 1, 2004
    Posts:
    279
    Ok, came up with this now:

    The test checked if your web browser reveals any private information while you visit Web sites. Usually such information is: the last site visited, your locale and who your Internet Service Provider is.
    At Risk!

    Attention! Your browser is not private. Privacy is 50%
    While visiting web sites your browser sends information about previous sites you have visited.

    Recommendation:
    Install a personal firewall program. If you already have a firewall, adjust it to block this information.
     
  14. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Which site are you checking with?

    Have you set the privacy options for cookies?(unticked "Allow sites to set cookies") Referer blocker to "block"?
     
  15. nixie21

    nixie21 Registered Member

    Joined:
    Oct 1, 2004
    Posts:
    279
    hackerwhacker..

    I unchecked the cookies and there is no option tab for the no referrer extension?

    Thanks again
     
  16. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Please check:
     

    Attached Files:

  17. Alphalutra1

    Alphalutra1 Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    1,160
    Location:
    127.0.0.0/255.0.0.0
    Also install the noscript extension, then visit the website. I believe that javascript may be the culprit.

    Cheers,

    Alphalutra1
     
  18. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Hackerwhacker needs script enabled or you cannot use the site.
    Most of the sites I have visited that perform browser checks need scripts enabled/allowed.
     
  19. duke1959

    duke1959 Very Frequent Poster

    Joined:
    Jul 21, 2006
    Posts:
    1,238
    I checked in my Firefox Browser 1.5.0.6, and the no referer option isn't anywhere to be seen in Tools. I was just wondering what version this is in, or do you need to add this? Thanks
     
  20. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Yes, this is an extension that needs to be installed. Go to tools / extensions (bottom right of the window that appears, click "get more extensions" This will take you to the "firefox addons" page. In the seach box type "refcontrol".
     
  21. Paranoid2000

    Paranoid2000 Registered Member

    Joined:
    May 2, 2004
    Posts:
    2,839
    Location:
    North West, United Kingdom
    Blocking referers completely is not a good idea since some sites use them and will fail in non-obvious ways (i.e. you won't get any indicator that referers are the cause). Setting the referer to the root URL of the site (e.g. setting it to http://somesite when visiting http://somesite/somepath/somepage.html) is much less likely to cause problems and removes any privacy risks.

    Online tests that fail to recognise spoofed referers and persist in giving warnings about them should be treated as false alarms.
     
  22. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    This should be extended to include "cookies", and may need to be added to FAQ
     
Thread Status:
Not open for further replies.