Boot Sector Virus or HD dead?

Discussion in 'malware problems & news' started by YODA, Nov 8, 2002.

Thread Status:
Not open for further replies.
  1. YODA

    YODA Registered Member

    Joined:
    Jul 15, 2002
    Posts:
    100
    Hey Guys,

    I was wonder if you might know wuts wrong with my hard drive. Umm, when i boot it up it freezes at the beginning where norton tries to do a boot scan, and the hard drive goes no where after that. I've tried to format the drive, but when i stick in a startup disk it won't go to dos either. Could this be a boot sector virus? I think i've also scanned the HD with f-prot for dos, and found nothing. Do you think its a virus or is my HD dead? What other suggestions do u think you might have that i could try.

    btw i'm running win98se...

    YODA
     
  2. snowy

    snowy Guest

    YODA

    Have you tryed to boot in SAFE MODE o_O

    snowman
     
  3. Pieter_Arntz

    Pieter_Arntz Spyware Veteran

    Joined:
    Apr 27, 2002
    Posts:
    13,332
    Location:
    Netherlands
    Have you tried to change the startup order in your BIOS?
    It might still go to C: first.
    When you get to DOS this way you may want to try the command fdisk /mbr first. Since you seem to have given up on the data on your HD already, this will do no more harm and might help.

    Regards,

    Pieter
     
  4. snowy

    snowy Guest

    Yoda

    don't know if this will work on your os..but you can try.


    1) Restart your computer using your emergency start-up disk.

    2) use the arrow key on your keyboard to select: "Start computer without cd-rom support" An then press "enter"

    3) at the prompt type scanreg/fix and then press "enter"


    goodluck

    snowman
     
  5. yodafan

    yodafan Guest

    YAY! i fixed it.... :D

    -Ok this was my problem, my HD would stop once it got to it said :

    Starting Windows 98....
    Loading NAVDX, please wait (then HD stops)

    -Ok... so i try safemode...

    Windows is bypassing your startup files (then HD stops)

    -Now i try to use a Windows 98 Startup Disk and got this:

    Microsoft RAMDrive Version 3.06 virtual Drive F:
    Disk Size:2,048k
    Sector Size:512bytes
    Allocation unit:2 sectors
    Directory entries: 64 (then HD would stop)

    -It wouldn't even go to where it says "A:"

    -I couldn't even format the HD cause it wouldn't even go to the A drive promp... so now i tried to do something else, i went to comand prompt, and it could only located my C drive, lucky i had Ghost installed. So i did a Gdisk and erase the whole disk and partitions, and it got rid of everything. Now everything works fine..... I wonder what was wrong. Do you guys think it was a boot sector virus. Lots of times i find warnings from my AV, after scanning a file it states that the boot records have been changed. Are those boot sector viruses?

    btw i scanned my computer with f-prot for dos and found nothing o_O

    YODA
     
  6. snowy

    snowy Guest

    YODA

    Well isn't that great!! Wonderful job and well done.

    Yoda I am considering dropping off the internet again...if I do...you take good care........wishing you well.


    snowman
     
  7. yodafan

    yodafan Guest

    Snowman,

    You take care man....we will miss ya at wilders.

    BestWishes,
    Yoda
     
  8. Prince_Serendip

    Prince_Serendip Registered Member

    Joined:
    Apr 8, 2002
    Posts:
    819
    Location:
    Canada
    :) Hi YOD@!

    Glad that you found an answer. I'm sure you'll find answers to your other questions too!

    To snowman:
    It's okay snowman if you need to rest. Or is the hardware malfunctioning again? In any event we'll be here when you get back. Thank you for making the effort to be here again. It's been a real treat! ;)

    Best regards to all from Larry! :)
     
  9. controler

    controler Guest

    No,,, the boot sector has nothing to do with your A: drive unless the boot sector of the A: drive was infected also.
    It was mentioned to look at your BIOS.
    If your BIOS was set to look at the A: drive first, you should have been able to boot to the floppy. That is for sure!!!!!!!!!!!!!!!!!!
    Now, if you had a memory resident virus, doing an restore from image would not have fixed a thing.
    Booting with Ghost uses a different version of DOS if I remember right
    Something sounds fishy to say the least
     
  10. yodafan

    yodafan Guest

    Hi controler,

    Ya my bios was configured to start on A drive, then CD drive, then Hard Drive. There was nothing wrong with the floppy or ne other hardware, or even the connections to the hardware.. everything was setup right and in workin condition. I didn't do a restore image, or booting of ghost. I used the command prompt by pressing f8 at boot up, and used the Ghost that was already installed on my hard drive. In ghost, there is a program called Gdisk, that is use to wipe disk. I was able to use gdisk in the command promp, and it wiped out all data and partitions that were on the drive. After that i recreated partitions, format, and reinstalled windows and everything seem to startup fine. But i would like to figure out wut it could of been. Do you guys know would do such a thing?

    YODA
     
Loading...
Thread Status:
Not open for further replies.