block a programs access

Discussion in 'ESET Smart Security' started by winchendonsprings, Mar 27, 2009.

Thread Status:
Not open for further replies.
  1. winchendonsprings

    winchendonsprings Registered Member

    Joined:
    Mar 27, 2009
    Posts:
    8
    what I want to do is block some of my programs access to the internet.

    I cant seem to figure it out.

    I been looking through the firewall settings.

    any help would be great.
     
  2. bodgy

    bodgy Registered Member

    Joined:
    Sep 22, 2005
    Posts:
    2,387
    Location:
    Qld.
    Right click on the system tray icon, choose Advanced Setup
    .

    From the left hand list select Personal Firewall and then Rules and Zones.

    Now, on the right hand panel select Zone and Rule Editor and click the Setup button.

    Click on NEW at the bottom of the panel.

    You will get a new form open titled New Rule.

    Give the rule a name, by default the action is set to Deny for in and out transactions and the protocol to TCP & UDP.

    Click on the Local tab.

    Click Add Port button.

    Select HTTP from the drop down box.

    Click Browse in the next panel down - find your program.

    OK out as normal.

    Colin
     
  3. winchendonsprings

    winchendonsprings Registered Member

    Joined:
    Mar 27, 2009
    Posts:
    8
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Firstly, you'll need to switch the firewall either to automatic mode with exceptions, interactive mode, learning mode or policy-based mode. Afterwards you'll be able to create rules yourself.
     
  5. winchendonsprings

    winchendonsprings Registered Member

    Joined:
    Mar 27, 2009
    Posts:
    8
    ok I have followed your instructions and have the firewall set to interactive mode.

    I have set up rules for some programs.

    When I tested those programs to see if the rules worked, nod32 still asks me if I want to allow or deny the program.

    since I have the rules set why does it still ask me?
     
  6. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Perhaps the rules you created were somehow specific (e.g. limited to certain local/remote ports)? In such case, if the rules don't match the criteria for detected communication, a pop-up window asking you for an action will appear.
     
  7. winchendonsprings

    winchendonsprings Registered Member

    Joined:
    Mar 27, 2009
    Posts:
    8
    ya, the local setting was for one port, but now I just changed the port range from 1 - 10000. Still it gave a allow or deny pop up.

    Is this range not broad enough? Any other ideas?

    oh ya, the other port I was using was 80 specific to http.

    EDIT. ok that was foolish of me the testing program was connecting through ftp not http. I'll test another

    thanks for helping so far
     
    Last edited: Mar 29, 2009
Thread Status:
Not open for further replies.