Bizzare TrueCrypt input/output error. Maybe corrupt but can mount and read files?

Discussion in 'encryption problems' started by EncryptionJack, Sep 30, 2014.

  1. EncryptionJack

    EncryptionJack Registered Member

    Sep 30, 2014
    Hi everyone,

    Thanks in advance for any assistance any one can offer. I have been a viewer of these forums for encryption issues for quite a while and have managed to solve a number of issues myself by browsing through old threads. However, this is the first time I am posting something as I am truly confused now.

    a. Have a external hard drive with multiple partitions.

    b. In each of the partitions there are TrueCrypt encrypted file containers of varying sizes (in the 50-100GB range)

    c. All the file containers are formatted as Mac OS Extended (Journaled)

    d. I am trying to copy all of the information onto a second external hard drive

    1. I am unable to copy three of the file containers onto the other hard drive. If I try copy the full, encrypted container files (eg "", "" and ", I get an error message saying "some of the data can't be read or written".

    2. I am able to mount the encrypted file containers using TrueCrypt. I can see and read/write the data. However, I cannot copy the files out of the encrypted container. I get the same error message as above.

    2. Two of the container files are on one partition, and the other container file is on a different partition.

    3. When mounting the three containers, I am able to successfully mount them, TrueCrypt accepts my password without problem.

    4. I see the disk images load up without issue and can browse and read/write to the mounted volumes.

    5. If I try to copy files out of the mounted volume anywhere (including to itself, just moving it out of the encrypted container), I get a read/write error. See:

    6. By process of elimination, I have managed to copy 90% of the files in each of the encrypted containers, but 10% of the files can still not be copied.

    7. Out of the 10% of the files that cannot be copied, I am able to actually open the files and read the files. Some of them are videos, and I am able to play the full video from start to finish without any problems, however some times it seems like there is a bit of a lag when I jump around.

    Attempted solutions:
    8. I am wondered if the hard drive was failing. Nope, diskutil verify/repair tells me there are no problems with any of the partitions and/or the entire hard disk. Everything is OK.

    9. Ran disk util verify/repair on the mounted file systems when I mount the file containers. TrueCrypt mounts them without problem. Diskutil tells me everything is OK. If you aren't familiar with macs, I ran fsck_hfs -fy, and diskutil verifyVolume

    10. When I try to copy the problem files anywhere, I get the read/write error, or everything freezes, and then truecrypt unmounts my file container without me telling it to do so. When this happens, note that the hard drive is fully accessible, and all the files in the partitions can be accessed. It is only the mounted, encrypted file container that gets unmounted.

    Thank you!
    Any help would be appreciated. I am pretty confused how to copy the specific files inside the three problem file containers. I somehow don't think it is a failing hard drive issue as I have barely used this hard drive and the fact that I can access all of the files when I mount the file container. Perhaps the file system in the file container got damaged somehow? However, the checks do not reveal anything.

    Thanks so much in advance!