avahi-daemon

Discussion in 'all things UNIX' started by cet, Mar 16, 2013.

Thread Status:
Not open for further replies.
  1. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    Everytime I boot-up I get a message that says ''localhost... network discovery service is disabled ...Avahi does not support ".local...'' something like this.I am not using a home network.I want to disable avahi.I found some instructions on a website.Is this safe and the right way to do?
    ht tp://cyberfunda.com/question/how-to-disable-avahi-daemon-in-ubuntu/
     
  2. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    To disable the avahi-daemon from starting on boot, the recommended way is:
    # echo "manual" >> /etc/init/avahi-daemon.override
    The 'override' will override the instruction in the avahi-daemon.conf file (in /etc/init/), the advantage being that the .conf file is not uninstalled.

    (I have to date not seen that message you are getting).
     
  3. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    I am sorry but can you please tell me how to do it.I found the avahi-daemon.conf under etc/init.Am I going to write those lines under the text or do I have to create a new text named avahi-daemon.override and put those text inside?
     
  4. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    Sorry, just enter the command in the terminal ..

    root@ocky-desktop:~# echo manual > /etc/init/avahi-daemon.override
    root@ocky-desktop:~#

    The override file will be created and you can delete it any time you want to revert.
     
  5. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    Thank you very much.I did it and no message at start-up :)
     
  6. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    Arghhhhh I got the messahe again today.This is from my log file:
    ar 17 10:10:18 ceylan-OptiPlex-390 avahi: Avahi disabled itself. If you want to use Avahi in this network, please
    Mar 17 10:10:18 ceylan-OptiPlex-390 avahi: contact your administrator and convince him to use a different DNS domain,
    Mar 17 10:10:18 ceylan-OptiPlex-390 avahi: since .local should be used exclusively for Zeroconf technology.
    Mar 17 10:10:18 ceylan-OptiPlex-390 avahi: For more information, see http://avahi.org/wiki/AvahiAndUnicastDotLocal
    Mar 17 10:10:20 ceylan-OptiPlex-390 goa[1833]: goa-daemon version 3.4.0 starting [main.c:112, main()]
    Mar 17 10:10:25 ceylan-OptiPlex-390 NetworkManager[847]: <info> (eth0): IP6 addrconf timed out or failed.
    Mar 17 10:10:25 ceylan-OptiPlex-390 NetworkManager[847]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
    Mar 17 10:10:25 ceylan-OptiPlex-390 NetworkManager[847]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) started...
    Mar 17 10:10:25 ceylan-OptiPlex-390 NetworkManager[847]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
    Mar 17 10:10:33 ceylan-OptiPlex-390 dbus[810]: [system] Failed to activate service 'org.freedesktop.Avahi': timed out
     
  7. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    See this thread. http://ubuntuforums.org/archive/index.php/t-1482573.html
    (Second last post).
    Looks like adding changing "AVAHI_DAEMON_DETECT_LOCAL=1" to "AVAHI_DAEMON_DETECT_LOCAL=0" in /etc/default/avahi-daemon may solve the problem.

    OR, https://lists.ubuntu.com/archives/foundations-bugs/2012-December/129282.html

     
    Last edited: Mar 17, 2013
Loading...
Thread Status:
Not open for further replies.