Auto update can't be switched off

Discussion in 'NOD32 version 2 Forum' started by x12, Sep 21, 2004.

Thread Status:
Not open for further replies.
  1. x12

    x12 Guest

    I have NOD32 version 2, Windows 2000 multiprocessor, SP4, Netscape 7.1

    This is a LAN server. Internet connection goes through an external router/firewall/NAT.
    In "update", "Automatic update" is disabled. I want to do the updates manually.
    Every time i connect to the internet, a tiny window appears near the clock and it's something about NOD doing an update, despite my settings. I suspect this annoying thing is causing some sort of interference with the routers web interface. The routers webpage freezes. This started to happen after the big update when DMON was added.

    Previously, i was also able to quit NOD and to stop the "NOD32 kernel service" whenever NOD caused trouble. It does that sometimes. For some weird reason, the service can no longer be stopped. I want full control over my computer and i want to be able to start and stop services as i like. Why is the service locked? How to get around this?
     
  2. rumpstah

    rumpstah Registered Member

    Joined:
    Mar 19, 2003
    Posts:
    486
    Due to the concern of many people/organizations, it is now a protected service in lieu of the malware that kills targeted antivirus programs (i.e. Klez).

    In another post by Marcos it was suggested to turn off IMON on a server (which may be causing your issue). I have never done this and have not had any issues on any NT/2000 servers.

    Turning off the HTTP checking may be another alternative.
     
  3. x12

    x12 Guest

    If multiprocessor isn't supported, that means hyperthreading isn't supported either.. If so, a program rewrite is needed.

    In scheduler/planner, there is no "Regular/Automatic update" to untick. Just a log maintenance.

    I never use IE/outlook/WMP/WAB/MSO or similar bad apps, so both IMON and DMON is off. The only thing enabled is AMON.

    I still want the ability to completely switch the NOD service off.
     
  4. rumpstah

    rumpstah Registered Member

    Joined:
    Mar 19, 2003
    Posts:
    486
    Hyperthreading is not exclusive to a multiprocessor system. Hyper-Threading Technology is a form of simultaneous multi-threading technology (SMT) where multiple threads of software applications can be run simultaneously on one processor.

    Setting the affinity of NOD32 to one cpu has fixed the issue with 2.12.2 from "the few" servers with dual processors that have had this issue, which leans me toward another process being the culprit. I agree that this issue should be looked into by support (which I believe they are at this time), but in the mean time the affinity setting may be your "work around".


    Only log maintainence is in the NOD32 System Tools/Scheduler Planner section? Log maintenance is in the NOD32 System Tools/NOD32 System Setup- Log maintenance tab. Makes one wonder if the NOD32 installation is corrupt.

    Have you tried setting the Recovery actions on the NOD32 kernel service? Currently they are all set to restart the service. Let us know if it gives you your desired result.
     
  5. x12

    x12 Guest

    HT acts as 2 processors and is in windows detected as 2 processors. That's why i assumed there would be a problem with a single HT-CPU if there's a problem with multiple real (non-HT) processors.

    Set affinity to nod32kui done. for nod32krn it couldn't be changed.

    Also found a solution to my problem with not being able to stop the krn service. I downloaded "supermgr.exe" (32KB) from ...
    http://www.freewarehome.com/System_Utilities/System_Tools/Task_Managers_t.html
    No problem killing NOD anymore. I can now also set affininty on the krn service.
     
  6. rumpstah

    rumpstah Registered Member

    Joined:
    Mar 19, 2003
    Posts:
    486
    Drop a note here if the affinity helps your issue.

    Nice tip on the killer. ;)

     
  7. x12

    x12 Guest

    AMON setup, tab "security", "Enable instant virus signature update".
    I unchecked that one and have not seen this problem anymore.

    Why is that option there? Why not under "Update" ?

    Setting affinity made no difference at all.
     
Thread Status:
Not open for further replies.