Auslogics BoostSpeed 5.1.0.0

Discussion in 'other software & services' started by Narxis, May 27, 2011.

Thread Status:
Not open for further replies.
  1. Narxis

    Narxis Registered Member

    Joined:
    Jun 10, 2009
    Posts:
    477
    5.1.0.0 (25/05/2011)

    Changelog:
    added support for Internet Explore r 9, FireFox 4 and the latest versions of Chrome, Safari and Opera browsers
    improved support of all previous versions of the browsers
    Disk Defrag: improved appearance, added new drive map display style
    Disk Defrag: significantly improved scheduler
    Disk Defrag: fixed Windows Explorer integration bugs in 64-bit systems
    Disk Defrag: optimized and improved disk defragmentation algorithm
    significantly improved disk and registry cleanup algorithms
    Registry Cleaner now works better with 64-bit systems
    Disk Cleaner and Registry Cleaner: added support for Microsoft Office 2010
    Disk Cleaner and Registry Cleaner: improved support of previous versions of Microsoft Office
    fixed bugs in the program registration module
    File Recovery: significantly improved deleted files search and recovery algorithms
    File Recovery: added ability of previewing new file types
    Track Eraser: optimized browsers history clearing algorithms
    Track Eraser: added new categories for clearing saved passwords
    Track Eraser: added new categories for clearing download history
    improved Integrator appearance
    optimized memory usage in all utilities, that allows them to work more efficiently and stably
    Disk Cleaner: added an option of excluding user-defined folders
    Duplicate File Finder: significantly improved duplicates search algorithm, that allows the program to work more reliably and stably
    Disk Explorer: fixed memory leaks and improved memory usage
    optimized reports generation process and improved their appearance in the latest versions of Internet Explorer, Chrome, Firefox, Opera
    Disk Wiper: fixed an issue that sometimes caused an error due to changes in files' attributes
    System Advisor: fixed advices that caused creation of exclusions on some configurations
    System Information: fixed an issue that caused an error when launching the program on the Windows XP OS without any service pack installed on it
    System Information: numerous changes in system information obtaining algorithm were made. Added support for the latest device versions
    fixed memory leaks in various modules, improved memory usage
    fixed all known bugs
    corrected localization mistakes
    improved installer

    Download
     
  2. Spruce

    Spruce Registered Member

    Joined:
    Dec 18, 2010
    Posts:
    291
    Don't use these suites myself anymore these days, but I can say that this is among the very best.
     
  3. Narxis

    Narxis Registered Member

    Joined:
    Jun 10, 2009
    Posts:
    477
    Yeah, for me the top3 would be:

    1. Auslogics Boost Speed 5
    2. IObit Advanced SystemCare 4
    3. TuneUp Utilities 2011
     
  4. ellison64

    ellison64 Registered Member

    Joined:
    Oct 5, 2003
    Posts:
    2,499
    Hi Narxis..
    Do you use boostspeed yourself?.Ive just installed it on w7 64bit,and set it to start with windows.The first thing i noticed is that winpatrol didnt alert me to a new start up entry which i expected it to.I then looked at winpatrol start up and boostspeed isnt showing there.I then checked msconfig and task scheduler for startup entries and its not showing there either...but it is starting with windows.If you use it does it show in your start up locations?
    tia
    ellison
     
  5. Narxis

    Narxis Registered Member

    Joined:
    Jun 10, 2009
    Posts:
    477
    Hi ellison

    I unchecked the Start with windows option when i installed. Maybe you should try a reinstall or contact with Auslogics support.
     
  6. treehouse786

    treehouse786 Registered Member

    Joined:
    Jun 6, 2010
    Posts:
    1,388
    Location:
    Lancashire
    settings - program setting- advanced- untick start with windows
     
  7. ellison64

    ellison64 Registered Member

    Joined:
    Oct 5, 2003
    Posts:
    2,499
    You can tick start with windows after install ,which is what i did.I have conatcted auaslogics...2 to 4 day support .Ill try a reinstall later
    ellison

    UPDATE
    ...reinstalled and ticked start with windows.Same results of no start up entry showing in msconfig ,or anywhere else i can find.Waiting for auslogics support to get back to me.
     
    Last edited: May 29, 2011
  8. ellison64

    ellison64 Registered Member

    Joined:
    Oct 5, 2003
    Posts:
    2,499
    Im not sure how that would help?
    ellison
     
  9. Narxis

    Narxis Registered Member

    Joined:
    Jun 10, 2009
    Posts:
    477
    Maybe your antivirus/firewall-HIPS or internet security blocks Auslogics to be added in the startup entry?I have no other idea.
     
  10. ellison64

    ellison64 Registered Member

    Joined:
    Oct 5, 2003
    Posts:
    2,499
    Auslogics replied saying its a task scheduler startup.I looked again at task scheduler and indeed its there.Previously i was looking under "task scheduler library" which i assumed showed ALL startups for task scheduler.However it doesn't apparently.On expanding the task scheduler tree ,i saw that boostspeed starts up from an auslogics folder in task scheduler.This presented another problem for me with winpatrol.Although it monitors task scheduler ,boostspeed is not listed.perhaps because its launched from a folder within task scheduler or perhaps because it doesn't monitor the whole task scheduler tree.Ive emailed bill at winpatrol for more clarification.
    ellison
     

    Attached Files:

  11. Boyfriend

    Boyfriend Registered Member

    Joined:
    Jun 7, 2010
    Posts:
    1,070
    Location:
    Pakistan
    Thanks for update :) I have updated mine backup copy.
     
  12. brainrb1

    brainrb1 Registered Member

    Joined:
    Mar 15, 2010
    Posts:
    475
  13. treehouse786

    treehouse786 Registered Member

    Joined:
    Jun 6, 2010
    Posts:
    1,388
    Location:
    Lancashire
  14. sweater

    sweater Registered Member

    Joined:
    Jun 24, 2005
    Posts:
    1,674
    Location:
    Philippines, the Political Dynasty Capital of the
    Hhhmmnnn.,....:rolleyes: ....am happy with their free Auslogics Disk Defrag, but a little bit hesitant using BoostSpeed coz their are many freewares out there that has excellent reviews that does the same thing like Glary Utilities and TweakNow PowerPack 2011. ;)

    I've even uninstalled and removed TuneUp Utilities 2011 in my pc coz cpu usage spikes up that I felt that instead of helping my pc to speed up it just makes the system respond slower. The only thing I like w/ TU was that I can customize and install Bootscreen logo and change the log-in welcome screen of w/c still are intact even if TU was already removed. :cool:
     
  15. ruinebabine

    ruinebabine Registered Member

    Joined:
    Aug 6, 2007
    Posts:
    1,097
    Location:
    QC
    Yes, but those remnants could possibly cause you some weird problem when you'll want to install some MS patches, at least it did for me when I had previously TU installed/uninstaled on my old pc (XP pro), but it was about 1 year ago and I don't use it anymore since then on win 7.
     
Thread Status:
Not open for further replies.