ATIH2009_9770 PSAPI.DLL problem!

Discussion in 'Acronis True Image Product Line' started by olivex, Jun 24, 2009.

Thread Status:
Not open for further replies.
  1. olivex

    olivex Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    13
    It seems this ATIH places a very old PSAPI.DLL (version 4.0.1371.1, size 18KB) in system32 folder, replaces the original one which should be version 5.1.2600.5512 on my XP SP3 machine, and causes IE7 and some other software to stop running!
    When the old PSAPI.dll is in place, IE7 will never start up. If you right click the desktop IE icon, you will not see 'Open Home Page', you will only see only 'Create shortcut', 'Delete', 'Rename', 'Properties' etc., and if you double click it, it only creates an IE shortcut on desktop, instead of opening IE. If you select 'Properties' from the right-click menu, you will get 'Procedure entry point GetProcessImageFileNameW could not be located in the dynamic link library PSAPI.DLL' error.
    Besides, some other applications, like Ultraedit, also won't start.
    If I manually replace the PSAPI.dll with the new (original) one, everything seems back OK.
     
  2. olivex

    olivex Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    13
    It seems it doesn't bother IE8. I have another XP machine with IE8 installed. The PSAPI.dll was also replaced but IE8 can still be run.
    Anyway it is still a problem.
     
  3. olivex

    olivex Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    13
    No any response?
     
  4. f3kf3k

    f3kf3k Registered Member

    Joined:
    Oct 21, 2008
    Posts:
    4
    arghhh, have the same problems. many apps have troubles since i have ti 2009 installed.
     
  5. olivex

    olivex Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    13
    If I replace that old psapi.dll with a new one, problems gone.
    Just don't understand why ATIH puts such an old version there.
     
  6. olivex

    olivex Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    13
    pump.
     
  7. jctay

    jctay Registered Member

    Joined:
    May 6, 2009
    Posts:
    10
    Running on XP sp3. My first ATIH version was build 9709, subsequently updated to build 9770 and build 9791. So far psapi.dll was not affected by ATIH 2009.
     
  8. olivex

    olivex Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    13
    Can you check the version of psapi.dll? Or at least the size? Is it 18KB?
     
  9. jctay

    jctay Registered Member

    Joined:
    May 6, 2009
    Posts:
    10
    psapi.dll
    Location: C:\WINDOWS\system32
    version: 5.1.2600.5512
    file size: 22.5 KB (23,040 bytes)
    Modified date: Monday, April 14, 2008, 8:00:00 AM
     
  10. olivex

    olivex Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    13
    This is weird. Each time I install ATIH, the file is replaced by a version 4.0. And I do not do anything else.
     
Thread Status:
Not open for further replies.