are older versions of winamp not safe?

Discussion in 'other software & services' started by iceni60, Oct 26, 2004.

Thread Status:
Not open for further replies.
  1. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    i've got an old version of winamp (2.91) because ive heard afew people say that it and 2.90 are the best versions. i think i should update it to the latest version, because ive had a popup recently saying theres a security flaw thats been fixed with the latest version.

    are these newer versions really not as good? and why?

    if 2.91 is better then later versions, will i be safe if i associate all extensions with WMP10, so anything used straight from the internet will open WMP10?
    then i can continue using winamp 2.91 just for CD's

    thanks, any help will be appreciated :) :cool: :)
     
  2. TheSnowGuy

    TheSnowGuy Guest

    Winamp versions 3.x and 5.x can be exploited to run in an executable program ......avoid using new skins...........am not certain in regards to the version you are using........
     
  3. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    thanks, TheSnowGuy :) .

    the reason i asked is because this cant be the first flaw found since 2.90, but people like AMRX and the guy that wrote MJ Registry Watcher have been recommending them (2.90/1)

    it makes me think these 2x versions may be more secure then later versions because they may have fewer bells-and-whistles o_O
     
  4. TheSnowGuy

    TheSnowGuy Guest

    ICE

    the link you provide offers this <"winamp290_lite> as the download.....I don't recall there ever being a LITE version of winampo_O/


    I'm not really into music players so can not speak with the knowledge more experience users of players may have.....I tryed an older version of winamp years ago.....without problems.......but I also seem to recall that winamp was associated with spyware.........I may be incorrect......comments anyone..on the spyware issue??/
     
  5. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    i noticed that it said lite, i googled it and came back with 25 results including a site called winamp heaven which has both the lite and standard versions of both 2.90 and 2.91. i just remembered that theres a winamp forum. i'll go and ask there-


    are you thinking of wild tangent? i found out about that just-in-time :eek: if thats what you are thinking about; post#4
    https://www.wilderssecurity.com/showthread.php?t=52321
     
  6. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    i just asked at the winamp forum and all versions are at risk prior to v5.05.
    thanks for your help, TheSnowGuy :cool:
     
  7. Notok

    Notok Registered Member

    Joined:
    May 28, 2004
    Posts:
    2,969
    Location:
    Portland, OR (USA)
    For the record, I really don't see any advantage to keeping 2.9 instead of updating to 5.05. I avoided v3 entirely, and am very happy with 5.05. You can even keep using your old 2.x skins if you don't like the "modern" look (I don't)

    snowguy: Yup, they used to have a lite version, it was the same thing just with fewer plug-ins by default.
     
  8. TheSnowGuy

    TheSnowGuy Guest

    ICE

    As always..you are most welcome......an thank you as well...for sharing.







    Notox

    An a warm greeting to you.........about those Skins.....its the skins that are exploited.........I didn't do research on the subject so there may be more info on the issue.....


    Good Tidings and Well Wishes

    That Snowman Guy
     
  9. Notok

    Notok Registered Member

    Joined:
    May 28, 2004
    Posts:
    2,969
    Location:
    Portland, OR (USA)
    snow: It's actually the mechanism for installing the skin that's exploited.. it will just download and run the zip file automatically, opening up a HTML file (web page document) in your local trusted zone (bypassing restrictions to internet documents.) Don't install skins from untrusted sources and you'll be fine, and if you have v5.05 it's not a problem.

    http://secunia.com/advisories/12381/
     
    Last edited: Oct 26, 2004
  10. TheSnowGuy

    TheSnowGuy Guest

    NOTOK
    my apology to you as well...mis-spelled your "nic"......just hasn't been my day...lol


    an thanks for sharing the info.....your comment about trusted sites is good....more people should heed such advice.
    oh..I don't use any player...no sound card.....cd's will play on d drive...thats about it...........
     
  11. Claiken

    Claiken Guest

    older versions of winamp (2.x) are better.... the newer versions have so much crap in them that it takes literally 45 seconds if your watching a movie on it and you want to fast forward. same with a song. whereas the older version finds the spot quick and keeps playing immediately.


    but my question is does anybody know how to make that stupid dialog stop. besides updating?
     
Loading...
Thread Status:
Not open for further replies.