AppGuard 4.x 32/64 Bit - Releases

Discussion in 'other anti-malware software' started by Jryder54, Oct 29, 2013.

Thread Status:
Not open for further replies.
  1. hjlbx

    hjlbx Guest

    BRN working on Enterprise version - so fixes for Professional version (beta tester's version) bugs will have to wait.

    Barb has her hands full...
     
  2. Barb_C

    Barb_C Developer

    Joined:
    Jan 7, 2011
    Posts:
    1,234
    Location:
    Virginia
    Hey all, just a quick note (as hjlbx indicated, I'm extremely busy with work on our Enterprise version and also getting ready to on vacation!). Anyway, the last release (4.4.4) had a bug that had an issue if you used the minimize button. Also, you could no longer open the GUI from the desktop shortcut - always have to use the icon in the tray). Anyway, we have an update that you can download at
    https://blueridgenetworks.s3.amazonaws.com/UpdateFolder/AppGuardSetup-4-4-6-1.exe.

    This 4.4.4 release really had minimal changes so we didn't run a beta test, but I've learned my lesson and I will always push for a beta test with this forum's users. You all would have definitely caught this bug and it would not have gone out to the masses. So we had to quickly turn around this fix and push it out.

    The 4.4.6 version also has a bug fix that was causing Guarded App policy for applications on external drives to disappear from the policy. So if you have policies for external drive Guarded applications, you may want to double check that they are still in your policy (of course they won't show up if your drive is unplugged, but if you brought up AppGuard with the drive unplugged, they were permanently removed and you needed to re-enter them). Now if you plug in your drive, they should reappear (though you may have to turn AppGuard off and turn it back on).

    Anyway, sorry if you updated to 4.4.4 and are experiencing these problems.

    And lastly (please don't shoot the messenger), I think that the version 4.x will no longer be available for new sales after July 1st (or about that time). We will continue to support 4.x with bug fixes and enhancements for the foreseeable future, but we are no longer selling the product with a perpetual license. There will be an annual fee for 5.x, but if you already have a 4.x license you will be able to update to any 4.x release that we do in the future. As stated above, I will be pushing for continuing our beta test program with Wilder's forum members so periodically I imagine that additional 4.x licenses may be made available for beta testing.
     
  3. Mr.X

    Mr.X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    4,027
    Location:
    Mexico
  4. Cutting_Edgetech

    Cutting_Edgetech Registered Member

    Joined:
    Mar 30, 2006
    Posts:
    5,653
    Location:
    USA
    Thank you for swinging by Barb. We appreciate being kept in the loop. Yeah, I had experienced the policy being erased for Guarded applications on external drive for a long time. It was not a big deal so I did not report it until recently. It did not happen very often. The issue that always happened is where the policy would not be loaded from the service to the driver after the the drive had been plugged in so AG would not load the policy for the application on the external drive unless AG was Disabled, and then Enabled again. It was just a minor inconvenience.
     
  5. guest

    guest Guest

    ok i think i found the cause of my issue :

    Issue: non-system partition located apps can't be guarded and generate an error popup after being added to the list.

    probable cause: i found out that portable apps needing admin right (or elevation) are only affected; example Ccleaner portable, Wise disk Cleaner Portable, HMP, etc...

    However, those that don't require elevation are guarded. example: Notepad++ portable, Foxit reader, Portable, etc...

    Note : that i use AG in a SUA with UAC max.
     
  6. hjlbx

    hjlbx Guest

    I wonder if the bug is somehow related to UAC. Does changing the UAC setting from "Always Notify" to "Notify me only..." eliminate the error message ? Either way it is still a bug...
     
  7. guest

    guest Guest

    it is a strange bug. for example Qbitorrent Portable, which doesnt need elevation is subject to this error. i will try reducing UAC to see if it is a cause.
     
  8. paulderdash

    paulderdash Registered Member

    Joined:
    Dec 27, 2013
    Posts:
    4,415
    Location:
    Under a bushel ...
    I have a perpetual (4.4.6.1) license on one machine.
    Can someone please clarify: Is it then still possible to buy another 4.x.x.x license before July 1, but this is no longer perpetual? If so, is that the Personal version?
     
  9. Barb_C

    Barb_C Developer

    Joined:
    Jan 7, 2011
    Posts:
    1,234
    Location:
    Virginia
    We didn't fix your particular bug (that has been there forever) so the minor inconvenience is still there. It's just with the 4.4.4 release, they were permanently deleted from the policy and needed to be re-added.
     
  10. Barb_C

    Barb_C Developer

    Joined:
    Jan 7, 2011
    Posts:
    1,234
    Location:
    Virginia
    I'm trying to confirm, but I think that though the ecommerce site may say that it is subscription pricing (this is in preparation for the launch date of "Personal" which will require subscription), the license that is currently being provided is perpetual from that site is 4.x and is perpetual. Unfortunately the person that has to confirm this usually doesn't get in till much later and I will be on the road by then. I can let you know what I hear on Monday.

    Just confirmed that you can buy AppGuard 4.X as AppGuard Personal through June 30th. On July 1st AppGuard Personal Subscription will be launched and AppGuard 4.X will no longer be sold. Note, we will continue to support and periodically upgrade AppGuard 4.x, but it will no longer be available for purchase through our web site.
     
    Last edited: Jun 27, 2016
  11. mood

    mood Updates Team

    Joined:
    Oct 27, 2012
    Posts:
    41,700
    Yes, switching modes is needed to let them appear.
    The alternative is a single click on "Customize", then the policy gets "refreshed" too. And you don't need to disable the protection.
     
  12. paulderdash

    paulderdash Registered Member

    Joined:
    Dec 27, 2013
    Posts:
    4,415
    Location:
    Under a bushel ...
    Thanks. I would appreciate that. :)
     
  13. guest

    guest Guest

    @Barb_C any development about my issue?
     
  14. mood

    mood Updates Team

    Joined:
    Oct 27, 2012
    Posts:
    41,700
    I can add them without problems (SUA + UAC max.), no error poup.
    Wasn't this a Rollback RX Issue somehow? It could be :cautious:
    There is maybe some other driver interfering with AG.
     
  15. artoor

    artoor Registered Member

    Joined:
    Oct 13, 2012
    Posts:
    113
    Location:
    Poland
    Hello!

    I think it's a good place to ask a question that concerns licensing... I have a license and from what I can see it's suitabe for 3 seats. Please let me know if there is any particular way to deactivate my currently used license before I do a format of my PC? As it looks (please open an attachement) I'm run out of Activations Left even though I currantly use my AppGuard on 2 PCs. Have I missed something?

    screenshot_11.png
     

    Attached Files:

  16. Mr.X

    Mr.X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    4,027
    Location:
    Mexico
    On the contrary, I think this type of questions should be asked directly to BRN via email support.
     
  17. artoor

    artoor Registered Member

    Joined:
    Oct 13, 2012
    Posts:
    113
    Location:
    Poland
    Thank you, I've just thought anyone here could have had some information about it so that I don't have to jack him around and let them work on improving this awesome tool ;)
     
  18. guest

    guest Guest

    you have to uninstall AG before formatting
     
  19. guest

    guest Guest

    on non-system partition?
     
  20. artoor

    artoor Registered Member

    Joined:
    Oct 13, 2012
    Posts:
    113
    Location:
    Poland
    guest, thank you! It looks I have missed that chance then :(
     
  21. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    20,590
    I haven't been able to download from that link.
     
  22. Jarmo P

    Jarmo P Registered Member

    Joined:
    Aug 27, 2005
    Posts:
    1,207
    Barb_C's post #5358 you mean? Copy and paste the link and remove the dot at the end. Should work then.

    I downloaded the install file for backup, but will most likely use the popup update thing instead to see which version it gives.
     
  23. Mr.X

    Mr.X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    4,027
    Location:
    Mexico
    https://blueridgenetworks.s3.amazonaws.com/UpdateFolder/AppGuardSetup-4-4-6-1.exe
     
  24. ViVek

    ViVek Registered Member

    Joined:
    Aug 7, 2008
    Posts:
    575
    Location:
    Moon
    Thanks for update
     
  25. hjlbx

    hjlbx Guest

    Everyone better save multiple copies of the 4.4.6.1 installer - otherwise it might be hard to get your hands on it after July 1st...
     
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.