AMON not scanning when "scan all files" is enabled

Discussion in 'NOD32 version 2 Forum' started by sukarof, Mar 2, 2005.

Thread Status:
Not open for further replies.
  1. sukarof

    sukarof Registered Member

    Joined:
    Jun 22, 2004
    Posts:
    1,714
    Location:
    Stockholm Sweden
    I noticed all of a sudden that AMON wasnt scanning files in realtime at all.
    After a bit investigation I noticed that if I disable "scan all files" (in extension editor) AMON scans files in realtime. But as soon as I enable it, AMON stops scanning...
    Any ideas of what has happend?

    When in "scan all files" mode I only have *.txt as an exclusion. Because otherwise AMON slows down the startup of Totalcommander and some other programs, AMON scans the Processguard log-file everytime TC is started. I have tried to exclude the scanning of Processguard log-file in AMON setup, but it doesnt help - it still keeps scanning the log file. So thats why I disabled the realtime scanning of .txt-files, thats the only way of stopping AMON to scan the log-file.

    )
     
  2. NOD32 user

    NOD32 user Registered Member

    Joined:
    Jan 23, 2005
    Posts:
    1,766
    Location:
    Australia
    Try just explicitly identifying the txt files you want excluded and see if it works then (full path including drive letter and case sensitive) - I'm wondering if the leading * makes it an exclusion match for everything since it looks like the exclusions are set up for explicit entries. I'd be interested to hear what difference that makes if any.
     
  3. sukarof

    sukarof Registered Member

    Joined:
    Jun 22, 2004
    Posts:
    1,714
    Location:
    Stockholm Sweden
    You were right. When I deleted the *.txt from exclusion I could use the "scan all files" feature - it scans everything again. And now I can exclude the processguard log-directory for some reason, it didn´t work earlier when I tried...strange.
    I guess this goes to the computer-archive X. Sometimes problems solves them selves for some reason.....
    Many thanks for your input NOD32 user!
    Never could have figured it out my self :)
     
  4. NOD32 user

    NOD32 user Registered Member

    Joined:
    Jan 23, 2005
    Posts:
    1,766
    Location:
    Australia
    Glad to be of assistance and thanks for letting us know how it went :)
     
Thread Status:
Not open for further replies.