Acronis True Image Echo Server for Windows installation troubles

Discussion in 'Acronis True Image Product Line' started by ms62, Feb 12, 2008.

Thread Status:
Not open for further replies.
  1. ms62

    ms62 Registered Member

    Joined:
    Feb 12, 2008
    Posts:
    2
    Hi,

    I try to install Acronis True Image Echo Server on Windows 2003 Enterprise Server X64 without any success :'(

    Installation process always fails with:
    The installation was interrupted before Acronis True Image Echo Server could be installed. Yout need to restart the installer to try again.


    Any Hints, please?

    I found this in Aconis installation log:
    ===================================
    1: MSIGEN:MsiSnapmanInstall: Path to SnapAPI DLL: C:\WINDOWS\SysWOW64\snapapi.dll
    MSI (s) (84:E0) [09:34:45:578]: Executing op: ActionStart(Name=_USRCUSTACT_MsiVSSInstall_VSSProvider,,)
    Action 9:34:45: _USRCUSTACT_MsiVSSInstall_VSSProvider.
    MSI (s) (84:E0) [09:34:45:578]: Executing op: CustomActionSchedule(Action=_USRCUSTACT_MsiVSSInstall_VSSProvider,ActionType=3073,Source=BinaryData,Target=MsiVSSInstall,CustomActionData=C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\tmp29.tmp)
    MSI (s) (84:90) [09:34:45:593]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI13B5.tmp, Entrypoint: MsiVSSInstall
    MSI (s) (84:E0) [09:34:45:625]: Executing op: ActionStart(Name=CARegisterComPLus_Acronis_VSS_Provider,,)
    Action 9:34:45: CARegisterComPLus_Acronis_VSS_Provider.
    MSI (s) (84:E0) [09:34:45:625]: Executing op: CustomActionSchedule(Action=CARegisterComPLus_Acronis_VSS_Provider,ActionType=3078,Source='cscript for registering/unregistering Acronis VSS Provider

    Option Explicit
    Dim ProviderName, ProviderDLL, ProviderDescription
    Dim Ok, OnRollback

    Function VBScriptCA_RollbackUninst()
    Ok = 1
    OnRollback = 1
    WriteToLog "Args passed: "&Session.Property("CustomActionData")

    Dim Args
    Args = Split(Session.Property("CustomActionData"), ";")

    Dim Count, Dummy
    Count = 0
    WriteToLog "Parameters parsed:"
    For Each Dummy In Args
    Count = Count + 1
    WriteToLog " "&Dummy
    Next

    If Count = 0 Then
    WriteToLog "No parameters were passed"
    VBScriptCA_RollbackUninst = 3
    Exit Function
    End If

    If Count > 0 Then
    If Args(0) = "-register" AND Count = 4 Then
    WriteToLog "Uninstall rollback mode detected.."
    ProviderName = Args(1)
    ProviderDLL = Args(2)
    ProviderDescription = Args(3)

    InstallClusterMSDTC

    If NOT Ok = 1 Then
    VBScriptCA_RollbackUnin
    [CUSTOMACTION]: Args passed: -register;Acronis VSS Provider;C:\WINDOWS\SysWOW64\snapapivss.dll;VSS Provider
    [CUSTOMACTION]: Parameters parsed:
    [CUSTOMACTION]: -register
    [CUSTOMACTION]: Acronis VSS Provider
    [CUSTOMACTION]: C:\WINDOWS\SysWOW64\snapapivss.dll
    [CUSTOMACTION]: VSS Provider
    [CUSTOMACTION]: Registering mode detected..
    [CUSTOMACTION]: Detecting MS Cluster...
    [CUSTOMACTION]: - Cluster connection attempted. Exit code: -2147023143 [0x800706D9]
    [CUSTOMACTION]: - This is not a cluster node
    [CUSTOMACTION]: - Proceeding with normal installation...
    [CUSTOMACTION]:
    ERROR:
    [CUSTOMACTION]: - Error code: 429 [0x1AD]
    [CUSTOMACTION]: - Exit code: 202
    [CUSTOMACTION]: - Description: ActiveX component can't create object
    [CUSTOMACTION]: - Source: Microsoft VBScript runtime error
    [CUSTOMACTION]: - Help file:
    [CUSTOMACTION]: - Help context: 0
    [CUSTOMACTION]: - COM+ Errors detected: (0)
    Action ended 9:34:45: InstallFinalize. Return value 3.
    MSI (s) (84:E0) [09:34:45:703]: User policy value 'DisableRollback' is 0
    MSI (s) (84:E0) [09:34:45:703]: Machine policy value 'DisableRollback' is 0
    MSI (s) (84:E0) [09:34:45:718]: Executing op: Header(Signature=1397708873,Version=301,Timestamp=944524371,LangId=1033,Platform=0,ScriptType=2,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=3)
    MSI (s) (84:E0) [09:34:45:718]: Executing op: DialogInfo(Type=0,Argument=1033)
    MSI (s) (84:E0) [09:34:45:718]: Executing op: DialogInfo(Type=1,Argument=Acronis*True*Image*Echo*Server)
    MSI (s) (84:E0) [09:34:45:718]: Executing op: RollbackInfo(,RollbackAction=Rollback,RollbackDescription=Rolling back action:,RollbackTemplate=[1],CleanupAction=RollbackCleanup,CleanupDescription=Removing backup files,CleanupTemplate=File: [1])
    Action 9:34:45: Rollback. Rolling back action:
    Rollback: CARegisterComPLus_Acronis_VSS_Provider
    =============================================

    Regards
     
  2. roaringmouse

    roaringmouse Registered Member

    Joined:
    Sep 16, 2007
    Posts:
    1
    I ran into that once. Try this:

    Error:
    The installation was interrupted before Acronis True Image Enterprise Server could be installed. You need to restart the installer to try again.

    Solution:

    Check the following services

    COM+ must be running.
    VSS can't be disabled.
     
  3. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello all,

    Thank you for using Acronis Server Disk Backup software

    ms62, could you please make sure the following services are running:

    * COM+ System Application
    * Distributed Transaction Coordinator

    If all of them are started, could you please check that COM+ is not broken by opening it manually (Control Panel -> Administrative Tools -> Component Services -> Computers -> My Computer -> COM+ Applications -> System Application). If at any of the steps there appears an error message, then COM+ Application is broken.

    If you've checked that services are enabled and COM+ Application is working then it's possible that Volume Shadow Copy service is disabled or not started. Could you please make sure it is enabled and then start it. If it fails to start due to any reason, this means that there are some problems with VSS subsystem itself.

    In case starting Volume Shadow Copy service does not help, proceed as follows:

    * Delete Acronis VSS Provider from Control Panel -> Administrative Tools -> Component Services -> Computers -> My Computer -> COM+ Applications -> System Application
    * Delete \Windows\System32\snapapivss.dll if it exists
    * Find and delete all registry keys (Start->Run->Regedit) which contain the following GUIDs:

    o F5DBCC43-B847-494e-8083-F030501DA611
    o 89CDAF20-82B6-42cd-A4B4-573C81999C35
    o 5FC845EB-F299-40f0-9725-34045F7EA8BA

    There will be keys with names beginning with SnapVSSProvider when one starts searching for 5FC845EB-F299-40f0-9725-34045F7EA8BA. These keys should be deleted.

    * Install SnapAPI
    * Install Acronis True Image Echo Server
    * Reboot

    If the issue is still exist then could you please submit a request for technical support. Attach all the information to your request along with the step-by-step description of the actions taken before the problem appears and the link to this thread. We will investigate the problem and try to provide you with a solution.

    Thank you.
    --
    Michael Levchenko
     
  4. ms62

    ms62 Registered Member

    Joined:
    Feb 12, 2008
    Posts:
    2
    Thank you!

    COM+ rebuild solved my problem ...

    http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3B301919

    BR



     
Thread Status:
Not open for further replies.