Acronis True Image Backup Archive Explorer and driver update?

Discussion in 'Acronis True Image Product Line' started by scott784, May 18, 2007.

Thread Status:
Not open for further replies.
  1. scott784

    scott784 Registered Member

    Joined:
    May 18, 2007
    Posts:
    2
    I am a new user of Acronis True Image Home. As part of the installation, this program installs the Acronis True Image Backup Archive Explorer within Device Manager.

    Okay, now the question. Is there an updated device driver for Acronis True Image Backup Archive Explorer?? When I pulled up this device within Device Manager, I noticed the driver is dated 11/15/2005. That seems really old for a new program. I have version 10 of Acronis True Image Home.

    I also wanted to point out that "Windows Vista Upgrade Advisor" does NOT recognize this driver. It recognizes version 10 of the actual program just fine but NOT this driver. So is there a way to update the driver? I tried by right clicking on the driver and hoping something would be found online but that did not happen.

    I am trying to get rid of incompatibilities within Vista and I really didn't want to start out using this new program with an old driver. Thank you for any help.
     
  2. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    That is the same date I show for the driver. I wouldn't worry about it. Perhaps it's really that old or perhaps they just didn't update the date. In any case, I haven't had any problems with it in Vista or XP.
     
  3. E-Buzz

    E-Buzz Registered Member

    Joined:
    May 28, 2005
    Posts:
    109
    Hmmmmm interesting, i noticed the same. As described in https://www.wilderssecurity.com/showthread.php?t=165177 some of us are having severe problems exploring backup archives, in my case created in Vista. Maybe the rather old (and outdated?) driver is the culprit in this case?
     
  4. scott784

    scott784 Registered Member

    Joined:
    May 18, 2007
    Posts:
    2
    I've shared this same question with technical support at acronis. I just find it strange that a new program (supposed to be Vista compatible) would have a driver that is not recognized by Windows Vista.

    Windows Vista Update Advisor clearly reports this driver as not being recognized when you run the Advisor program. Again, it recognizes the program but not that driver.

    I will post back on this board when I get some feedback. Meanwhile, if you learn of anything regarding this issue, please let me know. It should be noted that I have the latest build, 4942.
     
    Last edited: May 19, 2007
  5. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello scott784,

    Thank you for choosing Acronis Disk Backup Software.

    Could you please let us know your Acronis request number which was sent to you in autoreply to your letter? We will find out how the investigation of your issue is going. If you have not received an autoreply then please send us a Private Message containing your e-mail address.

    Thank you.
    --
    Marat Setdikov
     
  6. Lucab

    Lucab Registered Member

    Joined:
    Sep 17, 2007
    Posts:
    1
    Well I can only add my concern to the incompatibility of th edriver with Vista.
    I just upgraded another PC to Vista...and it was total hell, so I'd really like to know what is going on with this driver.
     
Thread Status:
Not open for further replies.