Acronis OSS Makes DVD Drive Disappear!!

Discussion in 'Acronis Disk Director Suite' started by radigast, May 19, 2008.

Thread Status:
Not open for further replies.
  1. radigast

    radigast Registered Member

    Joined:
    May 19, 2008
    Posts:
    4
    Here's my info:
    Windows XP w/ SP3
    Acronsic DD Suite 10.0 build 2 160

    I would love to use the Acronis OSS selector program, but it seems there is quite a large bug. Whenever I have OSS selector active, it makes the DVD drive on my system disappear. If I look in device manager, the DVD/CD drive is hidden, and it gives Error Code 45: "Currently, this hardware device is not connected to the computer. (Code 45)".

    I have tested on a freshly formatted default install of Windows XP SP3. As soon as OSS selector was installed and used for booting, the DVD drive disappeared and returned the error code above. This is on a laptop, so I completely removed the DVD drive and physically checked all connections, but there was no connection problem.

    The only way to fix this problem is to uninstall OSS Selector, and then repair the MBR using the recovery cd ("fixmbr" at the recovery command prompt). Then there are no longer any problems with the DVD drive.

    Has anyone else experienced this? Are there any workarounds? What's goin on? Again, I would love to use this program...but this is too big of a bug to overlook.

    Thanks for your help!

    --radigast
     
  2. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    I have not heard of this problem. Did it happen with XP SP2 (if you know)?

    Does it make a difference if you install OSS only from the CD and not in Windows?

    Have you tried checking the startup option Do not load CD-ROM drivers?
     
  3. radigast

    radigast Registered Member

    Joined:
    May 19, 2008
    Posts:
    4
    1. I'm not sure. I haven't tested it on SP2. But, I will only be using SP3, so I probably won't test it.

    2. I'm not sure how to do that. I am willing, if you can give me instructions. :)

    3. I didn't see that option anywhere. I'll look again and see if I can find it.
    **Update** I reinstalled OSS and checked this option to no avail. DVD drive posts correctly in BIOS, but does not load/appear in XP (as per first post).



    As a sidenote, here is some more weirdness. The DVD drive correctly loads in OSS selector, because it will allow me to boot off of a Windows CD. :(
     
    Last edited: May 19, 2008
  4. radigast

    radigast Registered Member

    Joined:
    May 19, 2008
    Posts:
    4
    The exact same problem happens in Windows Vista.

    This is a MAJOR error, and makes this program no better than a virus.

    I will no longer use Acronis products...ever. Further, I will recommend EVERY person/business I know to steer clear of Acronis products.
     
  5. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    This is a major problem on your computer, but definately not a common one. There are still several things you could try, though it sounds as if you've called it quits.

    Installing OSS from the CD means that OSS doesn't get installed in Windows. To do this, create a new DD CD with Media Builder and include the OSS programs. When you boot the CD, one of the menu options will be OSS. You'll need to enter the serial number so have it handy.

    There is also an OSS service that runs in Windows. As far as I know, it is installed even if only DD is installed. You could disable it and see if that makes a difference. Start msconfig, select the Services tab and uncheck the Acronis OS Selector Reinstall Service entry. Reboot.

    If you have OSS installed normally and you start Windows in Safe Mode, can you see the DVD drive?

    Another test procedure that you could try (if you haven't) is to install OSS, see that the problem exists and then just deactivate OSS instead of uninstalling. Is the problem still there?

    In your first post, you said you had to repair the MBR after you uninstalled OSS. Was this because the problem still existed or because the computer wouldn't boot properly?

    Lastly, if you cared to, it wouldn't hurt to submit a support request to Acronis regarding this problem (include a link to this thread). They may be able to provide you a custom build that will work on your computer.
     
  6. radigast

    radigast Registered Member

    Joined:
    May 19, 2008
    Posts:
    4
    This was the first thing I tried. It did not work.

    Unfortunately, no.

    Deactivating OSS and fixing the MBR does make the problem go away.

    The computer booted fine. The only way to fix the disappearing DVD drive was to deactivate, and then fix the MBR.

    Nah. As you said, I've given up on Acronis OSS. Instead, I am using a MUCH smaller and reliable program to control my OS booting needs: EasyBCD. Small footprint. Easy to use. No glaring errors. I highly recommend it.

    Thank you for all of your help and support. I do appreciate your advice.
     
  7. Lyner

    Lyner Registered Member

    Joined:
    Sep 4, 2008
    Posts:
    2
    Same thing happen here....


    My Problems after installing OSS:

    1) My DVD drive doesnot show up in OSS bootup althought i had tried to insert all kinds of bootable CDs or DVDs. (including XP/Vista installation DVD) However it does show up in my vista OSS.
    2) My DVD burning software found incompatiple DVD drive when attempting to burn files. (Ashampoo Burning Studio :cool:
    3) DVD drive seems to be unreadable sometime.
    4) Autoplay Option not functioning as it normally should when i insert any CD or DVD.



    Suspicious Error in Event Viewer after install OSS:

    1) VDS fails to claim a disk (\\?\ide#diskst3320620a______________________________3.aaf___#6&211a1aa2&0&0.0.0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}) due to error. Error Code: 80070005@0200000F

    2) \\?\ide#disklyner01.0.00__#4&36887771&0&0.0.0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}
    80070005@0200000F

    3) Failed to open device \\?\ide#diskst3320620a______________________________3.aaf___#6&211a1aa2&0&0.0.0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}. Error code: 5@02000017

    4) Failed to open device \\?\ide#disklyner01.0.00__#4&36887771&0&0.0.0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}. Error code: 5@02000017




    My System:
    Windows Vista Ultimate 64bits
    Acronis Disk Director Suite 10.0.0.2160
     
  8. Lyner

    Lyner Registered Member

    Joined:
    Sep 4, 2008
    Posts:
    2
    UPDATE :

    as what radigast did for recovery in 1st post, after uninstall Acronis OS selector + fixmbr with recovery disk everythings back to normal.

    However this have cost me 2 DVDRW Disk corrupted !! :cautious:
     
Thread Status:
Not open for further replies.