A question about application filtering

Discussion in 'LnS English Forum' started by Yair, Dec 10, 2004.

Thread Status:
Not open for further replies.
  1. Yair

    Yair Guest

    I configured lns to block my email program from launching IE to access the internet
    this way i can click on links in emails safely and see their real destination in IE's address bar without having to enter that address, it also defends me from some IE exploits.

    the problem is, it only works if IE isn't already opened, if it's already opened IE will simply redirect to the new address.

    how can that be? it's like a leak test bypassing lns... can i prevent that from happening?
     
  2. Skunky#1

    Skunky#1 Guest

    If you want to make it work,you have to put C:\PROGRA~1\INTERN~1\IEXPLORER.EXE into application filtering if not there already? And put two stop flags.

    So this way you won't connect to the server,but you will get the address when IE opens to the link.but it will not load the page,hope this helps,I use it all the time,and when I do need C:\PROGRA~1\INTERN~1\IEXPLORER.EXE I just put them to green.

    And it block's even if IE is opened or closed when you put the two stop flags on C:\PROGRA~1\INTERN~1\IEXPLORER.EXE you can click on the link in your email,and it will show you the address,but will say Can't find sever,hope this helps
     
  3. Yair

    Yair Guest

    thanks but that won't do as i use IE for surfing, i just don't want my email program to use it

    Since lns has an option to prevent a program from accessing the internet though another program, it sounds like a big hole to me if the program can still gain that internet access if a browser window (or any other program authorized to access the internet) is already opened.

    o_O
     
  4. Skunky#1

    Skunky#1 Guest

    Hi


    Sorry that won't work for you,but there are two IE's.exe,if you are aware of this please disregard the below info.

    ,1: c:\program files\Internet explorer,and the one I told you to block C:\PROGRA~1\INTERN~1\IEXPLORER.EXE ,if you block C:\PROGRA~1\INTERN~1\IEXPLORER\.EXE ,you can still surf the net using C:\PROGRAM FILES\INTERNET EXPLORER\IEXPLORER.EXE,I don't see why it won't work for you? If you block C:\PROGRA~1\INTERN~1\IEXPLORER.EXE just make sure C:\PROGRAM FILES\INTERNET EXPLORER\IEXPLORER.EXE is green I have had no problems what so ever,and it's been 8 months using this method,and when I do need
    C:\PROGRA~1\INTERN~1\IEXPLORER.EXE for email linking and other stuff I just turn it back on.

    I can pass every firewall leak test out there so far,and I don't have windows XP,if you know what apps to block there is not a problem
    ,but I don't recommend my method to other people,if there using XP since LnS has released a driver to pass most,or all leak tests,but does little for me since I don't use XP,but I pass every test out there,and LnS is the only firewall to pass most leak tests,and I have tried every firewall on the market
    and LnS works for me,but to each his own,good luck
     
  5. Yair

    Yair Guest

    ah OK now i understand what you meant.


    C:\PROGRA~1\INTERN~1\IEXPLORER.EXE
    and
    C:\PROGRAM FILES\INTERNET EXPLORER\IEXPLORER.EXE
    are addresses of the same file, only one is written for operating systems which only support short file names

    it's possible that lns treats the 2 addresses as different files when adding them to the list but i am not sure about that

    anyway, thanks for your suggestion :)
     
  6. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Well the both, short and long pathnames are supported by the system and that is why you see the both being used under Windows, you will see both styles being used depending on usage of Windows.
     
  7. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Unfortunately the option is only to prevent a program to start another one which will connect.
    If the program is already started by an allowed parent application, Outlook is not considered as the parent process and so IE connects to internet :(

    Frederic
     
  8. Yair

    Yair Guest

    oh that's too bad
    thanks for explaining that though :)
     
Thread Status:
Not open for further replies.