A Few problems with L 'n' S

Discussion in 'LnS English Forum' started by Jormungandr, Jan 3, 2007.

Thread Status:
Not open for further replies.
  1. Jormungandr

    Jormungandr Registered Member

    Joined:
    Jan 3, 2007
    Posts:
    3
    Hey,

    I'm new to this firewall's way of working, and I'm just trying to get a few things figured out. I have a few questions so do bare with me a moment.

    1. I set the firewall up as the stickied post suggested, but I'm confused as to a few things. In the post it shows the lan card as the network interface to be firewalled. Now I did this, but then I cannot connect to the internet (but if I connect first then place the firewall on, I can't do anything on the net, and the connected status in the welcome screen is not checked). The log shows up with the same entry:

    Code:
    |D-169|01-03-07,19:47:40|All other packets|ETH|00:90:1A:A0:94:2F|Type Ethernet:8864
    2. Now with the first question, if I set it to the second: WAN miniport (IP). Everything seems to work, the log shows different 'attacks' that are blocked and the connected status is checked. I even performed a few test with it (port scanning and such). It all ran perfectly, it's just that sometimes my connection would go down and msn would log off and I couldn't load a website anymore. It would also block my bittorrent downloading. (I added the exception from looknstop's website, and configured the bittorrent on to the correct port).

    3. I am although very happy with this firewall and hope to be able to fix these problems. I'm sure it is but my own fault. This firewall is small and it block much, perfect for a gamer as I.

    Thank you in advance.

    *edit: it seems my ip was correct, I accidentally re-connected to the internet, and I have a dynamic IP, sorry about the confusion.

    **edit #2: Ok so I've determined that I should use the WAN miniport connection (I know know how stupid I was, it was on the main L n S site). As for the rest still a few problems.

    ~Jor
     
    Last edited: Jan 3, 2007
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    Could you confirm the remaining few problem is "it's just that sometimes my connection would go down and msn would log off and I couldn't load a website anymore. It would also block my bittorrent downloading."

    Is there any entry in the log when you experiment these blocking issues ?

    Frederic
     
  3. Jormungandr

    Jormungandr Registered Member

    Joined:
    Jan 3, 2007
    Posts:
    3
    Thanks for the reply,

    It seems to have all worked out, I have yet to get another hiccup. I don't remember too well, but I guess it was just a rule I either implemented or somehow changed. I say this cause I reloaded the standard rule set and imported the msn and biuttorent rules into LnS and it seems to work now. Sorry to have waisted your time.

    Thank you again,
    ~Jor
     
  4. ugly

    ugly Registered Member

    Joined:
    Mar 21, 2005
    Posts:
    276
    Location:
    Romania
    If this is about problems ...
    My DC++ won't work with LnS.:'(
    I do import DirectConnect.rie.;)

    Is this right ?
    Something more to do ?
     

    Attached Files:

    • lns.JPG
      lns.JPG
      File size:
      16.2 KB
      Views:
      519
    Last edited by a moderator: Jan 15, 2007
  5. Jormungandr

    Jormungandr Registered Member

    Joined:
    Jan 3, 2007
    Posts:
    3
    well I don't know, but have you checked that the port in the rule is the same used by DC++? The reason I say this is because just like my bittorent client had a different port then the default given by most program, your DC++ could have a different port then the others.

    I'm sure there's some place in the options where it says what port(s) are being used by the download and upload.

    Hope it helps,
    ~Jor
     
  6. ugly

    ugly Registered Member

    Joined:
    Mar 21, 2005
    Posts:
    276
    Location:
    Romania
    Sorry. No luck.:'(
    Any other opinion on how to make that rule work please.o_O
    Best regards.
     
  7. ugly

    ugly Registered Member

    Joined:
    Mar 21, 2005
    Posts:
    276
    Location:
    Romania
    NO ONE ?!?! :'(
     
  8. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Is there any log additions in the Log tab when you are using the DC++ ?

    I guess the problem disappears as soon as Look 'n' Stop is stopped.
    Could you try to just disable the Internet filtering to verify if the problem is coming from this filtering ?

    Thanks,

    Frederic
     
  9. ugly

    ugly Registered Member

    Joined:
    Mar 21, 2005
    Posts:
    276
    Location:
    Romania
    If I quit LnS , of course without "keep internet filtering...", everything is all right.
     
  10. g00ng

    g00ng Registered Member

    Joined:
    May 16, 2005
    Posts:
    4
    I'm having the same problem as well.
    LNS version is 2.05p3 trial.

    Sometimes when I'm online, suddenly the connection dropped.
    I just tried Lns for a few days. It occurs to me a few times.


    The possible cause is :
    1. When I use Flashget, it happen suddenly, my browser and MSN dropped connection, but Flasget keep going. I thought flashget take all the bandwidth, so I stopped it. But I still can't connect. When I restart the flashget, I can't connect too. I had to restart the computer to restore connection.
    2. Happen too when I use uTorrent. Others can't connect, but Torrent still going until I stop it, and nothing would connect.
    3. Also when I'm up from hibernation (just occur, don't know for sure). This last time, I tried to quit Lns, and my connection is back. Symptom is the same. So I quess this was the cause by Lns.

    When I checked the log, it show that it all connection D- and U- (if I'm correct). Like :
    U-60 01-22-07 08:86:43 TCP:Any other packet TCP wilderssecurity.com Ports Dest:www-http Src:7687

    Seem like the Application filtering failed to start, and it blocked all application,
    I tried to disable and enable, but no effect.
    When I disable Internet Filtering, all connection return to normal.

    Tried to change to Standard rule, still can't connect.
    Change back to Enhanced rule, can't connect either.

    Maybe its a bug, or maybe there is conflict with other programs.
    Very lightweight firewall.. Hope it could be fix.

    Thanks.
     
  11. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hi g00ng

    The log entry that you have generously gave suggests an ‘Out-of-Bound’ of the rule ‘TCP : Authorize most common Internet services’, Source port temp-range is 1024-5000, now see the source-port shown with that log entry you provided? ‘Src:7687’, this means you’ll need to make a change to that there rule, instead of temp-range ports, specify ‘ALL’ and apply… This should correct that there problem you experiencing…


    Happy Trialing, g00ng...


    Regards,
    Phant0m``
     
  12. g00ng

    g00ng Registered Member

    Joined:
    May 16, 2005
    Posts:
    4
    I thought that's not the problem, because I had reload and try both the standar ruleset and enhanced ruleset, which supposed to open ALL ports for 'TCP : Authorize most common Internet services' if I'm not wrong.

    Maybe I'll try to check this setting if the error happen again, as I cannot simulate the error to occur.

    Thanks a lot for quick reply.
     
  13. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    No, it is the same for both rulesets...
     
  14. g00ng

    g00ng Registered Member

    Joined:
    May 16, 2005
    Posts:
    4
    Hi Phant0m, thanks for the info.

    The error just occured, and I tried to set ‘TCP : Authorize most common Internet services’ to ALL instead of 1024-5000.
    Seems like there was no effect.

    I quit and restart LnS a few time, and I got the connection back.
    Now I'm not sure if the error is from LnS.
    It might be from ISP, just stuck for a few moment.

    I'll need some time to confirm it.

    Thanks.
     
  15. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hi g00ng

    If you wouldn’t mind please e-mail me the log file that is located in \soft4Ever\looknstop\logs\ directory containing today’s timestamp, thanks.
     
  16. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    For the rule update to be processed, don’t forget to ‘Apply’ button it… :)
     
  17. ugly

    ugly Registered Member

    Joined:
    Mar 21, 2005
    Posts:
    276
    Location:
    Romania
    Any idea how to do with DC++ & LnS ?
     
  18. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hi ugly

    I can help but please if you don't mind I have some questions, first question is the connection type, and if you using a Router :)
     
  19. ugly

    ugly Registered Member

    Joined:
    Mar 21, 2005
    Posts:
    276
    Location:
    Romania
    Broadband -WAN Miniport.
    No router. Enhanced roules set.
     
  20. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Thanks, now can you give us some logfile entries for about the time you tried DC++ and experienced problems… The log files are found in \soft4Ever\looknstop\logs\
     
  21. ugly

    ugly Registered Member

    Joined:
    Mar 21, 2005
    Posts:
    276
    Location:
    Romania
  22. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hi

    The soft4Ever rule named DirectConnect.rie for DC-based p2p software permits a single port 1412 over ‘TCP or UDP’, and if you don’t specify just this single port and instead specify a range or no ports, you will have problems.

    Is your Internal IP address (shown on the Look ‘n’ Stop – Welcome page) different then your External IP address (shown by visiting www.myipaddress.com), if so then you really should be using Passv-mode instead of active-mode.

    From what I can see, you’ll need to verify it works, I don’t do DC…

    Rule changes needed in EnhancedRulesSet.rls when running in active-mode with no port specified,

    - ‘TCP : Authorize most common Internet services’, change from Temp-range 1024-5000 to ‘ALL’ or at minimum expand the range to 32000 (1024-32000)
    - ‘UDP : Any other UDP packet’, change from rule deny to rule permit, and might be good idea to remove the logging flag on that rule… Also you could restrict this rule ports from ‘ALL’ to temp-range like exactly shown with the previous rule…

    :D
     
  23. ugly

    ugly Registered Member

    Joined:
    Mar 21, 2005
    Posts:
    276
    Location:
    Romania
    Thank you very much for your answer.:D
    Unfortunately it didn't work for me.:'(
    I'm using an other firewall now and my DC++. Not so light as LnS , but ...

    Best regards.
     
Thread Status:
Not open for further replies.