4.0.437 disable splash via config or policy

Discussion in 'Other ESET Home Products' started by Bakker, Jul 21, 2009.

Thread Status:
Not open for further replies.
  1. Bakker

    Bakker Registered Member

    Joined:
    May 28, 2008
    Posts:
    90
    We deploy NOD32 via the RA server. We have the package configured with an XML that has "show splash screen at startup" disabled.

    However after a deployment the splash screen still shows and the checkbox in advanced configuration is still checked. Also applying a policy to these computers that should force the splash screen to off seems to have no results.

    The only way to disable the splash screen seems to be to disable it on each machine, one by one.

    I've double checked the configuration for the package and the policy settings. there is no overriding policy. View Merged only shows the setting for "show splash screen at startup" as "no".

    Has anyone noticed this behavior before?
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Since this is a per-user setting, did you also enable the "Suppress user settings" option?
     
  3. Bakker

    Bakker Registered Member

    Joined:
    May 28, 2008
    Posts:
    90
    I think i've unraveled the mystery.

    Our deployment config did not have "Supress User Settings" checked. This accounts for the fact that the splash screen did show up after a fresh install.

    However our policy did have this setting checked, so it should have overwritten this setting shortly after deployment (policy update and computer connect settings have been set to 1 minute for testing perpouses).

    As i've experienced so far... when you change something through the policy, and it takes effect on the client, it reflects the changes in the advanced configuration window. For example when i disable "Self Protection" via the policy... the checkbox in Advanced Configuration becomes unchecked.

    When you make a change to the "show splash screen at startup" via the group policy the setting DOES take effect but the checkbox DOES NOT get unchecked. It however does get unchecked after a reboot. So far this is the only setting i've experienced this behavior with.

    I've tested the above with 3 computer so far. Checkbox for "show splash screen at startup" does not get unchecked when changing the policy untill AFTER a reboot. I've also verified that the policy did take effect on the client by unchecking other settings (like the self protect function) these did get properly unchecked.. thus the policy took effect.
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    A restart of egui.exe is required for changes in settings concerning gui to take effect.
     
  5. Bakker

    Bakker Registered Member

    Joined:
    May 28, 2008
    Posts:
    90
    While it is understandable that changes to the UI require a restart of the UI itself. It is kind of odd that UI changes pushed out from an RA server are not reflected in the settings, while this is the case with non UI changes that are pushed from RA.

    In the end it's not really a problem since the settings due take effect. It's just odd that the configuration doesn't reflect the changes made untill the UI client is restarted.
     
Thread Status:
Not open for further replies.