2 PC Network using XOver cable ?

Discussion in 'LnS English Forum' started by Defenestration, Sep 14, 2007.

Thread Status:
Not open for further replies.
  1. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,086
    I've connected 2 PC's with a crossover cable, and have imported the File Sharing rules (as found on LnS website). I'm also using Phant0m's rule-set.

    When I click on My Network Places->Mshome in Explorer, an error is displayed saying "Mshome" is not accessible and the LnS log is showing:

    "Block: All other packets" UDP 255.255.255.255 Ports Dest 137 Src 137

    The UDP: Share rule that was imported already covers ports 137-139, but only allows for source and destination addresses of 192.168.0.0 with a mask of 255.255.0.0.

    What is the best way to solve this problem to allow for UDP communication on ports 137-139 with IP address of 255.255.255.255 (ie. can the current rule be modified, or should I just create a new rule) ?

    BTW, is this kind of UDP communication is normal for file sharing as it's not allowed in the standard file sharing rule ?
     
  2. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,086
    I forgot to mention the source IP address of the blocked UDP packets is my Internet IP address, the the destination IP address is the 255.255.255.255
     
  3. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    You should try to create a new specific rule to allow these packets.

    Usually it is not required. I think it's only for discovering the other machines on the local network. If you put a shortcut to the remote machine on the desktop, maybe the rule won't be required.

    The problem of the rule is you will accept broadcast from any machine, but this is not a problem if the 2 PC are directly connected.
    And by the way, are you sure it's normal Look 'n' Stop is configured to filter this network interface ? If your 2 PC are connected together, I guess there is another network interface for the internet connection, and this is the one to be monitored by Look 'n' Stop.

    Regards,

    Frederic
     
  4. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,086
    My laptop is running 32-bit XP Home SP2 and my Desktop is running XP Pro x64 SP2. I have my laptop Ethernet card configured to be IP address 192.168.0.1 and my desktop set to be 192.168.0.2.

    Both machines have LnS installed, and are set to Automatically select the Network interface. Both are configured to exclude the following IP addresses:

    "10;169.254;192.168.0.1;192.168.0.2;127.0.0.1"

    While the 32-bit version of LnS does not list the ethernet card under network interfaces, the 64-bit version does. Does this mean this is a bug with the 64-bit version ?

    When excluded, does this mean LnS will not perform any filtering on the traffic (ie. so the File Sharing rule is not needed) ?
     
  5. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Are the computers connected to internet through this IP ? or do you have other network interfaces with other IP address for the internet connections ?
    Here you should mention only the IP Look 'n' Stop should not filter.
    So, if you have another IP for the internet connection, this is OK. If the internet connection is using 192.168.0.x, these IP should not be there.
    All network interfaces should appear there. So, of there is a problem, it is more on the 32-bits version side. What is the list of network interfaces for this version ?
    The exclusion IP List is used by Look 'n' Stop to automatically select the interface to be filtered. When there are several interfaces in the options, Look 'n' Stop will choose the first one of the list having an IP not excluded. If all network interfaces have an IP which is in the exclusion list, the first network interface of the list is chosen anyway.
    If you have finally 2 network interfaces per computer, one for internet, and one local to connect the PC together, yes, Look 'n' Stop should be filtering the internet connection interface, and the sharing rule for the local network is not required.

    Frederic
     
  6. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,086
    I currently have a USB ADSL modem for connecting to the Internet. If I want to use my laptop for connecting to the Internet, I connect the modem to the laptop. If I want to use my desktop for connecting to the Internet, I connect the modem to the dekstop. LnS shows this network interface as a WAN miniport.

    Both the laptop and dekstop also have network cards and I have connected a crossover cable between these two cards to create a simple two machine network, so I can share files between the two machines.

    My Internet IP address is different from the LAN IP addresses.

    Re. the LAN network interface not appearing on the 32-bit version of LnS - I have LnS configured to perform an Extra Save of the registry settings, and when I re-installed LnS I used this .reg file to restore all my previous settings. Could this be the cause ?
     
  7. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Ok, in that case, the selected network interface should be the Wan Miniport one on both sides, the IP exclusion list is properly configured, and normally the Sharing rule are not required.

    I don't know why the LAN network interface is not appearing on the Win32 version. The problem happens sometimes when connecting a new USB adapters (and reinstalling Look'n' Stop solves the issue), but with an ethernet card, it is strange.

    Do you have one PC using the Win32 and the other one the x64 (so actually it could be linked to the PC and not the version of windows) ? or did you notice this difference for the same computer (and it that case you have a dual boot Win32/x64) ?

    Frederic
     
  8. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,086
    It's possible this might be because I imported settings from a previous installation of LnS. I'll do a bit more checking.

    I have my laptop using the Win32 version, and my desktop using the Win64 version.

    The exclude list is definitely not working for the Win64 version. I had it set to automatic selection, and it selected my onboard network interface whose IP equalled one that was in the exclude list.
     
  9. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,086
    I found out why it's not appearing in the list. t's because while trying to get the file sharing working, I disabled the LnS driver under LAN Properties. When I enabled it again, it appears in the list.
     
Thread Status:
Not open for further replies.