XeroBank: TAP-Win32 Adapter V9

Discussion in 'privacy technology' started by Pleonasm, Jun 23, 2008.

Thread Status:
Not open for further replies.
  1. Pleonasm
    Offline

    Pleonasm Registered Member

    After uninstalling XeroBank (2.0.0.14b) and successfully running the XeroBank Installer 2.0.0.15a on Windows Vista (32-bit), I am unable to connect to the XeroBank network. When xB VPN launches, the splash screen and the usual sequence of messages appears (ending in “Launching VPN client…”) — however, no connection is established, no OpenVPN GUI icon appears in the System Tray, and the Windows Task Manager does not list any xB or OpenVPN processes.

    In looking at Control Panel\Network and Internet\Network Connections, I noticed that the status of the TAP-Win32 Adapter V9 is listed as “Network cable unplugged”. Therefore, the cause of the problem might be that this adapter was not installed or initialized properly.

    What is the recommended solution?

    Thank you.

    P.S.: My previous XeroBank installation (2.0.0.14b) worked well, and this problem with the TAP-Win32 Adapter V9 did not arise.
    Last edited: Jun 23, 2008
  2. SteveTX
    Offline

    SteveTX Registered Member

  3. Pleonasm
    Offline

    Pleonasm Registered Member

    As a helpful hint to others who may experience this difficulty, I solved the problem by:

    • Downloading the OpenVPN installation file from OpenVPN Downloads
    • Uninstalling xB VPN, using Start | All Programs | XeroBank Uninstaller
    • Installing xB VPN which succeeds in installing the application but not the VPN driver (i.e., TAP-Win32), as listed in Control Panel | Network and Internet | Network Connections
    • Running the OpenVPN installation file, and selecting only the TAP-Win32 Virtual Ethernet Adapter component to install
    • Launching xB VPN, which then detects and uses the VPN driver
    The problem of xB VPN not installing the VPN driver (TAP-Win32) occurs with the XeroBank Installer 2.0.0.15a, containing either xB VPN 2.1.0.0RC7b or xB VPN 2.1.0.0RC7c, based on my experience.

    Acknowledgement: The core idea here was first reported by elumineX in this thread (post #14).
  4. SteveTX
    Offline

    SteveTX Registered Member

    Very odd. I've got it working in Vista x86 and Vista x64. Looks like more vista work required. i think I've got an "ultimate" solution... should be done today.
Thread Status:
Not open for further replies.