WG not saving prefs

Discussion in 'WormGuard' started by Defenestration, Aug 1, 2005.

Thread Status:
Not open for further replies.
  1. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,083
    For example, if I un-check "Deep-Search Files" and then click Done, when I restart WG this checkbox in enabled again. The same goes for the "On Blocked-File Execution"

    I have tried re-installing it but that doesn't help.

    I have been experimenting with disabling some XP Services to get a leaner machine. Could this have anything to do with WG mis-behaving ?
     
  2. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Hi, Can you check that wguard.dll is being injected into running processes please? Process Explorer or Faber Toys can show you this.
    I am concerned that something may have stopped WG from installing properly. :)
     
  3. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,083
    You are right that it's not being injected into runnning processes. I have since tried uninstalling WG, rebooting, disabling all resident protection, and then reinstalling WG, but it's still not being injected into running processes.

    Any ideas ?
     
  4. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,083
    I was wrong. It is being injected into explorer.exe which in turn is running all the other apps. Is this correct ?

    However, it's still not remembering settings.
     
  5. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Hmm, I am not sure about this one, we will have to await a DCS response as I am not sure what services might affect WormGuard or what other actions could cause your problem.
     
  6. richrf

    richrf Registered Member

    Joined:
    Dec 11, 2003
    Posts:
    1,907
    Not remembering settings on mine either.

    Rich
     
  7. snowbound

    snowbound Retired Moderator

    Joined:
    Feb 18, 2003
    Posts:
    8,723
    Location:
    The Big Smoke
    It never has on mine.( had WG for over 2 yrs now)


    snowbound
     
  8. Chalawah

    Chalawah Registered Member

    Joined:
    Jul 26, 2005
    Posts:
    75
    Location:
    Victoria Australia
    I had this problem too, and all I got from DiamonCS was " Try installing this pack for TDS/Wormguard first - just the first item, MS VB6 Runtime SP6
    http://tds.diamondcs.com.au/index.php?page=files "

    Seems to have fixed the holding the settings issue, but I have a new problem now which is that with WG protection enabled I cannot right click or double click to open any program shortcuts or files of any type on my Desktop. Some times I can drag then to My Documents and open them there...but not always. As soon as I disable protection in WG I can right click or double click to open all shortcuts and files on Desktop or wherever...

    I'd be intereseted to receive help for this issue, but don't want to distract from this thread....maybe the two are related?

    Cheers

    Julien
     
  9. Jooske

    Jooske Registered Member

    Joined:
    Feb 12, 2002
    Posts:
    9,713
    Location:
    Netherlands, EU near the sea
    Hi there,
    How are the names of the sortcuts? shortcut.1.exe and such double extensions?
    How about renaming to Program1 Program1 withouth any further extensions?

    Did you reboot after installation of the VB6 ?
     
  10. Chalawah

    Chalawah Registered Member

    Joined:
    Jul 26, 2005
    Posts:
    75
    Location:
    Victoria Australia

    Hi Jooske

    I did reboot after installing VB6

    As far as the names of the shortcuts this is all new ground for me but I am very keen to be brought up to speed...

    I right click the short cuts and select properties but I cannot see/find any information that you request...

    Are you able to explain further?

    Thanks for your time.

    Julien
     
  11. Jooske

    Jooske Registered Member

    Joined:
    Feb 12, 2002
    Posts:
    9,713
    Location:
    Netherlands, EU near the sea
    On your desktop, look at an icon you want to click, what is the name of the icon?
    Is it Jullian or Julian.1.exe, i just mean is it a possible double extension or a single name? Seen my examples about the test.vbs and test.vbs.vbs files and kind of tests? WormGuard is supposed to block double extensions.
    Also if your shortcut to a program would be to a double extension like tds.3.exe wormGuard should stop it and at least warn you for a double extension, if you open an attachment in an email for instance file.doc.eml or file.txt..........exe all that would be blocked to warn you and will tell you what the reason of blocking is.
    The program is exactly doing it's job by the sound of it.
    If you rightclick your desktop icons, , properties, you'll see the exact pathname where it goes too and what is the executable file it points to and that will give you more information.
    Give some examples please of names WormGuard will not allow you to open.
    If those are malware programs WormGuard will not allow you to run them even with single file names.
     
  12. Chalawah

    Chalawah Registered Member

    Joined:
    Jul 26, 2005
    Posts:
    75
    Location:
    Victoria Australia
    Hi Jookse

    I had a busy family weekend and couldn't make the time to reply to you..but here goes now.

    With WG enabled [and allowing a full ten seconds or so for the '.inf' file to be loaded before clicking 'OK']...

    If I click on a '.exe' software prog, as if I was going to install it [ in my working example I used 'Wizmo.exe'] WG did not question this at all.

    If I right click or double click to open a Word .doc, it won't open until I disable WG [and I get no warning from WG].

    If I double or right click on TD3.exe shortcut then I get no warning message from WG.

    If I double or right click on Norton AV 2004 shortcut [which is a .nsi type] NAV will not open and I get no warning message from WG.

    If I try and open CCleaner shortcut [.exe type] it opens and I get no warning from WG.

    The inability to open some of the above doesn't always happen, but does happen more often than not. As soon as I 'Remove Protection' from WG I always have absolutely no problem openning anything on my computer, but as soon as I 'Install Protection' then I get trouble again.

    In WG the default 'Block List' hasn't been changed, and there are no entries in the 'Allow List'.

    If I try and open a .htm document that I have saved from say,Yahoo!Mail when using my Mozilla1.7.8 then WG does block and offer the options for which I placed ticks in boxes for.

    Hope this helps.

    Thanks for the help and time you are giving me - much appreciated.

    Julien
     
  13. Tassie_Devils

    Tassie_Devils Global Moderator

    Joined:
    May 8, 2002
    Posts:
    2,514
    Location:
    State Queensland, Australia
    hmmmm, this is interesting indeed.

    Now, occasionally I have the same problems regarding shortcuts on Desktop, double click and nothing happens...

    for eg: I always save files to desktop to scan with AV, etc. and when clean, double click to open. Now, sometimes, nothing happens. I then try to actually open the program itself via desktop shortcut, same result.

    Then, I go to Start/Programs and select the program and it will open, then I have to go open on the document I want [say a PDF in Acrobat] via File/Open....which will work.

    This happens not frequently, but enough to be dang annoying, and I have never associated it with WG.

    To then fix the problem, I have to reboot and it works fine again for quite a while until the next time.

    Also, to further add to woes, sometimes, when I open Windows Explorer and just simply right click on a file, the whole desktop disappears and refreshes for no reason.

    I shall, the next time this happens, try disabling WG first, and see is it is the culprit as purported.

    And, the Deep File Search I did a test on also by unchecking, clicking 'DONE', re-opening and it is still checked.

    Cheers, TAS
     
  14. hitbit

    hitbit Registered Member

    Joined:
    Nov 25, 2005
    Posts:
    35
    Location:
    Dublin Ireland
    Hi There,
    When I right click my MailWasher or Windows Explorer decktop shortcuts I get an error message "Windows Explorer has encountered a problem and needs to close". Have no problem with other shortcuts. Everythings fine when double clicking. If anyone has a fix for this I would appreciate the info, if not I will live with this most miniscule of inconveniences and continue to enjoy the protection and safety offered by WormGuard.

    hitbit
     
  15. Gavin - DiamondCS

    Gavin - DiamondCS Former DCS Moderator

    Joined:
    Feb 10, 2002
    Posts:
    2,080
    Location:
    Perth, Western Australia
    The non saving preferences occurs on some machines and doesn't on others, most likely compatibility. The best you can do is try running WGUARD.EXE In Win2000 or Win98 compatibility mode and hope that it works for you. It very well may :)

    To do this, edit the shortcut properties under Compatibility
     
Thread Status:
Not open for further replies.