Vista SP2 RTM - be careful!

Discussion in 'ESET NOD32 Antivirus' started by jimwillsher, May 2, 2009.

Thread Status:
Not open for further replies.
  1. Kona
    Offline

    Kona Registered Member

    I am having major problems with NOD32 and Vista x64 SP2 on a fresh install - BSOD's all over the place from eamon.sys. Turning off self-defence in NOD32 fixes the "unable to start realtime protection" - I'll send a logfile over and see if you guys can fix this, unfortunately we have a lot of customers running NOD32 so if this update hits Windows Update and this issue isn't fixed in time - I'm going to be on the phone looking for an immediate fix ;)
  2. jimwillsher
    Offline

    jimwillsher Registered Member

    Other posts state that there's a new build due today, so hopefully it addresses the SP2 issue.

    As SP2 isn't publicly available yet, and there are known problems with ESET and SP2, I suggest you hold off installing SP2.
  3. hclarkjr
    Offline

    hclarkjr Registered Member

    what posts are you referring too? i have not seen any mention of a new build coming
    Last edited by a moderator: May 20, 2009
  4. jimwillsher
    Offline

    jimwillsher Registered Member

  5. hclarkjr
    Offline

    hclarkjr Registered Member

  6. hclarkjr
    Offline

    hclarkjr Registered Member

  7. subhum4n
    Offline

    subhum4n Registered Member

    I tried the new build but its still the same. After a clean uninstall and a reinstall ... the first thing after a reboot is the red icon. :(
    PLUS the anti virus crashes my computer while scanning a file from live messenger and this can be produced 100% of the time when the red icon is up..I lost so much data because of it... i wonder what Eset is doing about this ... its already +20 days since the release of SP2 RTM; not counting the amount of days SP2 is in RC... Eset should have tested it thoroughly.
  8. vulliw
    Offline

    vulliw Registered Member

    Blue Screen of Death with esset AntiVirus 4.0.424.0

    problem with eamon.sys !!!!!

    WARNING: Whitespace at end of path element
    Symbol search path is: srv*c:\symbols*http://msdl.microsoft.com/download/symbols
    Executable search path is:
    Windows Server 2008/Windows Vista Kernel Version 6002 (Service Pack 2) MP (2 procs) Free x86 compatible
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 6002.18005.x86fre.lh_sp2rtm.090410-1830
    Machine Name:
    Kernel base = 0x81e12000 PsLoadedModuleList = 0x81f29c70
    Debug session time: Wed May 20 12:14:51.198 2009 (GMT+2)
    System Uptime: 0 days 0:00:27.901
    Loading Kernel Symbols
    ...............................................................
    ................................................................
    ...........
    Loading User Symbols
    Loading unloaded module list
    ....
    *******************************************************************************
    * *
    * Bugcheck Analysis *
    * *
    *******************************************************************************

    Use !analyze -v to get detailed debugging information.

    BugCheck D1, {656c6946, 2, 0, 9a20a1de}

    Unable to load image \SystemRoot\system32\DRIVERS\eamon.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for eamon.sys
    *** ERROR: Module load completed but symbols could not be loaded for eamon.sys
    Probably caused by : eamon.sys ( eamon+51de )
  9. racketeer66
    Offline

    racketeer66 Registered Member

    There's a new kid on the block, Dude...this one has already been discussed deeply.
    Hail the 4.0.437!
  10. hclarkjr
    Offline

    hclarkjr Registered Member

    i just upgraded to new version. so far no trouble at all for me.
  11. ASpace
    Offline

    ASpace Guest

    4.0.435/4.0.437 - there seems to be an improvement ...
  12. lucassp
    Offline

    lucassp Registered Member

    Does the new version work or not with Vista SP2?
  13. CivilTaz
    Offline

    CivilTaz Registered Member

  14. Kona
    Offline

    Kona Registered Member

    Still have the same issue with the new build. I can't even uninstall it using the uninstaller now, time to dig out manual uninstall instructions.
  15. hclarkjr
    Offline

    hclarkjr Registered Member

    no, new version does not work with SP2. my computer just started with it disabled. lets go ESET get it fixed
  16. Recall
    Offline

    Recall Registered Member

    Still random freezes with internet explorer with latest version. :rolleyes:
  17. vulliw
    Offline

    vulliw Registered Member

    And for now temporary fix is to disable self-protection in advanced setup. I know it's not official fix, but hey at least it works Self-protection is a new feature to V4, so by disabling it temporary we still get all new features of V4 except well....self protection

    note: to disable it you must roll the dice so to speak to get one of those times when NOD32 starts up ok. Otherwise you can't disable self protection because it's protected by self protection which is not working correctly

    JuliusB
  18. alexsch8
    Offline

    alexsch8 Registered Member

    I have uninstalled NOD32 x64 from my Vista Ultimate SP2 box via safe mode and installed the latest build and the problems have disappeared for me.

    I then tried installing it over the old version (424) on Server 2k8 x64 SP2 but that did not work. The file protection service still failed to start. So I booted into safe mode and ripped out NOD32 (normal uninstall did not complete correctly). After that I installed NOD32 x64 fresh and no more issues for me.

    30 minutes later: I spoke too soon. Server 2k8 x64 SP2 just BSOD'd and now I am back to the red NOD32 icon where file protection does no longer work.
    Last edited: May 21, 2009
  19. Recall
    Offline

    Recall Registered Member

    Thanks, this seems to have stopped the freezing. Will have to use for a few days to be certain, but at least this gives ESET an idea of what module is causing the issue.

    Still disgusted with their lack of official response. I just persuaded my father to get a 3 licence deal and my renewal is coming up. Starting to regret it.....
  20. Kona
    Offline

    Kona Registered Member

    I have reverted to using v3 on Vista SP2 RTM as it's the only way to get NOD32 to work. I find it shocking that there has been no acknowledgement of this problem from ESET, especially as this has been going on a while now.

    Being a reseller of ESET products (and having a userbase of 500+) I am seriously considering recommending other products when customers come to renew as this type of service is simply not acceptable when it comes to major problems like this.
  21. OneTwoOneTwoOne
    Offline

    OneTwoOneTwoOne Registered Member

    This may not the appropriate thread to post this in, but it seems we're all having similar problems.

    I'm running XP x64 with SP2, fully updated. Every time I install the latest version of NOD32 4.x everything works great. Upon restarting the computer I BSOD as the system

    boots up unless I select 'Last Known Good Configuration'. From there NOD32 ceases to work. Egui.exe is loaded upon start-up but does not respond. Closing it manually and

    opening up NOD32 does not work either. No response is given. I can run the repair module but then the NOD32 icon goes red and informs me a critical problem has occurred and

    I should promptly reinstall the program.

    Removing the program seems to fix the issue if I remember correctly, but a reinstallation only causes the problem to reoccur next boot.

    Upon arriving at my desktop I am given the error msg:
    [Generic Host Process for Win32 Services
    Error Signature:
    EventType : BEX64 P1 : svchost.exe P2 : 5.2.3790.3959 P3 : 45d69a64
    P4 : unknown P5 : 0.0.0.0 P6 : 00000000 P7 : 000007ff660287d4
    P8 : c0000005 P9 : 0000000000000008]

    My Sysinspector log is too large to post via attachment so I've put it in a rapidshare file: ~Link removed. Log contains private information.~
    Last edited by a moderator: May 24, 2009
  22. ronjor
    Online

    ronjor Global Moderator

    Hello OneTwoOneTwoOne,

    Your link was removed as it contains private information. Send your log, if an ESET moderator requests it, according to these directions. >>

    How do I create a SysInspector log?
  23. hclarkjr
    Offline

    hclarkjr Registered Member


    see post number 20 of this thread for place to send the sysinspector log too.
  24. hclarkjr
    Offline

    hclarkjr Registered Member

    ronjor, why not sticky this thread till this issue is resolved?
  25. flyrfan111
    Offline

    flyrfan111 Registered Member

    Probably a good idea since SP2 could be released through Windows update at anytime now.
Thread Status:
Not open for further replies.