Vista SP2 RTM - be careful!

Discussion in 'ESET NOD32 Antivirus' started by jimwillsher, May 2, 2009.

Thread Status:
Not open for further replies.
  1. jimwillsher
    Offline

    jimwillsher Registered Member

    Following on from another thread on this forum, discussing SP2 RC. SP2 is now RTM and is available to MSDN and TechNet subscribers (I'm MSDN). It's due to be publicly available on May 5th.

    Using EAV BE x64 4.0.424, installing Vista SP2 RTM causes a BSOD during phase 3/3 of the service pack install. Rebooting causes the same. As such, my OS is hosed.

    I'm not bothered, as I was planning to wipe and install Win 7 RC anyway, but I thought others should know.

    So to confirm: Installing Vista SP2 x64 with EAV BE 4.0.424 installed, there's a strong chance you'll end up in a mess.

    I'm sure ESET will be working on this; I just hope (for their reputation) that it's something which changed between RC and RTM, since RC has been available for testing a long time.



    Jim
  2. ASpace
    Offline

    ASpace Guest

    Hi .

    Here in the forum there are users who have reported issues with Vista/2008's SP2 . However , are you sure that the BSOD has actually been caused by ESET NOD32 and not by something else ?
  3. jimwillsher
    Offline

    jimwillsher Registered Member

    eamon.sys was listed as the faulting module on the blue screen.


    Jim
  4. ASpace
    Offline

    ASpace Guest

  5. jimwillsher
    Offline

    jimwillsher Registered Member

    I'm sure the ESET guys will be "on the case", trying to get to the bottom of the cause. I can only assume that Microsoft changed something between RC and RTM that broke ESET, otherwise they'd have caught this when they tested with the RC.....if they did...


    Jim
  6. GAN
    Offline

    GAN Registered Member

    I been using Vista SP1 x64 with nod32 v4.0.424.0 and previous v4 releases without any serious problems. Now i uninstalled nod32, did a manual cleanup, installed SP2 and then reinstalled nod32. Windows works fine and no bluescreen, but nod32 doesn't work properly. After the installation everything worked just fine, but after a restart the realtime protection is disabled and i'm unable to enable the realtime protection again. Nod32 says that "a serious error occured while starting real-time file system protection". The logs contains an error as well where it says that "an error occured while starting proxy server" so http/pop3 scanning doesn't work either. Hopefully Eset is already working with the SP2 compatibility.
  7. bathisland
    Offline

    bathisland Registered Member

    Thank God all is well here with no problems whatsoever. The install went fine, have restarted many times and no BSOD or disabled AV. :)

    U guys running 4.0.424o_O
  8. dannyboy
    Offline

    dannyboy Registered Member

    for what it's worth, I have EAV 4.0.424 on Vista x64, and just installed the SP2 RTM with no issues whatsoever. Maybe there's some conflict with certain hardware/chipset combinations? Mine is a Gigabyte board with Intel P35 chipset.
  9. Kanna
    Offline

    Kanna Registered Member

    I'm not sure why only some of us are having problems, but comparing hardware configs with dannyboy I don't think that it's a hardware issue. My testing is done on a Intel C2D 6750, 8GB ram, Gigabyte P35-DS4v2, Intel ICH9R AHCI, and an OCZ vertex SSD.
  10. dannyboy
    Offline

    dannyboy Registered Member

    yeah based on your setup I'd have to agree, as I have identical CPU, 4Gb RAM (PC8500), P35-DS3R and Intel AHCI
  11. bodean
    Offline

    bodean Registered Member

    HIGHLY doubt they are.
    It's been reported on here for over 2 months now, and not one comment from them on it. Also sent in reports via email to them, and never got it fixed.
    What a shame.
  12. MOM2009
    Offline

    MOM2009 Registered Member

    this seems to be a permission problem.

    on my computer NOD antivirus v4 works only if UAC is disabled in vista sp2 rtm
  13. GAN
    Offline

    GAN Registered Member

    According to this post:
    http://www.wilderssecurity.com/showpost.php?p=1459184
    they are testing Eset software with SP2 for Vista and 2008. Hopefully there will be an update very soon.
  14. GAN
    Offline

    GAN Registered Member

    One of the first thing i did after installing Vista is to disable UAC completely. So i never had UAC enabled during the installation/uninstallation of nod32 on this computer. Still having issues. When SP2 installed the uninstallation of nod32 v4 doesn't work correctly either. One service where not removed during uninstall which gave me problems trying to delete the Eset folders, reg keys and also wouldn't let me disable/stop the service. As soon as i managed to stop/disable that service i had no problems deleting the leftovers from nod32. So i guess this have to do with the self protection of nod32 and not Vista security in this case.
    I never had this kind of issues with nod32 (any version) before Vista SP2.
  15. GAN
    Offline

    GAN Registered Member

    I finally managed to install nod32 v4 when Vista SP2 where already installed. I tried three times with the same problem where nod32 where not working properly after the installation and every time i imported the settings i exported before i installed SP2. The last time i did not import the settings and just restarted the computer with the default settings. After the reboot i changed the settings manually instead of importing the xml file and restarted once more with no problems. I have no idea if this is a coincidence or if importing the setting caused this problem, but at least now everything is working fine.....so far.
  16. dannyboy
    Offline

    dannyboy Registered Member

    well it seems I spoke to soon. As my PC was booting up this morning, eamon.sys caused a BSOD, just as the desktop was loading.

    I let it reboot to see if it would happen again, but it booted fine the second time, so it seems to be an intermittent issue.

    Problem signature:
    Problem Event Name: BlueScreen
    OS Version: 6.0.6002.2.2.0.256.1
    Locale ID: 2057

    Additional information about the problem:
    BCCode: 3b
    BCP1: 00000000C0000005
    BCP2: FFFFFA6008006A8F
    BCP3: FFFFFA6008705D20
    BCP4: 0000000000000000
    OS Version: 6_0_6002
    Service Pack: 2_0
    Product: 256_1
  17. jimwillsher
    Offline

    jimwillsher Registered Member

    Yeah, I don't think it's a UAC problem as I to have that disabled.

    Interesting that I'm now running Win7 RC x64, with ESET 4.0.424, and it's all going great!


    Jim
  18. Brama
    Offline

    Brama Registered Member

    I confirm that with a i7 920 processor and a X58 MB, with Vista 32 SP2 RTM I can install without any trouble the SP, but I have disabled real time file checking and an unknown error 0x004.

    It is strange that if I scan the C: drive to check and correct errors, at next reboot ESET is working properly.
    If I reboot again, red icon on the taskbar with realtime checking disabled and error 0x004.

    I use last 4.0.424.0 version.
  19. hclarkjr
    Offline

    hclarkjr Registered Member

    i am running vista ultimate 64 bit with service pack 2 and the latest NOD32 version 4 with no trouble at all. i did a clean install with a integrated DVD though and not an upgrade from service pack 1. i should mention that i had one start up with it disabled like is talked about here but that was on a restart where some files were updating so that may have been the cause. i just restarted again and all has been good since. i have been running it 3 days so far and have had no problems doing scans and so forth. NOD even alerted me that i needed to download some updates from windows update which surprised me.
  20. agoretsky
    Offline

    agoretsky Eset Staff Account

    Hello,

    ESET is currently in the process of testing Service Pack 2 for Microsoft Windows Vista and Microsoft Windows 2008.

    If anyone is having trouble running ESET's software on a computer running with Service Pack 2, please use ESET SysInspector to create a log file and then send me a private message for instructions on where to send it for review.

    Regards,

    Aryeh Goretsky
  21. Forellenblau
    Offline

    Forellenblau Registered Member

    I set up Windows Vista 64bit those days and after installing SP2 RTM i tried to install EAV 4.0.24. But the installer quits with an unknown error - UAC is completely disabled.

    So i'll wait for a fix...

    Forellenblau
  22. hclarkjr
    Offline

    hclarkjr Registered Member


    you have private message. upon cold boot today it was disabled for me, i rebooted and it is fine once again. any word on when new version is coming Aryeh?
  23. rno
    Offline

    rno Registered Member

    I'm experiencing same problems on Vista 64 SP2 RTM. Some times NOD32 starts just fine, another time it reports that it needs to be reinstalled. Hopefully we have updated version of NOD32 soon that is fully SP2 compatible.
  24. xxJackxx
    Offline

    xxJackxx Registered Member

    Interesting. I have a desktop with Vista SP2 x64 and laptop with Vista SP2 x86 and have not had any problems. For those having issues it must be specific to their hardware or something to do with their configuration. I have UAC enabled on both of mine, so I really doubt UAC is an issue. I hope the cause of the problems some are having is found, but I haven't had any problems with the 4.0.424.0 build.
  25. hclarkjr
    Offline

    hclarkjr Registered Member

    another thing i have found is that NOD takes real long time to do full system scan. i started a full system scan last night and had to stop it after over 2 hours. i do not have that many files that it should take that long. not sure if this is related to SP2 or not, i had no problems with it before this
Thread Status:
Not open for further replies.