Virus signature database update failed...

Discussion in 'ESET NOD32 Antivirus' started by gregd, Mar 23, 2011.

Thread Status:
Not open for further replies.
  1. gregd
    Offline

    gregd Registered Member

    Is anyone else seeing this this morning when trying to update NOD32 Antivirus?

    Virus signature database could not be updated
    General compiler error​

    I've tried numerous times to update and I'm getting the same error every time.
  2. ronjor
    Online

    ronjor Global Moderator

  3. gregd
    Offline

    gregd Registered Member

    Clearing the update cache seems to have resolved the issue.

    Thanks ronjor!
  4. ronjor
    Online

    ronjor Global Moderator

    Good deal. :)
  5. gregd
    Offline

    gregd Registered Member

    I spoke too soon. While the clear update cache worked yesterday, it's back to General Compiler Errors now.

    Some additional information.

    I'm using the remote admin console to update my clients (my workstation is a client).

    I'm on version 4.2.67 of the client and the rest of my office is on 4.0.424 and they're updating just fine.

    When I click "Clear Update Cache" and attempt to download, it will download this update below and then fail applying the update.

    http://i.imgur.com/Kece0.jpg

    So it looks like it's trying to apply nod530D.nup and it's failing. It's a large file, so I'm assuming it's attempting to install a newer client. I'm going to try a few other things, but if anyone has anything to add, please do.

    Edited to add

    I'm not allowing it to download pre-release files.
  6. Nick0
    Offline

    Nick0 Registered Member

    It sounds like you may have upgraded from 4.0 to 4.2 rather than an uninstall followed by install of 4.2.

    This general compiler error sometimes occures due to self defence from the previous version kicking in.

    Best option, Uninstall 4.2, reboot when asked, then remove (if still exist):
    C:\program files\eset
    C:\documents and settings\all users\application data\eset
    c:\programdata\eset

    Then you can do a clean install of 4.2, and you should be fine.

    This does not always happen with every upgrade from 4.0 to 4.2 but I have seen it in some cases.
  7. gregd
    Offline

    gregd Registered Member

    I upgraded a few months ago and it's been working fine until just a couple of days ago. Something in one of the sig files that would cause it do this?
  8. gregd
    Offline

    gregd Registered Member

    Short of a complete reinstallation, nobody has any ideas?
  9. jimwillsher
    Offline

    jimwillsher Registered Member

    If I were you I'd uninstall and then reinstall 4.2.71, it'll only take you two minutes. Hopefully that will cure it.


    Jim
  10. gregd
    Offline

    gregd Registered Member

    Well in order to get this working again, I uninstalled the previous version and then back-revved it to 4.0.437 and for now, I'm up-to-date.
Thread Status:
Not open for further replies.