UltimateDefrag v3 - is THIS the very best defragger ever?

Discussion in 'backup, imaging & disk mgmt' started by qazwee, Jul 21, 2010.

Thread Status:
Not open for further replies.
  1. TraumaDoc
    Offline

    TraumaDoc Registered Member

    Anyone have a good tutorial/guide for using winhex to edit the NTFS files such as $MFTMirr ?

    The problem I had seems to have come from compacting the MFT or something I think.

    On drives where bootdefrag would no longer work, I moved my files, reformatted within Windows and boottime defrag worked again even with 16KB clusters .... so it's not an incompatibility with 16KB clusters

    My 16KB cluster size system disk has an only 4KB $MFTMirror and I cannot edit it .... I've tried to edit and it's always locked or access denied - booting in windows in BartPE, in DDOS, etc. etc. I've used a boot disk to use TestDisk and when it asks me if I want to rewrite the $MFTMirr using the MFT and I answer Yes the system auto reboots and nothing was changed

    Nothing I can do allows me to edit or access or overwrite the $MFTMirr

    Suggestions o_Oo_O

    Please !

    I don't want to reformat yet if I don't have to and besides, doing this will be a good learning experience for any future issues

    Thanks !
  2. zfactor
    Offline

    zfactor Registered Member

    yeah im tempted to try this as well but it would be tested on a older celeron 1.46 laptop to see what happens. i will not be doing this just yet on my everyday laptop i use that should be fine with it though as its a i7 based
  3. DOSawaits
    Online

    DOSawaits Registered Member

    I don't see any evidence screenshot or stats of that 787% faster harddisk ?
    Could it be the author forgot to include it ? :gack:


    Compressing the most frequently modified files ? o_O :gack: :shifty:
    Code:
    a) the added latency is in no relation to the sequential read bandwidth of a modern drive
    b) it makes DMA useless
    c) it disables the buffer cache
    d) it makes asynchronous reads synchronous
    e) it disables sharing of mapped pages
    
    Especially c) d) and e) bear great evil.
    Last edited: Nov 4, 2010
  4. Isso
    Offline

    Isso Developer

    TraumaDoc - $MFTMirr size cannot be 4 KB on a 16 KB cluster-formatted volume, because the smallest $MFTMirr is one cluster size, that is 16 KB for your disk. So is seems indeed something is wrong with your file system. How did you find out that it is 4 KB?

    You can edit file content or attributes on NTFS using WinHex or other NTFS aware disk editor, but changing the file size is a rather difficult task requiring detailed knowledge of NTFS structures.

    You might try to intentionally corrupt $MFTMirr by say filling it with zeros and see if chkdsk fixes it, but you definitely should take a backup image before doing anything like that.


    zfactor - thanks for kind words!


    mike42 - I got your message with bug list - thank you for taking time to document them. Actually I didn't forget about those that you already pointed out before. It's just that we decided to work on other items for this release. I'll check the error -102 that you noticed. As for cancelling reboot after boot time defrag is done - sorry, it's not possible, because boot time module (and similar programs too -like chkdsk) modify the content of the disk directly - bypassing Windows file system driver. So if we don't reboot the file system driver will become confused and will BSOD.
  5. zfactor
    Offline

    zfactor Registered Member

    this new version fixed the error i was getting when running on a system with puran also installed. it def seems faster as well when defragmenting the drive also.
  6. TraumaDoc
    Offline

    TraumaDoc Registered Member

    Yes, I KNOW it shouldn't be 4KB in size - that's why I want to take care of it.

    I used both WinHex and RunTime's Disk Explorer to view the NTFS Files (of course specifically looking for the $MFTMirr size). it is 4096 of course and not 16KB as expected for my cluster size

    I've tried to edit the $MFTMirr with WinHex in Windows and in DOS using boot disks, etc. But no matter what method I use, I get a file access error and cannot save the changes. I've used TestDisk in Windows and DOS boot disk modes and TestDisk also cannot replace the MFTMirr by using the MFT.

    There must be a way but I'm just missing what it is

    I've tried to just do what you said - to fill with zeros but it won't allow me to save the changes.

    I'd really like to fix this rather than reimage -
  7. acuariano
    Offline

    acuariano Registered Member

    hey guys one question;..then what is better 4k or 16k after formating partition or drive?
  8. TraumaDoc
    Offline

    TraumaDoc Registered Member

    Cluster size performance is based on what kind/size of files you are storing on that drive.

    Very large files - many many MB such as video deserve larger cluster sizes

    Smaller files deserve small cluster size

    4KB is chosen as optimal for the average user - since average users have a combination of file sizes - where a system disk has many small files and commonly large files

    There is no reason to change them unless you have a specific purpose or need in mind

    I chose 16 KB cluster sizes for ONE reason - compatibility with with Windows 7 System Restore and VSS

    The REAL issue is how to solve my issue hehe :argh:

    That is the only reason I did it - to prevent the deletion of Restore Points when doing defrag
  9. Isso
    Offline

    Isso Developer

    zfactor - great to hear the problem went away.

    TraumaDoc - if you are getting access denied then it might be that you are just using the disk editor programs incorrectly. Try to connect the hard drive externally to another machine and edit it from there, also make sure the disk editor isn't working in read-only mode.

    acuariano - just use 4 KB, it's optimal and won't cause compatibility problems.
  10. acuariano
    Offline

    acuariano Registered Member

    thanks Trauma and Isso
  11. TraumaDoc
    Offline

    TraumaDoc Registered Member

    No - I am absolutely NOT in read only mode. I've done it in default mode and in the in-place mode and I always get an access denied error

    I've also take the disk out (this is all from my laptop having the issue) and put it in a USB adapter box to my desktop - and I still get the inability to access or write to the disk.

    I'm assuming this is also related to the issue of the $MFTMirr file specifically and not a whole disk problem or user error on my part.

    I just used the GParted boot disk and ran testdisk - it also found the MFTMirror mismatch (both in the boot environment as well as seeing in the start up evaluation log) - I said is successfully repaired the MFTMirror from the MFT (when it failed running testdisk from a dos boot or in windows itself).

    But, upon rebooting the system, the MFTMirr was unchanged and UD still won't degrag on boot with the same error of them not matching

    UGGGGGGGGGGggggggggggggggggggggggg

    There's gotta be a way to solve this
  12. zfactor
    Offline

    zfactor Registered Member

    when i choose the shutdown after defrag option i get a error pop up anyone else tried this yet??

    edit i uninstalled it and reinstalled and i didnt even put in my lic key yet and i still get the error its a yellow exclamation point and says gagoo_O

    i also tried installing on a system that has never had it before and once again ran in trial mode and same result??

    tried on yet one more system. this one has 28 days left of the trial and i get the same message "gago" only when using the shutdown after defrag option.. thoughts??
    Last edited: Nov 4, 2010
  13. mike42
    Offline

    mike42 Registered Member

    Confirmed. I have the "GAGO" message too. I guess, it is a left over debug thing.
  14. TraumaDoc
    Offline

    TraumaDoc Registered Member

    I still can't resolve this issue.

    If someone can point me to a tutorial or guide or something that can help simplify it for non-programmer who is smart enough to follow and learn it I'd appreciate it.

    I find this to be a flaw in UD - I've used Puran, PerfectDisk, O&O in the past 2 days and they all run boot-time defragmentation just fine.

    I truly prefer UD, but without boot-time defrag the program is essentially useless to me

    If anyone can help, I would appreciate it

    Thanks
  15. mike42
    Offline

    mike42 Registered Member

    But didn't you already confirm, that your $MFTMirr is corrupted? So why should it be a flaw in UD? I guess, the other defraggers simply ignore the corruption in your MFTMirr.
    But, honestly, I wonder why you don't just resetup your system. Really, I wouldn't spend so many days trying to fix a corrupted system meta file.
  16. TraumaDoc
    Offline

    TraumaDoc Registered Member

    Because of the point of the matter. I want to repair it if possible - since it will help me learn

    I don't think it's fair to say the $MFTMirr is actually "corrupt" rather it is incorrectly made/created/whatever

    In the last few minutes I did the following

    I created a WinPE recovery disk and booted and ran winhex. I WAS able to completely overwrite/fill the $MFTMirr with zero's .... and it saved

    I rebooted the system and in Windows confirmed that the $MFTMirr was still all zero's

    Rebooted with a chkdsk on startup and Windows found and repaired errors in the MFT Mirror

    Rebooted and the "new" $MFTMirr is still only 4KB (4096 bytes)

    The drive is 16Kb clusters

    While the file is ONLY 4KB and SHOULD BE 16KB, the actual contents of the 4KB $MFTMirr Does match the first 4KB of the $MFT as expected - it's just that the $MFTMirr is not the expected 16KB

    Confirmed that my 2 other partitions which are also 16KB clusters contain 16KB $MFTMirr files

    Rebooted again with UD set to boot time defrag and it still finds that the MFT Mirror is different - despite having been zero'd and "repaired" by Windows

    Is it possible to actually "delete" the file from the drive ? I wanted to resize the $MFTMirr in winhex to be a proper 16KB in size of data, but that's not possible as far as I can tell, since making the file larger will go into the next contiguous file and corrupt the data there.

    It's a matter of "pride" and principle - I'd like to fix it.

    I like to solve problems and determine the origin if at all possible

    Of course, I'm positive I'll need to just reimage - but I still want to know and try :)
    Last edited: Nov 5, 2010
  17. mantra
    Offline

    mantra Registered Member

    hi
    may i ask a question ?
    abaut the cool feature adjust new position

    with this feature i can move a file or folder in a deliberate position of the hard disk (partition)

    well it's cool but if i run a defrag ,ud 3 will defrag this file and move again

    i can select "exclude this file from subsequent automatic defrag" cool!

    but the file moved with the feature "exclude this file from subsequent automatic defrag" will not defrago_O


    is hard to add a feature to defrag the files moved with this feature without changing the posistion?


    thanks!:thumb:
  18. zfactor
    Offline

    zfactor Registered Member

    shutdown after defrag fixed in version 3.0.100.19
  19. TraumaDoc
    Offline

    TraumaDoc Registered Member

    Anyway

    Forced to format!

    So...

    Is this newest release of UltimateDefrag FULLY VSS compatible?

    Is it compatible both in Windows defragging and in Boot-Time defrag?

    If I do a boot-time will it delete my restore points from Windows 7 ?
  20. Isso
    Offline

    Isso Developer

    mantra,

    Yes I think you are right and we should add also "defragment the file in place" along with "excluding the file from subsequent defrag" option. Will add it to TODO list.

    TraumaDoc:

    I don't think there is any defragmentation program that guarantees to preserve all your restore points. The reason is that if you move files with fully VSS-compatible mode then you must be very lucky to defragment anything at all, because it's too strict. And even then still there is a possibility for old restore points to be deleted.
    So what VSS-compatibility normally means is an operation mode that causes the least file movements. We did quite a lot of testing and found out that if you use Consolidate mode with "Very fast" option turned on, or if you use "Fragmented files only" mode then there are very little chances for old restore points to be deleted (actually I was never able to get any deleted using that modes). So I recommend using either of that two methods if you have lot of restore points, or to not defragment at all - if all restore points are of critical importance.

    For boot time defrag - it may delete the oldest restore points too, just like ordinary defrag.
  21. Coolio10
    Offline

    Coolio10 Registered Member

    Hi Isso, is it possible to add a feature which allows defragging the whole drive during boot-time. I believe puran defrag is the only software which can do this, nothing wrong with being 2nd place :). I have many files which can't be defragged when windows is open, it would be nice to do this overnight.
  22. Boyfriend
    Offline

    Boyfriend Registered Member

    Adding boot time defragmentation will be very useful and cool feature.

    Raxco PerfectDisk Pro 11 can also defragment whole disk at boot time.
  23. zfactor
    Offline

    zfactor Registered Member

    i agree with this i would love a whole disk defrag at boot time
  24. TraumaDoc
    Offline

    TraumaDoc Registered Member

    Complete crap !!!

    I spent 5 hours - formatting, wiping my disk, formatting, installing Windows, all my apps .... on a system with 16 KB clusters (supposedly compatible with defragging and VSS) and including the system volume information folder in the exclude of UD options.

    And did ONLY a boot-time defrag and UD deleted EACH and EVERY of my 16 Restore Point ! Not only that, while it deletes restore points, that means it takes away and deletes all the "Previous Version" of files as well

    Complete crap !!!!! It just wasted my entire time and effort

    It didn't delete "just the most recent points" as claimed - it delete EVERY ONE of them

    Puran never deleted my restore points; nor did O&O or Perfect Disk - so why exactly is UD doing so?

    What is the point of doing a boot-time defrag and allowing your software to DELETE files and system configuration from my system? UGGGggggggggggggggg

    All this work of the past few days gone to waste with UD deleting my restore points and previous file versions !!!!!!!!!!!!!

    DAMNIT :mad:

    What is the point of a program that is destructive or at least not compatible with the whole 16KB cluster issue and VSS ?

    7 minutes to defrag my 3 partitions at boot-time trumps over the many, many hours it took to get my system working again

    Imaging a disk is useless as well since an image and image restoration also destroys all restore points

    What is whole point of defragging and making a product that doesn't work in the big picture of the limitations ? Why have it at all when it destroys my ability to go back to previous versions and so on ?

    Now I have to start all over again and be stuck with once again now simply being unable to defrag my boot files - so why bother having a program that does it if it can't actually be used in a safe and non-destructive manner

    16KB is a waste of time since it still is taken over by programs that can't do their job compatibly

    Can anyone recommend a well-working program that can save my ass with the whole "previous versions" functionality of system restore in Windows that is destroyed by doing such a basic function as defragging ? I've got my 16KB clusters as recommended by MS but wasted by doing a basic system boot time defrag of system files !

    Anyone?
    Last edited: Nov 8, 2010
  25. MerleOne
    Offline

    MerleOne Registered Member

    You could disable once and for all Windows System Restore, which is generally crap, and use an image software such as Drive Snapshot, Macrium Reflect, Keriver Image, Image for Windows, etc. Only so you are certain to recover your system from most things that go wrong.
Thread Status:
Not open for further replies.