Steam + ESET NOD32 Vista 32-bit (not connecting)

Discussion in 'ESET NOD32 Antivirus' started by xbbdc, Sep 6, 2008.

Thread Status:
Not open for further replies.
  1. xbbdc

    xbbdc Registered Member

    Sep 6, 2008
    steam is set to load on startup. it didnt want to connect. i put it in offline mode, connected to a server in tf2 and immediately got the "connection failed" message and would be disconnected in 30 seconds. the way i got it to work is by going into services, and setting "take no action" on the recovery tab for eset kernel. i loaded nod32 back up and able to connect to server fine.

    i used tcpview and noticed ekrn.exe blocking steam.exe from connecting.

    version of nod32: 3.0.642.0
    version of definitions: 3423 (20080906)

    version of steam: built sept 1, 2008 at 12:40:38
    version of steam api: v007
    steam packaged version: 46/649
  2. Eryan

    Eryan Eset Staff Account

    Jan 17, 2008
    Hi, try adjusting the protocol filtering settings for Steam.

    1. From the main program window, press the F5 key to enter the Advanced Setup tree.

    2. Click 'Antivirus and antispyware' -> 'Protocol Filtering'.

    3. From the Advanced Setup tree, click 'Antivirus and antispyware' -> 'Web access protection' -> 'HTTP' -> 'Web browsers' and make sure that Steam is not selected.

    Typically only real web browsers (iexplorer.exe, firefox.exe, etc.) will need to be selected. Let us know if this helps.
Thread Status:
Not open for further replies.